PanX 10.2 b23 issues with Find/Select dialog

I was trying to search/select in a field in one of my databases for the field to contain a certain word and this message appeared:

Internal error in dialog logic.
Field or Variable [dig Trigger] does not exist.

I’m using version 10.2.0.b23 and just downloaded and installed the new bug fix this morning. Does anyone have an idea of how to fix that? I can’t search for what I need since each time I get the same message.

I am getting this error, too, when I enter a search string and click the Find button. When I click the “Error Wizard” button in the error dialog, the error seems to be related to one of the recent fixes: Panorama seems to think that there is no search string entered — although (in my case) there is a search string entered.

same experience here: everything freezes on search

I have discovered (through trial and error) that, if I hit the return key first and then use my mouse to hit the ‘select’ button in the find/select panel the selection I was seeking does appear. However, if I use my mouse and hit the ‘select’ button first, I get the error message I mentioned previously. Weird.


Yes, that matches my early investigations into this. In fact, it appears that any mouse click in the dialog causes an error if text editing is active (blinking i-beam). Apparently one of the minor changes in b23 caused unforseen problems, I am investigating this. It’s possible that the Find/Select dialog is not the only dialog affected.

I have it happening in a procedure that previously worked fine:

Have you tried the b24 release?

No. I was on b23. b24 works fine. Thanks

Downloaded the bug fix and all is well. THANK YOU for the quick turn-around on this! It is much appreciated.

I have two addition errors that are major issues for me.

  1. When I’m removing items from my database, I search using NEW SELECTION pulldown (upper left) then fill in the search box. If I have not set the first search criteria correctly, it used to be that after filling in the data box, I could use the pulldown to find the right criteria (column) to search. Trying that now I get an error message: Internal error in dialog logic. Field or Variable (dlgTrigger) does not exist.

This can be fixed by making sure I have the criteria properly selected before entering the data in the search box, but that hampers the program. Does work though.

  1. More important issue is that I used to create a list of items to remove from the database. Now I can only enter one item at a time, using the instructions above.

Assuming I’ve got my first item identified to remove from the database, I used to be able to change “New Selection” in upper left to “Superset Of Current Selection” and then enter the data for my 2nd search, hit enter and it would add it, so I now have 2 items in my list of items to delete. I often have 20-30 items to delete and this is the easiest method I’ve found, then I would use the “delete” X to remove each one by one.

Now when I try to add a 2nd item I get an error message, even though when searching with “Superset of Current Selection” selected, the note in upper right corner says “2 matches from 53,834 records” and it shows both of the items I want in my list. But entering “select” I get that same error code again (Internal error in dialog logic. Field or Variable (dlgTrigger) does not exist) and no apparent work around. Which means I have delete one item at a time which is not going to work given my use of the database.


Have you upgraded to the b24 release that was uploaded last night?

Sounds like Jim’s latest fix (v. 24) will fix this. But if I understand what you’re trying to do, you might review select reverse and remove unselected.

Yes, did that this morning before attempting my database updates.

No, the latest update didn’t fix this. And not sure what you’re suggesting, sounds like you’re suggesting somehow select everything (53k lines) that are NOT the ones I want to remove? Seems like an odd way to remove specific items. Would prefer that the select items function work properly.

I reinstalled b23 on my computer and was able to duplicate the problems you are describing. But when running b24, everything works fine. I think somehow you are actually running b23, not b24. Maybe you somehow have more than one copy of on your computer? Please make sure that you have only one copy of on your computer, and that it is the b24 release.

MY APOLOGIES! Although I downloaded and updated, for some reason the update didn’t “take”. When I just reopened my file it gave me the update message again and asked if I wanted to install (since I’d already downloaded it) and restart. Did, and all is bliss in my Panorama world again. Thanks!

While I’ve got your ear, did the issue ever get fixed where setting a field to “no duplicates” doesn’t seem to have any effect? No “ding”, no nothing. That was my biggest complaint and still is, but perhaps there’s a fix or workaround now?

From the Panorama X 10.2 public beta FAQ page – Panorama X 10.2 Public Beta Frequently Asked Questions

To learn more about this see the help page.

Panorama X 10.2 is a huge upgrade, it is well worth taking some time to study the release notes.

Not fixed. That feature (enabling “no duplicates” in a field) is there, but it’s not been implemented. Still. Unless I’m missing a trick, enabling No Duplicates still does nothing, there is no warning given (the FAQ says it’s “supposed” to provide a warning). It still does not.

Going to the discussion forums there’s a thread about this that says as of 2020 it still has not been implemented (lots of us needing it) but that was the last post, no update since then.

If I set a field to No Duplicates, and then try to enter a duplicate, I get this.

This feature applies to manual entries that you type or paste in. It does not apply to imports or procedures assigning a value to the field.

I think I know the thread you are referring to, since you participated in it, and that’s not what I am seeing.

Panorama 10.2 is the “next version” that is being referred to.