My file is damaged -Data.Plist- & can't be repaired

For the last few days my DB which I’ve used for years becomes damaged and unusable. A window appears that states file is damaged - Data.plist. I’ve tried using backup copies but they become corrupted too. The program just locks up with the file in question. Is there a way to fix this. Thanks. Dave

If you are using Sonoma 14.4 as your operating system,you may be having the same problem reported in this and a few other recent threads.

Wow. same here!

Running 14.4.1, I just tried to open a PanX file from the Open File dialog I get a “The database is damaged (data.plist)”. If I just the double-click on the file, nothing (visible) happens.

When I click Site License, I get the “Start Free Trail” screen.

If I import a new text file and save it as .pandb it will open in PanX with a double click.

So how do we get things back to good? Wait for 14.4.2?

Check the link above but see my post over there as I had the same thing but was able to fix it all and go back to normal.

Thank you. I was initially concerned because it seemed that the integrity check was tied to specific databases, and I couldn’t turn it off unless I opened the database - which I usedta could, but kan’t now. Searching the Help - I read that the integrity check was also in the advanced Tab.

I turned it off there, opened my previously unavailable databases, and saved. Then I re-logged in my registration.

The registration is fine, but after playing around with the integrity check on/off, now none of the databases will open, regardless of that setting.

Fortunately, I am not in a “production”, or “Mission Critical” environment.

Operating on M2 Mini and OS 14.4.1

This is a new day (the next day) and my registration has again been forgotten - I’m gettng the 7-day trial dialog again.

Let’s hope Apple gets this fixed.

I have the same problem with one heavily used database. damages plist. A couple of others seem to be ok

Also on 14.4.1.

A Mac Studio with an M1 Max.

Perhaps I’ll try time machine effort.


Can you please double check that the setting you un-checked is in the Advanced tab of the Preferences window?

If that option is un-checked, it should be impossible for Panorama to display the corrupted database message - FOR ANY DATABASE. This is a global setting that is for all databases, not individual databases. There is also a setting in the Database Options window that affects only the current database, but that is not what I am talking about.

I don’t think your database is actually damaged. Rather than using Time Machine, I would turn off the Check database integrity when opening & saving option. For now you probably just want to leave that option off permanently - this option didn’t even exist until recently so you should be fine without it.

Thanks Jim,

That fixed the problem.

Best Regards


I have some things to try and report back here and/or directly to ProVUE, but first I need to add a little clarity because issues are getting confused.

In my case, there are three anomalies:

  1. PanX forgets it is registered - manifests by displaying the 7-Day Trial window in About Panorama
  2. PanX doesn’t open a database - gives a “… damaged (data.plist).” window
  3. PanX doesn’t open the database at all. Whether double-clicked or via Open File dialog, no notification is given.

That last anomaly is what I was experiencing at the end of my trials yesterday. It wasn’t that I was getting some “integrity” result, It was that nothing happened at all when I tried to open a db file. Using the Open File, I could select it, and that dialog would show the usual icon, database size, etc. But nothing would happen when I pushed Open.

Though I got the 7-Day Trial window earlier today. Now, without a restart or other effort, it shows correctly registered.

This, from the Help:

By default, Panorama always adds an integrity seal when saving a database. If you don’t want to include an integrity seal in a particular database, use the File>Database Options>General panel to disable this option.

So I wondered how I could do that if I couldn’t open the database.
Then I read further (what a concept) and saw there was a “global” Disable in the Setting Advanced Tab.

As suggested earlier, disabling that allows opening databases - for now.

This sounds like something different than anyone else has reported.

I am not sure that it is “corruption" as such. To me it looks like Panorama is saving the PLIST in a different format (as mentioned in another thread). Maybe something changed in Sonoma 14.4 that when Panorame calls a routine to calculate and save the checksum for each individual file, it is being returned in a different format, as e.g:


vs (the expected format):


I assume that when Panorama retrieves the PLIST, it expects it in the format and when it finds format it assumes it has been corrupted.

Maybe there is a setting when calling the routine where an assumed default has changed in Sonoma 14.4?

I don’t think things like this can just change without there being a reason for it.

On the No File is Opening observation - I thought perhaps the file was opening but the window was somewhere off-screen. But that doesn’t seem to be the case because when the db does open, it’s front and center.

I’ll have to mess around with it and see if I can duplicate the event. It happened as I was repeatedly relaunching PanX and turning the integrity off/on while opening new and previous files.

Note that today - a new day - the 7-day trial window is back - but then it returns to normal registration. So that seems to be a timing issue. Does it need some verification from the outside upon launch? I haven’t been launching it every day. But still, I don’t recall ever seeing this 7-Day Trial window that often in the past.

Same here. This is a total disaster for me. I am on way to managing a convention, and several databases are crucial for that. Can’t get updater to work. Log on screen. Etc. Now I get corrupted file.

HOW do I get this fixed. Has to get done immediately.

Screenshot 2024-04-08 at 1.26.10 PM

How do I recover this? how/why is data.plist damaged?

All was fine until I tried to run your updater. Never again!

There’s a lot of background on this already. See PanX loses its credentials when I quit - #18 by admin.

But today’s Emergency Fix is what you really need: Emergency Fix for macOS 14.4 problems

To be fair to ProVue, this problem is probably a “present” from Apple. It’s not uncommon for a problem to manifest in some app, and everyone using the App thinks it’s the app’s fault. But turns out, that people using other apps are also having problems with the release.

Jim’s latest update was working fine, and if you can return to an Apple OS prior to 14.4, it will probably continue to work fine.

Those who have been on the commercial side for a while, often consider the first public release as “still Beta” and they don’t upgrade until some time as passed and the inevitable “fixes” appear. I have several apps with a version number ending in “.1”, or “.2” because of issues that needed to be addressed after the first release.

Maybe it is something in Panorama. But my experience over the years is often, “the last thing that changed did the deed.” and the last thing that changed was Apple’s update.

1 Like

What you are saying is that you will never update macOS again before you have a critical deadline, right? RIGHT???

This problem was not caused by running the Panorama updater - it was caused by running the macOS updater. The problems you encountered did not occur with macOS 14.3 or earlier versions. The new Panorama release includes fixes in response to unannounced internal changes Apple made to the macOS 14.4 system.

It seems logical that if something is working, and there’s a change after which there’s a problem, the thing that changed usually (but not always) caused the problem.

The latest OS update had caused issues with other software; not just Panorama - my web browser updates for example. We are all subject to the foibles of Apple’s OS.

But it could be worse. We could be subject to the foibles of Windows OS.