Emergency Fix for macOS 14.4 problems

The original emergency post below was written on April 8. We have now succeeded in uploading a notarized copy of the b38 release, so it should be easier for all users to install this update. However, if you are running macOS 14.4, you still cannot use the Check for Updates window to automatically install this update. But when the next update after b38 comes out, you’ll be able to go back to using the automatic update feature (as long as you actually installed b38).

If you’ve already upgraded to b38, you’re all set. Just skip the rest of this post and get on with your lives.

If you haven’t yet upgraded to b38 and you are running macOS 14.4 or later, the simplest way to upgrade will be to manually download the new release from provue.com. Just click on Download Trial and follow the normal instructions (you won’t need the emergency instructions in the original post below). You’ll want to upgrade right away because otherwise you’ll encounter a lot of problems using Panorama (as described below in the original post).

If you haven’t yet upgraded to b38 and you are running macOS 14.3 or earlier, you can use Check for Updates to automatically install the update. No special steps are needed. You don’t absolutely have to update right away, but this new version works fine on all older versions of macOS back to 10.12 Sierra, both Intel and Apple Silicon.

I’ve left the original post on this topic below, for continuity. But most of this original post is no longer necessary. You can still use Check for Updates to install the b38 version using the instructions below, but it’s probably simpler to just download it from provue.com. And the instructions for manually downloading the b38 version are now completely unnecessary.

— Original Post from Monday, April 8, 2024 —

I have good news and less good news.

The good news is that I am nearly certain that I have figured out what is causing the problems with the new macOS 14.4 release. I’ve discovered that macOS 14.4 makes a silent, undocumented internal change that conflicts with an internal component of Panorama. This internal Panorama component has been revised to remove the conflict. I believe this conflict was causing both the (erroneous) data corruption errors and causing Panorama X to lose its registration information every time you launched it (requiring you to enter the email address and password every time you launched it).

The less good news is that when I went to upload the new version of Panorama X with the fix, Apple’s servers refused to notarize the software, with an obscure error message. It’s not clear to me whether this is a temporary problem with Apple’s servers that will be resolved quickly, or possibly a permanent problem that may require a major revision of the tooling used to create Panorama. If the latter, it could take days or weeks to resolve this issue.

Using Check for Updates to install the b38 version

In the meantime, I’ve gone ahead and uploaded an un-notarized version of PanoramaX.app that includes the fixes for macOS 14.4. You should be able to update to this version (b38) using the Check for Updates option in the Panorama X menu. Using Check for Updates bypasses the need for notarization, avoiding the scary dialog described below if you manually download. Unfortunately, however, the internal component conflict also affects the update process, so if you are running macOS 14.4 you’ll need to perform the extra manual steps described here (if you are running macOS 14.3 or earlier, the update process should just work normally without these extra steps):

  • Open the Panorama Software Updates window.
  • Click on the Download Update icon.
  • When the progress indicator shows that the download is finished, Panorama will hang instead of completing the update. You’ll need to force quit Panorama (which you can do by right clicking on the icon in the dock).
  • In the Finder, open the Downloads folder.
  • Double click on the panoramax.zip file to unzip it.
  • Drag the PanoramaX.app folder into the Applications folder, replacing your old copy of Panorama X.
  • Double click PanoramaX.app to launch it. If you are running macOS 14.4 you may need to enter your email address and password one more time, but you shouldn’t have to do it again after that.

Manually Downloading the b38 Version

If for some reason you need to manually download the new b38 version, you can do so using this link. (Update: There seems to be a problem in embedding a link to a .zip file into a forum page. If clicking on the link does not work, right click on it and choose Open Link in New Window.)


If you download manually, you’ll have to go thru a special process the first time you open it. Start by dragging the app into the Applications folder. Then instead of double clicking to launch it, you’ll need to hold down the Control key and click once on the app. Choose Open from the pop-up menu that appears. Then you’ll see this scary looking dialog:

Just press the Open button, and Panorama X will open. You’ll only need to do this once, after the first time you can simply double click on the app icon or on a database to launch Panorama normally.

Because this new b38 version is not yet notarized (so requires the special procedure described above to open the first time) I have not uploaded it to the main provue.com web page. That page still contains the b37 version.

I’m very sorry for the inconvenience of all this, but unfortunately it’s beyond my control. Hopefully this emergency fix will get those of you running 14.4 back up and running normally with Panorama X. Oh by the way, if you have turned off database integrity, you should be able to turn it back on once you install the b38 version.

Jim Rea
President, ProVUE Development

1 Like

I am running Mac 14.4.1 The update for me did not go as you described. I got the dialog saying I needed to update so clicked the button to download. It just downloaded the zip file and did nothing. Just hung there. The progress bar completed but stayed stuck on the update dialog. I had to quit.
I tried again and same result.
I tried then to do manually. I clicked that link but nothing happens.
So unzipped the downloaded zip file and dragged the PanX file into applications.
I tried the control click to open but did not get that scary dialog. It just opened Pan. It is b38. Seems all is ok.

I was about to post much the same. I updated two of my three computers running Sonoma 14.4.1. On both the update downloaded then hung. On both, I had to force quit then drag the downloaded Panorama to Applications replacing the existing copy.

After launching and re-entering my registration, both are up and running. A few hours should tell whether or not the targeted issues are resolved.

Possibly the hang was another Sonoma/Panorama Registration issue and possibly resolved by this update for future updates.

Same with me. I had not noticed the problem because I use Panorama mostly on an older computer, but it seems to work on my M1 Mac.

The same here on my 2019 Intel MBP with Sonoma 14.4.1. The download worked, but did not finish with the installation. I found the download in my Downloads folder, installed Pan X in my Applications folder, went through the Gatekeeper dialog, and now b38 is running well.

Thanks for the tip. I had the same problems, but manually moving the file from Downloads to Application folder fixed it.

1 Like

Apparently the Discourse forum software doesn’t like links to .zip files. I have been able to get the link to work by right clicking on it, then choosing Open Link in New Window. I have updated the original post with this information.

Yes, that’s exactly it, the conflict I found is well placed to cause unfortunate consequences. This makes it even more certain that I have found the cause and fixed it, so that part is good. I have updated the instructions above with the rather more complicated process needed to use Check for Updates if you are already using Sonoma. Later, when b39 becomes available, the update process should work correctly.

I went through the same issue with the having to re-sign in, the file being reported damaged, and then the download not updating, but once I came to the forum and saw the post on manually dragging and replacing the application, my file(s) without any extra tap dancing.
I DID, however, discover an interesting anomaly along the way to getting b38 installed, to whit:
Back in the halcyon days of Pan 6 I had three databases “bundled” as one to open simultaneously, as they were linked in a way that two provided information to the third without having to re-enter it. Once Pan10 came along, that link bundle was broken and I had to open the three separately, until I discovered, no doubt on this forum, that one could be made the “boss” database, and IT would, when opened, automatically open the other two. It was THAT database that would no longer open, and triggered the corrupted warning until I loaded 38b, whereas I could still open the two slave databases with no problem. I didn’t attempt to actually open any data into either of them, as they were useless without the boss, but it was an interesting programming quirk, nonetheless.

Richard Fullerton

I didn’t have to Force Quit. It downloaded and unzipped just fine. I moved it to the Apps folder - both versions are there now. I did have to re-login to get rid of the 7-Day trial.

Life is good.

this version seems to not be able to import from text files, it says file not found
New database from text file. consistently comes up with
fileload(: The file “L4585.txt” couldn’t be opened because there is no such file.
even though it will upload into pan 6, also other files that I have used for years fail in the same way, I havent downgraded to a prior version to check it
this is running mojave.

With OS 14.4.1 and Panorama 10.2.0 (b38) installed, everything seems to be back to normal (database integrity is enabled).

I cannot duplicate this, the New Database from Text File command works perfectly, as does several other import tests I tried.

consistently fails with several files that import to excell or pan6. I can email you the files. I am using mojave which I assume you are not using?
once they are in pan6 they will convert and work with panx

It works fine on Mojave (you are correct that we don’t normally use Mojave, but we do have a computer running Mojave that we can run tests on).

Sure, go ahead, but I can tell you right now that they will work fine.

You indicate that the the error message is “file not found”. That means that Panorama isn’t even seeing the file. Maybe there is a permission error with the folder containing the file that prevents Panorama from reading the file. Try moving the file to the desktop or documents folder and see if that clears up the problem. Also - are you using iCloud Drive? Panorama will not be able to open a file that is not actually on your hard drive, but only in the cloud. In fact, that could cause that exact error, I think.

I have several (single-user) files on iCloud that I use without problems all the time.

While Panorama may work wonderfully for you with iCloud storage, it has been proven to be a problem for others who do not work with their iCloud storage with the exact same parameters. As the user is having problems, it is always best to first try using the program the way it was designed to work. If that works, then the user can try pushing the limits beyond the way Panorama was designed to work, and they can find what their limit is.

When trying to figure out why the computer won’t turn on, first check to see if it is plugged in. The user who knows it was working fine yesterday is typically reluctant to start at the beginning to solve their problem.

Because there have been some posts implying Panorama caused this issue, apparently, some people running OS 14.4.1 can on longer get screenshots by holding down Shift+Cmd+4 (or whatever optional number you are using).

Hey Jim, when are you going to fix that screenshot issue? :grinning: