Sierra macOS upgrade - Panorama 6 not working properly

I’ve read that Panorama 6 has been working fine under Sierra for everyone who has tried updating their OS from El Capitan to Sierra after Panorama 6 was already installed. As it turns out, my system is the exception. I’ve spent at least 8 hours per day for the past three days trying to solve this without any progress so far. Jeff Cook has also jumped in to provide assistance, and we keep hitting dead ends. Following are a few of the many odd symptoms Panorama 6 demonstrates after updating to Sierra:

  1. On launch after upgrade, Panorama puts up the New Database Wizard, but instead of having just one new field to enter, it has many blank ones stacked on top of each other. Panorama is frozen. Clicking CMD-Period will unfreeze it. If you then try typing into one of the blank fields, the following error is displayed: “Field or variable does not exist: newDatabaseSpec”

  2. If you select “Preferences” from the Panorama drop-down in the menubar, a grid of 9 preference panels is displayed, but instead of the normal icons which fill each panel, each just shows a wrench and screwdriver.

  3. If I launch Panorama 6 by double-clicking an existing Database, the Menubar shows only “Panorama/File/Wizards” at the top like it normally does when Panorama first launches, then the double-clicked Database data sheet is displayed, but this is when things go wrong: next the Menubar should change to display all the options for that database like “Records/Field/Setup” etc. Instead, the Menubar still only shows “Panorama/File/Wizards”.

  4. After following the steps above to open a database, if I click over to another program or to the Finder, then click back on the opened Database data sheet window (or click the Panorama icon in the dock), the database comes back up but then all the menubar fields appear correctly as they should have originally. It also appears things might be operating “somewhat” normally at that point, but I wouldn’t trust it since there are so many other issues happening. Even at that point if I select the menu Panorama/Preferences, for example, the preference panes do not show their proper icons.

  5. Once Panorama 6 is running, if I go to another program, pressing CMD-Tab to get back to Panorama does not work. It stays on the current program, doesn’t switch to Panorama as it should. Selecting the Panorama icon in the dock, however, will bring me back to Panorama.

Background: The machine I am upgrading is a 12" MacBook which was purchased about two months ago with El Capitan. I’ve installed BBEdit, VMWare Fusion, Adobe Creative Cloud Photoshop, and a few other common programs. All are the very latest versions. I haven’t installed any unusual utilities or system enhancements.

Sierra version: 10.12.1

Things we’ve tried.

  1. I’ve downgraded back to my backup and tried upgrading to Sierra four separate times now. Each time, Panorama 6 fails in the same ways described above.

  2. I’ve deleted the preferences folder which Panorama stores in ~/Library/Applications Support several times. No change.

  3. I’ve done several clean installs of Panorama 6.0.0 trying both build 94356 as well as build 121629. No change.

  4. I’ve tried doing a “safe” boot. All this did was cause even more problems, with “font” errors popped up in Panorama indicating missing fonts.

  5. I’ve tried creating a new user. Same issues under a new user or a guest user.

  6. I’ve tried fixing permissions by updating permissions for both the Panorama Application folder as well as the Panorama folder in Applications Support to be as universal as possible, giving Read/Write permissions to all users and Admin.

Stumped. Any suggestions of what we can try next?


  • Jeff

Well, this is a very relative description. What is a usual utility and what is an unusual one?

And what if a third party app that has been working well for years, suddenly is incompatible with the recent system update and prevents lots of other apps (Apple apps as well as third party apps) from launching successfully?

This has happened recently with One Periodics’s firewall software Hands Off! and macOS 10.12.1. A discussion in the Apple Community forum detected it as culprit, and the developer was able to provide a compatible version (3.1.2) after about a week.

Don’t know if that helps in your case …

Testing your issues, I cannot duplicate any of them. The only thing that is wrong is that I am getting a “Cannot Compile Procedure” error if I try to open the Preferences. Build 121508.

Not using Hands Off and in our case, I mean we haven’t added any system level extensions that would be operating while Panorama is operating, at least nothing I’ve added knowingly.

I just installed Sierra macOS this morning and I am seeing the exact same results as Jeff when using the 121629 version of Panorama 6. I have an older version of Panorama 90251 that starts automatically at startup and displays a running clock at the bottom of each of my screens in rather large type to grab my attention. This version seems to be behaving itself normally with none of the problems exhibited by the newer version.

I run a fairly simple system with only PopChar, TypeIt4Me and USB-Overdrive added to the mix. My machine is a iMac (21.5-inch, Late 2009) with 8 GB memory with an additional 19" monitor to the side. I use an older Kensington track ball and that is handled by the USB-Overdrive extension. Installing the new OS took forever but did not show any problems except to tell me the Growl software was incompatible and would not load.

Other than my screen clock running in the background which is operating just fine at the moment, I don’t use Panorama 6 anymore except to test things that come up on the forum

Since Gary is having the same issue could it be that the current full download of Sierra 10.12.1 (mine also says 16B2657 next to it, whatever that means), maybe Sierra 10.12.1 is the culprit?

Is anyone successfully running Panorama 6 under 10.12.1?

Any developers on here who have tried running Panorama 6 under the developer Beta 10.12.2? I think it is coming out for public beta later this week.

Best wishes,

  • Jeff

That must be a very new build. The first indication I have of any Panorama X users running that build is today. Apparently there have been at least 7 10.12.1 builds so far. So perhaps Apple has broken Carbon in this build. If so, we’ll have to hope that they fix it ASAP.

I am using it under macOS 10.12.1 (16B2555) without any issues.

Just to be more exact, Preferences opens under the Wizards menu, but not under the Panorama menu on my machine.

Yep, that’s the version I just installed this morning.

I’m running 10.12.1 (16B2555) (as reported by About this Mac, System Information, System Software Overview)

I run Pano 6 almost the entire 16 hours of my workday. The reliability is nothing different from prior to Sierra.

Robert Ameeti
(949) 422-6866

I always keep a backup of my Apple OS builds prior to my installations and as such I would guess that I have 16B2555 in storage.

Robert Ameeti

I just upgraded to 10.12.2 Beta (build 16C32f). Unfortunately, this does not fix any of the issues.

It seems this must be caused by a bug introduced in Sierra somewhere between 10.12.1 (build 16B2555) and 10.12.1 (build 16B2657).

  • Jeff

I suggest those who may be affected by this issue report the bug to Apple. Search your Mac for an application called “Feedback Assistant” and a bug reporting form pops up you can use to report this. I imagine the more reports, the more likely Apple is to prioritize this issue.

I’ve turned off my System Preferences/App Store/

Automatically Install macOS updates and also the
Install system data files and security updates.

Robert Ameeti

I wrote earlier that the older version of Panorama seemed to work OK in this latest Sierra OS but it also has now show significant problems as well. When I tried to enter data in my old checkbook file I soon got a message warning of corrupted data and shortly afterwards it crashed. It will be important to see if others besides Jeff and myself are seeing the same problems with the latest release version.

It seems you have to be a registered beta tester to use this method to report a problem. It would not allow me to file a report.

Gary, I believe you said that you’d moved on beyond the build 16B2555. Would you like to see if it works with an earlier build of Sierra than you currently have?

Robert Ameeti
(949) 422-6866

I think I’ll stay with the newest version even with the Pan 6 problems. I always hold my breath every time I change my system software. In the past I had some problems upgrading and restarting (none recently thank goodness) so I’m still reluctant to mess with changes unless I have to do so. I have migrated everything to Pan X already so I can live with the Pan 6 problems.

Well, I tried reporting this bug all day using Feedback Assistant, which I could do since I was using a developer release. Unfortunately, due to a bug in Feedback Assistant itself, it kept crashing about 3/4 of the way through trying to send the bug report. So, so far, I haven’t been able to report it. Hopefully Apple finds and fixes this through some other means, or someone else on this forum who has a developer release can report it.