Revert to Browse all versions doesn't seem to work

I tried to go back a few saves to get an earlier version of a file and when I went to Revert to Browse all versions Pan X would crash. So I opened Custom Button Generator thinking that would be a better file to test and the Revert to Browse all versions pops up, but when I use the arrow keys to look at previous versions, or try to see previous versions the browse view disappears behind the open file. Has anyone else seen this issue?

Since no one has answered this, I suppose I am being a dummy and don’t know what I am doing? :wink:

Don’t suppose that, I am seeing the same behavior. In fact, it is not possible to browse the older versions. When you click an older version, the Time Machine UI disappears and the actual version remains unchanged.

So, does that mean something is not working properly. I thought in watching Jim’s videos, you could go through older versions?

Thanks for responding, at least I feel a little better about my mental state…

I thought I was seeing something like this quite a long time ago, well before the latest revisions. You can likely find it back in BitBucket, along with a response from Jim.

There should not be any problem in the recent releases, since these commands were moved into a separate submenu. I just tried it right now, in fact, I actually needed it, and it worked just fine. I was able to go back and get a version that I had saved a couple of hours ago.

Are you clicking the Restore button?

Personally, I think the UI for this is kind of confusing, but I have no control over that. Panorama calls an Apple API to start the process, then Panorama loses complete control over the computer until you press Done (which is really cancel) or Restore.

Ok, so I go and enter the Time Machine and multiple images of the database appear. I click on an an image of an older database (I think) and hit restore and up pops the database. Now, I am almost positive I tried this yesterday prior to my posting, so I am not sure how it now works and it did not yesterday. Thanks for checking this out, as this is quite helpful.

Well, the behavior seems to depend on if the database is saved with one or with many windows open.

The Time Machine UI works perfectly for me in a database with only one open window.

In a database with 3 windows open, the UI picked the backmost window (a procedure window I had forgotten it was open), and browsing through the versions instantly crashed Panorama.

Thank you. You are quite the Sherlock Holmes in finding these bugs. I am guessing that is what happened when I first ran into this issue, as I was working on some procedures, so there were a few windows open. When I did the last test, only the data sheet was open.

I am having the same problem with version 0.9.002 (2495). I have a screen recording to show what happens if there is somewhere I can send it. Never get to a point where I can restore, as soon as I click to move back in time it crashes.

I just experienced the same problem.
Running 0.9.006 I needed to revert to a file from about an hour ago. Selected Revert To —> Browse All Versions.
Time-Machine style window opens with the current version on the left and old versions tiled to the right. When I select a previous version PanX crashes.
I just updated to 0.9.007 and am having the same issues.
Any suggestions?

Earlier in this thread, some users suggested that they had better luck when only the data sheet was open. I don’t have any suggestions other than that.

@admin Thank you for pointing that out.
Tried that. It worked the first time, but on subsequent attempts that crashes resumed.

Fortunately I’d saved and earlier version of my work as a different file and was able to use a lookup to grab the data I’d lost w the crash.

I just screen recorded the crashing of the Browse All Version time machine UI. Linked to here…

Browse All Versions Crash

That was the only data sheet I had open. (Note: I do have 2 monitors running. The open sheet and the versioning UI were on the same monitor.)

When I first read this thread, I was having no luck with the “Browse all versions” option. It was not feasible for me to have no forms open, so I just used the frequent saving of copies of the file recommended elsewhere in the forum. At that time, however, “Revert to saved” was working fine. However, “Revert to saved” is not doing anything for me (for at least the last few days, probably longer), which is a pest, since when I’m trialling a change in a programme I run it, planning to revert if everything goes haywire, (as it often does!!!)

Just wanting to document the bug.

I’m experiencing the same issue – Panorama X crashes when I hit the restore button. It also crashes when I try to close every open form. Most will close, but there’s one which causes a crash as soon as it comes to the front – hence my need to revert to an earlier version.

This is a major problem for me – the database I can’t use or revert contains the major data I use in my daily work (not to mention hours of form design etc). Is there a way to get to an earlier version without using this clunky revert procedure?

Please, please, please, Jim, if you read this, contact me – I’m a user rather than a developer, and my missing data is my lifeline. I have a 5-year licence with four and a half years to go, which currently looks like the worst investment I’ve ever made.

  1. You can use TimeMachine — even when you have no external TimeMachine volume attached. Some backups should be saved locally.
    (But do you know for sure that the conflicting form was the last change you have made, and when that change was made?)

  2. If you know a certain form is the culprit, you can use the View Organizer from the View menu to delete that form from the database.

No. This is not a Panorama feature, it is an Apple feature. If you think it is clunky, you’ll need to get in touch with them. The Panorama code simply has ONE line of code that invokes that “time machine” interface, then Apple takes over and we have no control until you close that interface.

There is a developer, Howard Oakley, that has a bunch of free utilities for working with the Mac. You can find them here:

There is one in particular I’ve been meaning to check out, called Revisionist. It promises to make the version history of any document accessible, if that document was created with an application that uses Apple’s standard document handling. I just tried it with a Panorama X, and it works. When you open the database in Revisionist, it shows all of the versions that have been saved. If you press the Archive button, it will create a folder and fill it with separate databases for each version. You can then go back and open the one you want.

The user interface for Revisionist is a bit spare, but it does include some documentation. So this does provide an alternate way to get at previously saved versions of a database. Mr. Oakley also has a bunch of information about Apple’s version system both in the documentation, and in his blog (which I have been following for quite a while).

Thanks, Kurt.

Suggestion 1 will solve it (and I should have thought of it despite the cold sweat I was breaking into). I’ve got the database stored on Dropbox and that saves multiple versions.

I’d already tried suggestion 2, but deleting the form caused a crash as well.

Really appreciate you taking the trouble to answer – I can move away from the computer and relax now.



Thanks, Jim.

In my mad panic I’d totally overlooked the fact that my database is saved to Dropbox – Kurt J Meyer was kind enough to prompt me to recall the fact. I’ve managed to get back to a situation where all I’ve lost is a few hours.

Many thanks for your suggestions, which I will look at in more detail and apologies for getting so upset – I was paranoid that I was going to miss a deadline through being unable to access my prompt list.

Very best,