Pano X image display problem, why?

Hi, all,

After years of functioning faultlessly I suddenly have a problem with a Pano X database and I am not able to detect the reason why. Maybe other eyes will see something I don’t.

Basics: Mac Mini (Mid 2011), OSX 10.13.6 (the last one this model accepts).

My database is for photos with the pertinent technical and subject data and each record contains a jpg of the photo. Each record is about only one photo, which has a unique number distinguishing it from others. This unique number consists of:

TP (Type or Format) = is empty in the case of 35mm film
R-NO (Archive number) = consecutive number given to each exposure
ES = error correction number (in the case of erroneous R-Nos). Empty when no error.
.YR = last 2 digits of the year when shot was taken

The unique number thus consists of: +TP+«R-NO»+ES+YR in 4 separate fields

This database is set up new for every calendar year resulting in a few hundred to several thousand records each. A folder

YYYY thumbs ƒ

holding the jpgs is accompanying every Pano X database. This whole package is within a yearly folder

Photo. YY ƒ .

Now to my problem:

In the folder Photo.71 ƒ there are 2 consecutive records 747.71 and 748.71 with the same subject (a chapel) taken within a few minutes from each other. When clicked on they came up with their respective jpgs with no problem at all.

Then, I decided to put a slightly larger scan into the jpg folder. This also worked without problems in all cases but for these 2 records: 747.71 shows the bigger jpg, 748.71 doesn’t show any image at all.

The procedure to call up the image is:

In the “BigPix” view of the record in Data Mode clicking on the image area to activate it, there is the following formula:

“1971 thumbs ƒ/”+TP+«R-NO»+ES+YR

This brings up the jpg scan in the record 747.71 and nothing at all in the record 748.71. As you will see the “fishing” formula doesn’t have the particular record’s number but grabs the pertinent parts of the unique number (see above) when the record is open.

This has me totally baffled, I can not find an explanation. Anybody to give it a try?

With the problem record active, I would suggest that you open the Formula Workshop and enter that formula into it. Carefully compare the result of the formula to the name of the image file.

Hello Dave,
your answer was a stroke of genius: the formula in each of the 2 records looked EXACTLY the same to me. When I entered the one from the problem record into the Formula Workshop, as suggested by you, it said, that “Field or Variable [TP] does not exist”.
Of course, thought I, it doesn’t exist in the correct record either, since in 35mm shots in my DB system it is empty. But then why does one record show the jpg, the other not?
In my desperation I copy-pasted the TP field from a good record to the TP field of the bad one and, voilá, the jpg suddenly appeared.
So I have learnt an important lesson: the difference in Pano X between an empty and a non-existing field when both have nothing in them and look the same. Digital VooDoo! But thanks a lot!

I think the field wasn’t really empty. It probably had a space in it, so it looked empty.

There are several ways to get around this. One would be to use the strip( function in your formula


Another technique would be to use the Strip Surrounding Blanks method in the Morph Field Dialog.

The Strip Surrounding Blanks method is described on this page:

I think you had a separate problem when you tried the Formula Workshop. I think maybe you didn’t have your database selected in the Formula Workshop’s pop-up menu in the upper right. Since TP was the first field in the formula, you would get an error that the field didn’t exist since you were using the wrong database. A field is a field – it is always defined whether it has a value in it or not. There’s no voodoo.

For anyone reading this in the future, sometimes what I like to do to debug this sort of problem is create a temporary Text Display object with the formula. Then I can easily see the formula result as I move from record to record. Once I get the formula debugged, I copy the formula back to the Image Display object and then delete the Text Display object.

If you want to know if a cell contains invisible characters, I recommend Gary Yonaites’ “Reveal Invisible Text” from the Database Exchange (in the Panorama X Help menu).

Hello Jim,

Thanks for the analysis. Retracing my steps in Formula Workshop, you are right, I didn’t enter the DB name in the upper right corner. But the problem is solved now, one which has never happened in the last 8 or so years until now and from now on, if I am still alive when it happens next, I’ll know what to look for.

Thanks for all the help from this illustrious group.

If you open the Formula Workshop with your database already open and on top, the database name will be pre-set for you. You must have had some other database active at that moment.

Glad the problem is resolved.

2 posts were split to a new topic: Moving Panorama X to a New Machine