Dialog program error when searching

I can’t do a FInd/Select in Pan X. I get an error message and I can’t escape it, I have to force quit Pan X to recover!

If you ever get an error like this in ANY dialog, you should be able to press the Ok button to dismiss the alert, then press the ESC key to force the dialog to close.

If you keep getting this problem every time you open the Find/Select dialog, your Panorama preferences may have gotten corrupted somehow. There is no way to uncorrupt them, but they can be deleted using these steps.

• If it is open, Quit from Panorama X
• Open a new window in the Finder
• Choose “Go To Folder” from the “Go” menu
• Enter ~/Library/Preferences/ and press the “Go” button
• Find the file “com.provue.PanoramaX.plist” and move it to the trash
• Relauch Panorama X (this will automatically create new, default preferences)
• Log into your Panorama account

If you’ve set up any options in the Panorama X preferences window, you will need to set them up again.

Sorry no luck. I did all that and still I have

the error where I have to force quit. WTH is wrong? Pan X is a lot of work and a lot of reprograming. I’m reallyt tiored of it buyt I have no choice I guess.

1 Like

You DO NOT have to force quit. From the where that screen shot is, press the OK button to close the alert, then press the ESC key. That will close the dialog without having to force quit.

WTH is wrong?

Does this happen with just this database, or any database? How about a brand new empty database?

Hi Jim, OK so with a new database I still get the error but the OK-ESC does work. With a converted database ESC will not work and I have to force quit.

I don’t really have any further ideas on this, other than clearing out preferences as I described above. I notice that you reported the exact same problem 3 years ago.

What version of macOS are you running? Is it the same one you were using 3 years ago? Is it the same computer? Do you have another computer you could try? If that’s not possible, I would suggest setting up a new user account on your computer and test on that (it’s easy to delete the account again once the test is finished).

No this is a brand new MacBook Pro running Mohave. What happened back then was pulling up a Sort Dialog, I just tested it and it shows the error but is NOT escapapble by Cancel/ESC. I’ll try the new account and report back.

Thanks for posting this Leo, it’s very good to know this before I buy Pan x.

Personally I wouldn’t look at the results of a couple of users as a reason to buy or not to buy the program. For the vast majority of us Panorama X has been functioning very well in a lot of advanced applications. I depend heavily on its reliable performance and have found it to be a very worthwhile purchase.

I just finished converting someone’s Panorama 6 files to Panorama X and it was very quick. Most of their existing procedures ran without any changes. A few had some minor adjustments and that was it.

@LeoC2, I noticed your screen shots show the cell in the sort and search windows has handles on it, as if the cell has been selected in Graphics Mode:

That’s odd and I can’t find a way to get mine to do that. It should look like this:

Are you doing the sort and the search from a procedure, or simply using the regular menu choice? If from a procedure I have to wonder what precedes it?


I believe that depends largely on the complexity of the Pan 6 files. The more complex, the more difficult the conversion. Also bad programming in Pan 6 leads to more to do in Pan X.

I saw this too and found it to be curious. No it occurs from a menu or Command-F choice. I haven’t reid it from a procedure but I’ll test it tonight.

I suspect that this is a big clue about your issue. Something ain’t right.

Ya think? LOL! This has been since the day I first tried Pan X (3 yrs maybe?) and the problem has never been solved. This as well as when it happens under some SORT conditions is a serious problem and basically renders Pan X useless to me. Very frustrated.

Jim. I set up a new user account and ran Pan X. Lo and behold the problem and error went away. Any thoughts on what I need to do next?

That’s great.news. So this means that the problem is one of the Panorama related files in the Library folder. You want to delete this file


And also delete this folder

~/Library/Application Support/PanoramaX

I’ve posted detailed instructions for doing earlier on this thread and on another recent thread. I think you said this didn’t work before, but if creating a new account works, this HAS to work. Maybe try rebooting the computer after deleting these items to make sure everything is flushed from any caches.

I did as you say and no help, I still have the same error message after reboot! Very frustrating!

ps: the error also occurs opening the Find/Select dialog from a procedure

That may mean that you have a conflict with one of your log-in items. Turn them all off in the Users & Groups pane and see if that helps. Then add them in one by one.

That might include LaunchAgents as well.

Only LaunchAgents for that user.

You can open Activity Monitor and look up what is running in the bad account and not in the other.