"Could not open [DB] on [Server

I just shared a DB to my server. The notifications are as follows:

PanoramaX 10.2:Uploading [db] to Bill’s Panorama X Server
Panorama Server: Opening connection to Bill’s Panorama X Server
Panorama Server: Opening [db] on Bill’s Panorama X Server
Could not open [db] on Bill’s Panorama X Server: Database “/Users/williamconable/Library/Application Support/PanoramaX/Server/Public Databases/Alex Mail.panserverdb/Alex Mail.pandb” does not exist

True enough. Looking in that folder, Alex Mail.panserverdb does exist, but Alex Mail.panserverdb/Alex Mail.pandb does not.

Also, when I quit PanX, restart and open the db Alex Mail, which has supposedly been shared to the above server, I get the same “Could not open” notification.
Can someone help?

I think files are sometimes said to not exist when the actual problem is a permissions issue.

Thanks, Dave, but I’m afraid that’s not it. I made the permissions r/w for everyone, with no success.

On a different computer, I opened the Server Admin panel, saw the problem db listed as existing on the server, tried to download it, and got the message “Can not download [filename].”

And none of this yet addresses the issue of the last line in the above chain of notifications: PanX seems to be looking for a genuinely non-existent DB: Alex Mail.panserverdb/Alex Mail.pandb.

Assuming that you have direct access to the server computer, take a look in the Public Databases folder: /Users/billconable/Library/Application Support/PanoramaX/Server. There should be NO file names ending in .pandb as your error message is suggesting.

Otherwise, I’d be inclined to delete and reshare the file. Try deleting first through Server Administration and if that fails do it yourself.

When you reshare, be sure that you don’t inadvertently paste or enter something extra in the Server Database Name.

Right. There is no DB in the public databases folder that ends in .pandb.
I deleted the file and reshared it. It is now present in the public db’s folder with the correct suffix. But again I got
Could not open [db] on Bill’s Panorama X Server : Database “/Users/williamconable/Library/Application Support/PanoramaX/Server/Public Databases/Alex Mail.panserverdb/Alex Mail.pandb” does not exist

For some reason Pan is looking for a DB that does not and should not exist.

And again I was told on my second computer that I could not download the file, though it does show up as an existing file on the server admin panel in that second computer.

Another DB that I shared some time ago works perfectly.

This is a random question, but the problem db has a space in its name: Alex Mail. The working one doesn’t. Could that be an issue? I’m going to fool around with some other DB’s with and without spaces and if anything interesting happens I’ll report.

Well who’d have thought? When I renamed the DB in question without spaces in its name (Alex Mail → AlexMail). It shared without a whimper and is behaving quite normally. So apparently that space was confusing PanX.

I’m glad you solved your immediate problem, but Panorama Server is perfectly fine with database names that include spaces.

You are wrong about the should not part. Not only should this database exist, it must exist.

The .panserverdb files inside the Public Database folder are packages. This means they are folders, but the contents of the folder are hidden and you can’t normally see inside them, at least when using the Finder. In fact, the only way to see inside is to use right click on the file and choose Show Package Contents.

Here is the Public Databases folder on my test computer. As you can see, there are many databases that have spaces in the name. If I pick one of them, right click on it and choose Show Package Contents, I can see that there is a .pandb file inside the .panserverdb package.

This .pandb file inside the .panserverdb package is what the error message is telling you is missing. I don’t know why this happened, perhaps some sort of permissions error as Dave theorized. I have not heard of this symptom before, especially now that you have discovered that it works ok if there is no space in the name.

Note that the permission problem could be on YOUR computer, not the server. The .panserverdb file is created on the client computer and then uploaded to the server. Are you using a different client computer than you used to upload your earlier shared databases?

And we’re back to not working again. I deleted all my DBs from the server with the idea that I wanted to get the whole suite correctly functioning before I put it on the server.
I uploaded the main file (AlexMail). I immediately got the error message and when I checked the package on the server, it did not in fact contain the pandb file, just info.cfg and status.cfg. Why isn’t the whole package being uploaded?
And the same thing happened with another file. Permissions do not seem to be funky as far as I can tell from Get Info.
This is weird.
I am not using a different computer than before to upload the dbs; they’re all created on my desktop and being uploaded to a server that is a MacBook Pro and is not used for anything else.

And by the way, nothing is stored in the cloud. The main DB’s are all on an external HD and work just fine when not shared.

I’ve just thought of more data that may be relevant. When the whole thing did work, it took several tries to get the db downloaded from the server to a second client computer. Several times it went half-way and stalled. Finally it did fully download. This time when I was uploading to the server it went suspiciously fast; the DB in question is 1.4 MB, but since only the .cfg files were being transferred it didn’t take any time at all.
So this makes me wonder sadly whether there’s something wrong with the machine I’m using as a server. It’s a MB Pro that was retired because it was sometimes behaving strangely. So perhaps it’s just that the machine itself is funky and not connecting reliably to the local network? (I’m doing all this completely in house at present.)

It’s probably not being created correctly on the client in the first place.

The first step Panorama takes in the upload process is to create the server database in this folder on the client computer:

~/Library/Application Support/PanoramaX/Client/TempTransfer

If there is a permission problem, it is probably with that folder itself (or one of its parent folders). I would suggest deleting that folder, then re-creating it.

If that doesn’t work, probably the next step would be to try deleting the entire Panorama X folder within the Application Support folder. Do that with Panorama not running. Then the next time Panorama starts up again, it will create a new empty Application Support folder.

Sorry that this is getting more and more difficult. To test the premise that there was something mechanically wrong with the computer which I was using for my PanX server, I shut that down and installed the server on another computer entirely. It seemed to be ok, but then I once again was not able to load a file onto the new server. And to add to the confusion, there is no PanoramaX folder in the Application Support folder on this other computer! Restarting Panorama doesn’t have any effect. I did delete the Panorama X folder from App Support on my main desktop, and it got recreated when I started up, but that didn’t make any difference.

Am I at a point where I need to install new versions of Panorama on my computers? This is very frustrating, I’ve been a semi-advanced Panorama user from way way back and have never found my shoelaces tied to each other to such an extent as this.

I find it hard to believe that there are permission problems; every file I look at is set for me to be able to read and write and staff and everyone to read only. Almost every file on my computer is set like that and it has never given me any problems.

I tried to upload a file to the server once again and got the notification Database “Alex Workshop.panserverdb” does not exist. Ditto when I tried to delete it from the server (because of course). The Temp transfer folder on the client computer from which I’m trying to upload the DB stays empty. Nothing is being created in there. So what you (Jim) said in your last post is correct.

That hasn’t been my premise. I think there is something wrong with the computer you are uploading the database from. I would suggest you try uploading from a different computer. You can upload from the same computer you are running the server on if that’s the only one available.

That folder is normally empty. Once Panorama has finished uploading a file, it will delete it from that temporary folder.

Hopefully by the time you read this you’ll have gotten a good night’s sleep and you’ll have a fresh new perspective.

Two points:

  • Directories can also have incorrect permissions, and that can affect every file in the directory, including in nested folders. So just because you look at a file and the permissions look correct, doesn’t mean things are ok.
  • In addition to the basic permissions you can see with Get Info, a file or folder can also have an advanced type of permissions called ACL (Access Control List) that is much more difficult to work with or even see. I don’t even want to talk about those! (and I’m not really qualified to say much about them either).

Installing Panorama is super easy. I don’t think that will help, but it’s really not a last resort measure – it’s so easy to do that you might as well try it. But I would concentrate on the client computer, not the server computer.

Another longshot possibility, your Panorama preferences may have gotten corrupted somehow. There is no way to uncorrupt them, but they can be deleted using these easy steps.

• If it is open, Quit from Panorama X
• Open a new window in the Finder
• Choose “Go To Folder” from the “Go” menu
• Enter ~/Library/Preferences/ and press the “Go” button
• Find the file “com.provue.PanoramaX.plist” and move it to the trash
• Relauch Panorama X (this will automatically create new, default preferences)
• Log into your Panorama account

If you’ve set up any options in the Panorama X preferences window, you will need to set them up again.

I set up a new server on my good laptop. I was able to share a couple of db’s on it successfully. (NB: I cannot find a PanoramaX folder in the Application Support folder on that computer.) I tried to share another db to it and got this:

When I close the dialog, the whole Database Options panel closes. (Obviously.)

I also transferred a standalone version of my main file over to the laptop and tried to upload it to the server. It seemed to be successful, but on the server admin panel that db appears but is said to have a size of 0 bytes.

I’d say there is something wrong with that DB (yuck, it’s my main db), but then there’s this other problem (the first one in this post).
See you in a couple of hours…

If possible please send me a standalone version of your file (compress it into a zip) and I will see if it can be uploaded to a server here.

I tried something else that seems to have succeeded. I recovered a backup of the crucial DB and downloaded it in a sequestered place. I went to share it and voila! it shared with no apparent problem. This leads me to believe that something funky crept into the latest versions of that DB that interfered with sharing. I will now update it with recent data and set up relations to other dbs etc. and see how it goes.

And yet again the problem. I have successfully shared 3 DB’s. I just tried to share a 4th and 5th. The 4th didn’t share successfully; I don’t think there was a notification, it just hung, and it’s a small db. Then I tried a 5th one and got the familiar “Database “/Users/williamconable/Library/Application Support/PanoramaX/Server/Public Databases/ImatOnline.panserverdb/ImatOnline.pandb” does not exist” notification.
But this time I looked in the TempTransfer folder and there I see the name of the 4th db I unsuccessfully tried to share. It had a size of 0 bytes. I dragged that to the trash and tried to share ImatOnline (the 5th one) again, but immediately got that same does not exist notification.

I am grateful for the 3 I do have but would like to also share the other 2. Once I have some coffee and decompress, I’ll try sharing earlier versions of the 2 problem files and see what happens. The fact that I successfully shared 3 seems to indicate that it’s not a permissions problem, right? To be sure, I checked and they’re the usual me rw, the other 2 r only.

Considering the number of files I’ve uploaded for sharing and web publishing - and on a few servers - I have to wonder if you have a network issue or some other external interference.

I’ve uploaded and updated generations, modified procedures and forms,… issues have been pretty rare and usually easily resolved. Some recent issues were resolved by running OS X Cocktail.

Maybe just running both client and server in Safe Mode will give some better results.

Good news (I think), I was able to upload your database to my server with no problem. Here’s a screenshot of the package contents of the server database in the Public Databases folder.

So it would appear that the database isn’t the problem.

Sorry for the late reply, I wrote this post last night but apparently went to bed without posting it.

Not solved yet. I deleted PanX preferences. I cleaned up all the permissions with Cocktail. I started both computers in safe mode.

I keep being told that Database “ImatOnline.panserverdb” does not exist. I’m told this when I try to share the DB, when I unshare it, and when I try to delete and detach it as well. (These notifications also appear in the Daily Sharing Errors log, as I would have expected.)
There are 4 databases I have been able to share successfully, and they can all be opened, synchronized, etc. It’s just this last one now that I still can’t share (or unshare, or anything else.)

Wait a minute: I just looked at the Temp Transfer folder, and there is a file in there named ImatOnline.panserverdb with a size of 0 bytes. I threw it away, and then, going back through Jim’s suggestions above I deleted the Temp Transfer folder, and then the whole PanoramaX folder in App support. Nothing changed, and the DB options panel in the DB in question still thinks the file is shared.

I guess I could get rid of that file entirely and copy a backup version over and start from scratch with that. I’ll try it later.

Any further suggestions would be appreciated.

Yes, please try that.

Another thing you could try is renaming the file. Maybe there is something leftover on your system with that name.