Convert Pan 6 Database to Pan X hangs

Currently trying the Pan X trial and converting some Pan 6 databases to Pan X and I copied a Pan 6 database, called People Farms to a laptop where the Pan X trial is being used. Once copied to the Panorama folder (Pan X), renamed the database to People Farms.pan and then attempt to open the db in Pan X and all that happens in the little spinning rainbow appears and the db never does open. The rainbow just spins and spins.
Have converted several other Pan 6 databases into Pan X databases with the trial with no issues. But this one db never opens and it just spins and spins until I finally issue a Force Quit on Pan X. The database is only 24 MB in size. I have no idea why Pan X is having an issue in trying to open this Pan 6 db. I’ve tried this several times but in each instance the db never opens, Pan X just spins and spins until Force Quit is issued.
How can I determine what the issue might be with Pan X in trying to open this Pan 6 database? Any suggestions or ideas would be appreciated?


Some (older?) Panorama databases need to be re-saved in Pan 6 first.

I’m not sure what you mean when you state it must be re-saved in Pan 6. Do you mean open the db in Pan 6 (the db as it exists in Pan 6 without the .pan extension) or once the .pan extension has been added, then save it in Pan 6 before then trying to convert to Pan X with the .pandb extension?
Right now anything to do with the Pan X trial is in a separate folder from the production Pan 6 databases. Thanks.

If the database was originally created by Panorama 5.5 or earlier, and you haven’t made any changes to its data or design using Panorama 6, then it might still be in the Power PC format, which Panorama 6 can open, but Panorama X cannot. If you open it with Panorama 6, and then save, it will be saved in the Intel format which Panorama X can open.

I think the file may have been corrupted a long time ago. I have a copy of that file and saving it in Pan 6 did not allow it to open. The first time I tried to open it I received a message that it did not contain a valid Panorama 6 database. I opened it in 6 and saved it but I still got the beach ball when I tried to open it in X. So, I exported the database to a text file and found that there were about 50 extra fields with spurious names in the export that are not visible in the Panorama 6 database. I recreated the Pan 6 database by making a new database, importing the text export, deleting the extra fields, then ran a procedure to replace the field names with the field names in the first record. I saved it and it opened in Pan x with no problem.

Thanks for your feedbacks. I can’t say when the database was created as it was long before I ever became involved at the office, but will ask the person that would/should know. Since they still have Pan 3 manuals it could very well have been back then.
I’m pretty sure the database is used frequently so it should have been saved my times, but opening it and saving it again (or doing a Save Ass) is something I can certainly do. If that fails I may have to do what JeffK stated and try and export the database to a text file. Thanks again for your responses.

The Save of the People Farms database in Pan 6 did not resolve the issue, it still hangs when trying to open with Pan X. So the next step would be as JeffK suggests, export to a text file. And since JeffK has a copy of People Farms, I asked the owner, and you likely know who it is JeffK, if she knew you and she does remember you. That said, I tried to export People Farms to a text file, but Pan 6 returns a message about the file being too large and it will not export the file.
Now, I’m not a Panorama user nor do I have Panorama experience, though I have a technical background in IT, so bear with my questions. Is there a limit to the size limit on a file that can be exported in Pan 6? People Farms contains 7500 records and is 24MB in size, and perhaps has existed from almost the beginning of Panorama according to Alicia.
Is there a setting in Pan 6 that perhaps I can increase to accomplish the export? Or must the file perhaps be “cut in half” or split somehow to proceed with the export to a text file? Once an export is accomplished then it would need to be checked by the lady named above for any anomalies, extra fields with spurious names not visible by Pan 6, as mentioned by JeffK. But right now it needs to be exported but, because of its size, Pan 6 will not do so. Please advise.


Panorama 6 does not have any limit on the size of an exported text file. If the database will open, it can be exported. There is no message in the program that says a file is “too large and will not export.” (Even if there was, 7500 records and 24Mb is not a very large file.)

Are you running an unregistered copy of Panorama 6? If so, then if you save or export a file with more than 250 records you’ll see a dialog asking you to register the software. You can temporarily bypass this dialog and perform the save or export operation by clicking on the blue letters in the dialog.

No, it is not an unregistered copy of Pan 6, the office is registered on both MAC’s for using Pan 6. The primary MAC on which Pan 6 is run and a second MAC on which Pan 6 is registered, but normally Pan 6 is not used there, but is where I have been running the Pan X trial.
When I attempted to export the People Farms file under Pan 6 on this second MAC is when I get the File Too Large message. I’m not at the office right now, but will be later and I can take a screen shot of the message at that time and will post it…unless it makes a liar out of me. And if it does I will post that too. But I tried to export the file under Pan 6 a couple of times and each time received the File Too Large message.

I think this is the error you are referring to. You can get it when you use the Text Export Wizard.

If all the cells contain simple, one line entries, you can export by using Save As… and checking the Text Only option. Otherwise, you will need to write a procedure that uses the Export command.

Edit: You can also select subsets of the database, and export them. So you could still use the wizard by exporting several smaller pieces.

Thank you David. I have the same QNA Archive database, and was able to duplicate this by clicking on the Export Text icon.

There is an easy workaround. Instead of just clicking on the Export Text icon, hold down the Control key and click (or right click) on the icon. Then choose Export From Text File from the popup menu. A dialog will appear to allow you to select the name and location of the exported file. Using this technique I was able to export this 75Mb database with no problem. (Using the Save As command as David suggested will also work.)

P.S. From time to time some of you express a longing for the “good old days” of Panorama 6. One thing you are forgetting about is the pain of dealing with “scratch memory”, and manual memory allocation in general. I for one am very happy to never have to deal with manual memory allocation ever again – in fact I had mostly forgotten about it. In this case the problem was that Panorama was trying to use 24Mb of data in a formula, in preparation for possibly dragging the exported data to the Finder. Of course 24Mb exceeded the scratch memory allocation, which I think by default was about 1Mb. By right clicking you eliminate the possibility of drag-and-drop, so Panorama doesn’t run this formula. I’m surprised this bug never came up a decade ago.

Jim, I did a “Save As” and saved the file as text including the field names. Will using the “Export From Text File” export the hidden corrupted fields as well?

If the database is corrupted, all bets are off. I have no idea.

Yes, that is the error I’m seeing. Just did the export, selected Export Text, got the Export Database window and when clicked on Export Text button received the File too large message. Even tried restarting the MAC, think perhaps there was not enough free storage to load the file. But when I tried to export right after the restart, received the same File too large error.
I’ve attached a couple of screen shots, the first showing Pan 6 is licensed on this MAC, the second screenshot showing the error before I restarted the MAC, and the 3rd screenshot taken after the MAC was restarted.
I will try the workaround as suggested by Admin and see what happens. Thanks for your responses. !
And I’m with Admin as far as the view of the “good old days”.
Anyway, thanks again for your responses.

Somehow the first screenshot of the license got dropped. Here it is again just to verify Pan 6 is registered on this MAC.

Ok, Admin’s workaround to export the database to a text file worked. Now it will have to be looked at by Alicia to determine if there might be an spurious fields not seen by Pan 6 as JeffK indicated in his initial response. Thanks.

If there aren’t, try saving it the way he did, using Save As… and including field names.

Question regarding exporting a Pan 6 (or maybe even a Pan X) database to a text file using the workaround method Admin suggested in a previous reply of his. I used that method to export People Farms to a text file. Then created a Pan X database in the trial by using the exported text file as input to create the db.
When I clicked on View in the newly created Pan X database I did not see any of the forms or procedures that exist in the Pan 6 version of People Farms. Also the number of records in the Pan 6 db is just under 7500 while in the new Pan X db created from importing the text file exported from Pan 6 is over 132,000 records.
Might this be because, unlike converting from Pan 6 to Pan X within Pan X (open a .pan file and saving as a .pandb file), exporting to a text file does not “preserve” the forms and procedures that exist in Pan 6 ? And all those forms and procedures need to be recreated when exported text from Pan 6 is used as input in Pan X to create a new database? And might the difference in record number between the Pan 6 and Pan X database also be for this same reason, each line of a procedure is now a separate text record?
If this is not the case, could someone please explain why I see not forms or procedures in View and why the record counts are so different? I would like to understand. Thanks.

  1. That is exactly what this method was about: To save the data of the problematic database separated from procedures and forms.

  2. If I remember correctly, there was another way in Panorama 6 to do exactly the opposite: To save a clone without the — possibly corrupted — data. You can do that manually, too: Duplicate the database, select all records, delete the selected records. That leaves a nearly empty database with just one record remaining, but containing all the procedures and forms. So you can try if it is possible to import that emptied database into Panorama X. This will work, or it won’t. In each case you get a hint whether the problem is caused by corrupted data or by broken procedure code or by forms that cannot be transferred to Panorama X.

  1. Not at all. Procedures are completely separated from the data, and records are pure data. The differing records count might be a result corrupted data or just for data that do not work well with this text export method. Have you tried the simple Save as Text method? What is the record count then?

If all you did was ‘export as a text file’ then that’s what you would expect to get: just text.
Saving the original Pan6 file with a .pan extension, then opening the file under PanX should open the new database as something like OldPan.(Panorama 6).pandb
Good luck; it works pretty reliably that way.