Zlog not working on b25

While trying to troubleshoot a crashing procedure for someone, I was unable to get anything to show up in the console with zlog. I tried on two computers and also restarted.

I replaced 10.2.0b25 (3901) with 10.2.0b21 (3826) and immediately was able to get the console to show the zlog notes for me.

A bit more info… after restoring b25 and on that machine the zlog continued to work. On the computer that had remained on b25 the log still failed to work.

I tried the same process of swapping in b21 and zlog worked. Back to b25 and zlog fails again - and the crash I thought I had resolved continues to occur.

This is a known issue with b25. So far I have not been able to figure out why this is occurring. I would suggest running PanoramaX under Terminal.app for real time logging.

Interesting that you were able to get it to work by going back to b21, however, I would recommend against going back that far. The console problem is not in b24, so if you want to go back, you should go back to that. You can download any version you want using the Versions menu in the Check for Updates window. My recommendation though would be to stick with b25 and use Terminal.app to see the log.

As noted in another thread, my switching of versions did not cause zlog to work when I went back to b25. I was mistaken on that point.


Does option 4, logging the output to a specified text file, also still work in b25?

I’m not sure why you call this “option 4”, but yes, logging output to a text file works.

As far as logging to the console goes, Panorama is still sending out the log information, but the Console either isn’t receiving it, or isn’t displaying it in the right place.