What replaced OutlineLevel

Hello Friends,
I am using a select formula that I brought over from Pan 6 and I am getting a error. The line is OutlineLevel(1). Is there anything that replaced this?

I’m not sure I understand the context. There is no outlinelevel( function. There is an outlinelevel statement. You would write that as

outlinelevel 1

or as

outlinelevel "1"

That’s not a select formula.

As Dave said, there has never been an outlinelevel( function, in either Panorama 6 or Panorama X. If you try to use such a function in Panorama 6, you’ll see an “unknown function” error.

If you wanted to do a selection based on the summary level, you could do it like this:

select info("summarylevel")=1 // or whatever level you wanted

However, it would be more normal to use the outlinelevel statement, as Dave stated. This works the same in both Panorama 6 and X.

Hi Jim,
That is so strange. The following is what I have been using for years in Pan6 and it has worked just fine with no errors"

;This macro will find selected Credit Card# and Total


Field «Card#»
Select «Card#»=add
Field «Amt. Paid»
OutlineLevel (1)
«aaa»=«Amt. Paid»
RemoveSummaries (7)

I think it is the parentheses that are causing the problem. Try removing them.

There are things in Panorama 6 which should not have worked, and yet did. This may be one of them.

I did remove the parentheses and did not get any errors. This was one on those things that worked in Pan 6 that should not have,

I just tried a procedure with

outlinelevel (1)

and it worked just fine – no errors. Certainly the parentheses are not necessary, but they shouldn’t cause a problem either, and they don’t in my test. What was the error you saw? Was this a syntax error or an error message that occurred when you ran the procedure.

I think there be something else that went on with the parentheses, but I decided to test it myself with a file I have that summarizes and goes to level 1. The parentheses did not cause a problem, but I accidentally ran it again without clearing the summary, and Panorama X crashed.

Unless this is just a typo in the post, the error here would probably be because there is no space before the parentheses.

I think it is a typo in the post. In his second post, the space was there. More importantly, I tried it in Panorama 6 and it also gives an error if the space is missing, but works if the space is included.