Welcome to the Panorama X 10.2 Public Beta!

Programming of Panorama X 10.2 began in late 2018. The development of this new version has been a long process – 22 beta releases (so far), over 80 beta testers, over 100 new features, over a thousand pages of new documentation, and over 200 bug fixes. With all that behind us, we’ve now reached a major milestone - the release of a public beta version. We’re calling this new version Panorama X 10.2 Denali .

To learn about this new version, including how to download and install it, please visit the new Panorama X 10.2 Public Beta Frequently Asked Questions (FAQ) page.

You may notice that this post you are currently reading is not in the usual Panorama X category on the forum, instead it is in a subtopic specifically for the 10.2 beta program. Until today, this subtopic was only accessible to students registered for the Mastering Panorama X 10.2 training course, but now it is available for all forum members. I encourage you to direct your discussion about the new beta version to this subtopic, so that it will be easier for other users to know when the beta version is being discussed versus the previous versions. In addition, you will find that there are already hundreds of posts in this beta topic that weren’t previously visible to you. So if you have a question about the beta that isn’t answered on the FAQ page or in the documentation, you may be able to find the answer here.

Jim Rea
President, ProVUE Development

Congratulations, Jim!

It has been a long road but the results are truly impressive.

2 Likes

I have read the release notes and web page on the new PaxX 10.2 Public Beta version. When I tried to use the Panorama Database Exchange to download and install PanX 10.2 Public Beta, there wer no databases indicated. Will PanX 10.2 work on a Mac running Catalina, or do I need to upgrade to Big Sur? Any help downloading and installing the new version would be greatly appreciated. I have tried to use the Panorama Database Exchange to download and install PanX 10.2 Public Beta, but there are no databases indicated. Will PanX 10.2 work on a Mac running Catalina, or do I need to upgrade to Big Sur?

Looks like the server for the Database Exchange is currently down. Possibly too many folks trying at the same time brought it to its knees. Try again later.

10.2 runs fine on Catalina. I have it running in both Catalina and High Sierra.

I have fixed the problem with the server and the Database Exchange is now working correctly. You may have to close and then re-open it.

Congratulations to Jim and the team of beta testers! I’ve been watching and waiting for the update and know a lot of work has gone into making it a significant step forward in performance and capability. I’m looking forward to exploring the new features and welcome the stability improvements as I continue to transition my work to Pan X!

Cheers for a milestone accomplishment!

1 Like

When I click on Check for updates I get this
Screen Shot 2021-10-15 at 2.37.51 PM

Please follow the link to the FAQ page on my original post, the first answered question is how to install the public beta, with complete step-by-step instructions. Here’s the link again.

I finally got it downloaded now it just sits there saying it’s Uncompressing PanoramaX_3846.zip file. How long does it take?

It certainly should be done by the time you’re able to type that post into the forum.

I would suggest looking in your Downloads folder. You may see a PanoramaX 10.2.0.b22 (3846).app file there. If you do, you’re all set, just copy that to the Applications folder (and rename it, if so desired).

If you don’t see the .app file, there should be a PanoramaX_3846.zip file. You can use the Finder to uncompress that manually to get the .app file.

I followed the UpDate steps under the About menu and it did install but it didn’t relaunch as the dialog said it would. This was on a 2018 Mac Mini running OS 11.6. Now running PanoramaX 10.2.0.b23(3857)

I am finding sometimes it relaunches, and sometimes it does not, but it always updates.

I ran the update today by watching Jim’s 2-minute video and the installation went smoothly. However, now I’m trying to open my databases and it’s saying that they’re damaged and I can’t open them. Below is a screenshot of the error.

I ended up looking through the feed and I saw other people were having this issue. I disabled the integrity checking and now I can open my database. I don’t know if this is a good long-term solution, but it’s working for now.