Weird error on str()

One of my procedures included the expression str( round(100*InclPts/max(1, InclVals), 1)) for calculating a percentage… the procedure wouldn’t run but it gave me no error messages. The problem turned out to be the BLANK SPACE between “str(” and “round”. I removed the blank space and the procedure ran just fine… it took me three hours to find out what the problem was.

I can’t duplicate this, using either Panorama X or Panorama 6. Are you sure you didn’t make some other change along the way?

Thanks for trying… I should tell you that I’m running Sierra 10.12.1. If you’re not, that could explain it… or not. As I recall, Pan6 was very tolerant about blanks… I used to use them to organize complex statements into components that I could easily see.

I went through the Loop code line by line, from “Loop” down, testing to see if the Loop would… um… loop. Something was stopping it from reaching the “Until”. Then when I found the line of code that was stopping the evaluation, the line containing the str( ), I cut and pasted statements within the line to find out what wasn’t working. As an act of desperation I removed the blank, and it worked. THEN, I put the blank back in… and it still worked… for now. So I have no idea what was causing the problem… maybe I just wasn’t holding my mouth right.

There are a few other odd behaviors within PanX that I’ve noticed that are intermittent and unpredictable. Some can only be fixed by quitting and restarting PanX. Here’s a partial list:

  1. “Showpage” within a procedure will SOMETIMES deselect (make invisible) the first record (if that happens to be the currently selected record) and select the next one for no reason that I’ve been able to determine.

  2. Logic statements don’t always work like what I’m used to… For instance, some complex statements won’t evaluate correctly without parentheses: CurrStudent=2+5*(n-1) will usually not evaluate as “true” even when it is but CurrStudent=(2+5*(n-1)) evaluates correctly every time. They both worked in Pan6.

  3. I have had problems getting the “Find” statement to work as it did in Pan6… “Find StudentName=array(WorkGroupMembers, k, ¶)” where k indexes the WorkGroup list. But I can get it to work as two statements:

    x=array(WorkGroupMembers, k, ¶)
    Find StudentName=x

  4. I have just today encountered a sudden refusal by PanX to call a procedure attached to a text editor object. The cursor just kept blinking in the field after pressing the return key. It had worked fine for hours before that. I eventually had to quit PanX and restart it.

  5. And of course, PanX still crashes randomly when I close a window, not as much as before I installed 10.12.1…

You (and Jim) probably want to tell me that what I’m describing can’t possibly be happening, but I’ve been working with Panorama since version 2. Of course, it might be my very familiarity with Pan6 that is causing me problems: things that worked in 6 quite clearly won’t work in X. (This is why we BETA test, right…?)

Or maybe I have GREMLINS!!! ARRRRrrrrgggh!


BTW, I still need the popup menu button object to work when it’s set to “transparent”… :slight_smile:

Most likely it wasn’t really a blank, but some other weird character that looked like a blank.

This is a bug that I have fixed, but the version with the fix hasn’t been released yet.


Your story is looking just like mine after I installed Sierra.

If you’re a regular follower of the forum, you would have seen a string of bugs reported by me that nobody else could reproduce - Jim and Dave were ready to send in the guys in the white coats. It took me a couple of weeks and seven clean installs until eventually I went back to Yosemite and now all is well.

I suspect that I have a third-party app that’s interfering with Sierra - there are several (Pan6 included) that will continue to run in Sierra but can’t be installed from scratch.

Good luck with it.

I’m not really buying the “it’s the fault of 3rd-party apps” argument: I don’t use 3rd-party apps much, and none of them are running at the same time as PanX. I haven’t experienced any problems with Sierra 10.12.1 and the native apps that might be caused by alien apps interfering with the system operation. It could be that the problems lie with with my iMac’s FusionDrive or the ForceTouch trackpad that I prefer to use. I don’t know.

If Jim can’t get PanX to run smoothly with Sierra, then I can only conclude that the app is doomed. The OS will continue to move forward, but people who want to use PanX will never be able to upgrade from Yosemite. That alone would force me to move to Filemaker (shudder) which is guaranteed to be compatible.

It’s my good fortune that I don’t actually NEED to use Panorama, in any form. I’m a retired college math teacher. I think I started using Panorama back at version 2, and my main reason was that I wanted to create a Gradebook that would look great and do exactly what I wanted it to do. I’ve been working on that Gradebook for 20 years, rewriting it from scratch four times so far. (This will be the last time.) I’m still working on it because programming helps keeps my mind sharp. If I spend my time on Facebook, TV and the dogs, I think that I’ll slowly dull-ifly.

So I’m sticking with Sierra and PanX as a “public” service to Jim, Dave and Panorama users everywhere. A program that only runs (well) on a legacy OS will not survive, no matter how wonderful it is.

BTW have you seen the new “Touch Bar” on the MacBook Pros? Amazing! But I am betting that PanX will not be taking advantage of that hardware/software interaction… ever… since it’s likely tied to Sierra. That makes me very sad… truly.

FYI – The current breakdown of Panorama X usage by operating system is:

10.12 – 29% (39% of those on 10.12.1, rising fast)
10.11 – 49%
10.10 – 12%
10.9 – 9%

So Sierra is already getting a lot of use, and reports of problems are running at about the same rate as for the other OS versions.

I agree, and that is why I’ve invested nearly 5 years of my life in Panorama X.

1 Like