Warnings Ignored

I had all my Warnings, in Preferences, set to Always. Been using it that way for weeks.
Then I made my first User Link using the Share Preferences dialog sheet, with ALL Categories checked.
When I tested the link, which logged me in as a User, I found there was no warning when deleting a record! The Preferences still showed Always.
Then I logged in as Administrator, and STILL got no warning, even though they were set to Always. I tried setting them all to Never, and then Back to Always, restarting Pan X, but now I get NO warning for deleting records, and I can’t get the warning back.

What Happened? (version b29)

I cannot duplicate this problem, so I cannot tell you what happened.

Ok, well, I’ve rebooted my Mac, switched the warnings off and on, saving the file in between, and restarted Panorama several times, and now, with them all set to Always, I still get no warnings at all.

Any suggestions as to what to try next? Is there a pref file somewhere I should delete?

You might want to double check the settings in the Notifications & Focus panel of System Preferences to make sure Panorama is set for showing all the notifications. I have had preferences change on me by themselves on one occasion and had my Calendar app stop showing them a short while back.

The warnings Dave is talking about are not notifications, so they would not be affected by the Notifications & Focus panel.

You could completely delete Panorama X preferences. That seems like an unlikely fix to me since you say that the preferences show up in the panel, but you could try it. They can be deleted using these steps.

• If it is open, Quit from Panorama X
• Open a new window in the Finder
• Choose “Go To Folder” from the “Go” menu
• Enter ~/Library/Preferences/ and press the “Go” button
• Find the file “com.provue.PanoramaX.plist” and move it to the trash
• Relauch Panorama X (this will automatically create new, default preferences)
• Log into your Panorama account

If you’ve set up any options in the Panorama X preferences window, you will need to set them all up again.

SOLVED, I think. Deleting the prefs file restored the proper warnings. I noticed the default prefs had the Option key checked for “Bypass warnings…”
When I unchecked all three modifier check boxes, I got NO Warnings again, even with them all set to Always. I remember I had no modifiers checked before I deleted the prefs file, so I think that was it.
I guess Jim can decide if this is a bug or not. I would expect the warnings to appear even when all the boxes are unchecked, but I’m perfectly happy to leave one or more checked.

(I did find it’s tricky to include a combination of modifiers, then try to click the Delete button in the toolbar, as Control and Command have other functionality when clicking in the toolbar, but again, I’m OK to just leave Option selected.)

Thanks for the help!

BINGO! That’s definitely a bug, and will be fixed in b30.