View-As-List Header, all column names don't display

I have a View-As-List form, with a Header and a Data tile. The Header tile Appearance is set to “000099”, the text and horizontal/vertical lines are set to “FFFFFF”. The form has a total of 18 columns. Column headers are TDO. My procedure selects the data as expected, but my problem is the header tile does NOT always display the column names. It all looks fine in the Graphics Mode, and sometimes all column names show when the procedure is ran, but run the procedure again for a different set of records (example Amendment 3 after A1) – and all my column names do NOT show. The first two on the far left always show. If I click in the header area of the opened form, my column names appear. Here are two screen shots, before and after clicking in the header of the opened form. Sure, I could make the header Appearance FFFFFF and my text/lines black, but I like the color.

I have a somewhat similar problem, perhaps. Sometimes a form (not a view
as list one) will open or move to a new record or present the results of
a lookup, and some text-edit boxes seem to be empty, but if I click on
them the data that’s supposed to be there shows up. This may not be the
same thing, but it might, so I’ll mention it. I may have reported this
before, but I’m working on taxes and don’t have time to dig it up.

Dusty Norwood wrote:

I don’t want to appear that I am ignoring this thread, but there is really nothing for me to go on here. Obviously I have no idea what you have put in these text objects in the header, and I have no idea what “the procedure” does. If there is a bug here, I would need to be able to duplicate it on my computer to have any hope of fixing it.

You haven’t said what your procedure does, but it sounds like a screen drawing issue since clicking can cause it to update. So, have you tried ending the procedure with any sort of Show that would relate to the data? ShowFields, ShowVariables, ShowPage…?

Sorry Jim… My procedure is below. I have 8 different TEO’s on my data entry form that triggers the procedure, each of course specific to 1 thru 8. The form header has Text Display Objects, Mode is Literal Text with the names of each column that I’ve entered in the formula pane when setting up the form. I’ve attached a screen shot of the form set-up.

Local theamendnumber,titleholder
Field «Amdt1»
Select «Amdt1»=“x”
If info(“Empty”)
Alert 1000, “Oops, sorry there are no records for Amendment Number “+theamendnumber+”. :wink:” stop
Field AmendmentType
titleholder=“Amendment Number: “+theamendnumber+” :point_right:
setwindow 73, 10, 758, 1075,""
openform “Amendment Number”,“Scrollbars”,false(),“Toolbar”,false()
ShowVariables titleholder

Hi James, please see more detail above for my procedure. I do use showVariables for the one variable in the header, which is the Amendment Number, 1, 2, 3, etc. There are no fields in the header. I’ve never had to use ShowPage before.

The new version just released today (build 2361)… solved my issue above. Thank you!