User cannot log in at all

I have a user on Catalina 10.15.7 and she cannot log in at all. We tried the Log In Link that I have been using for other users, and it works fine on my Mac. She has rebooted, we threw out the Panorama plist prefs, but no go.

Finally, I had her just click the Free Trial button, which ALSO fails. In all cases, it says “Contacting Server…” with the spinning wheel for about ten seconds, then that message disappears, and the Log In box just sits there.

She had grabbed the Log In link file from dropbox, so she was definitely connected to the internet.

While we were trying these various things, I logged on and off several times on my Mac.

It sounds like their ISP is blocking the SSL encrypted connection to, or maybe the local router (for example a poorly configured proxy server). I’ve seen this before with Japanese ISP’s (though very rarely). The best solution would of course get the ISP to stop doing that or fix the router configuration. However, Panorama can be configured to not use SSL. To do that, open the Site License window and click on the green padlock. It should look like this, but I’m guessing it will probably display an error message.

To turn off SSL, uncheck the box at the bottom of this dialog, then press ok.

Now the padlock will be gray and unlocked.

Panorama actually does it’s own encryption when communicating with, so even though SSL is not being used the connection is still quite secure.

Thank you Jim. We will try this if the problem continues.
However, I didn’t mention that in the same office where we had this trouble, we have another Mac that has been logged in and using Pan X for a couple of weeks. The only difference is that the office Mini is connected via lan cable, while the user’s Catalina was a MacBook on WiFi. Same ISP of course.

When we finished, she was heading home from the office to try it at home, so a different ISP. I’ll update this when I hear from her.

But thanks again, this is good info.

OK, she tried switching off SSL, but no change. Here’s what she wrote:

I was beginning to think that the firewall setting on my PC might be causing a problem. Yes, I had firewall on. I have turned it off, deleted the plist file, unlocked the padlock on the Pan x log on dialog, and tried to launch the program. Still the same result (nothing happens).

When I tried to unlock the padlock, it now becomes grayed out, instead of being unlocked.

Is there anything else we can do to test her reach to the ProVUE server? Are you able to see her connection attempts?

This seems like information that would have been important to start with. Based on all the information supplied, it sounds like the firewall probably wasn’t actually turned off, even though she says it was.

No, for two reasons. First, our server doesn’t keep logs with that kind of detail. Secondly, it really sounds like the connection is being blocked either on her computer or on the router, so our server is never seeing the request. If our server sees a request, it will always respond.

It’s pretty evident at this point that the problem is inside her building, either on her computer or in the WiFi router. Since there is a firewall, I would start there.

The mini that is working uses ethernet. But is the router that ethernet cable is connected to the same router that is providing the WiFi? Depending on how the office network is set up, it could be the same or different. If it’s a different router, the WiFi router might have a firewall that is blocking access.

One thing that could be tried would be to temporarily switch the Mac mini to WiFi. Or, they could get an Ethernet adapter for the MacBook.

At this point this definitely sounds like a problem for whoever is in charge of IT at this facility. I don’t think there is going to be anything further that ProVUE can do. This page provides some information about how Panorama connects to and working with firewalls & blockers.

I am using Little Snitch and a VPN and have not had to make any adjustments to run Panorama. But I’m only running as a single user - nothing more exotic than that.

Little Snitch is extremely configurable, and it can definitely be configured so that it will interfere with Panorama. In fact, it’s a program that’s pretty difficult to use intelligently, because the entire purpose of it is to interfere with network connections. Most people have no way of knowing which connections they can block without causing themselves problems (and I include myself in “most people”). I used to run Little Snitch myself but I found that I really wasn’t able to configure it to do anything that was helpful to me.

Thanks again Jim, for all your help with this strange problem!

Yes, we just have one router at the office, with a WiFi card stuck into it, so it’s the same router doing both.

I should have made it clearer that she later tried at her home, so a different environment completely (but still failed to log in with no error message). That is where she switched off the SSL. I have asked her to try a LAN cable at home, and maybe tethering to her phone, just to try other configurations, and will let you know what happens.

It pretty much must be that there is a firewall on that computer. Every other possibility has been ruled out.