Updating OS on mini running Enterprise

After having spent the better part of this last weekend failing miserably attempting to install Enterprise on a newer Mac mini, I am now faced with updating an older Mac mini that is currently running 10.6.8. I would like to take it to 10.13.6 and am wondering if doing Apple’s updates on the OS will cause any problem with Enterprise?

FWIW, I was able to get Local Sharing working fine, but Internet sharing was the obstacle. After getting Apache running with a confirmation of it being up, Panorama was still not able to connect with Enterprise. Opening up the drives permissions as is typically necessary was a disaster as many Terminal commands were then not happy with the improper permissions.

I’ve been able to run Enterprise on 10.14.5 so it’s still hanging in there.

Here is a post that was on the QNA list a few years ago about the necessary edits to the httpd.conf file to enable internet sharing and/or publishing:

Starting with OS X 10.10, Apple changed the web server configuration so that CGI programs are disabled. I guess they thought that was a potential security issue, but they didn’t care that people were actually using that feature!

To get it working again, you have to edit the httpd.conf file, which is found at:


It’s kind of difficult to edit this text file, because it is in a protected location. I use BBEdit to do this, it has the ability to prompt you for the system password and allow you to edit the file.

Once you have the file open, you’ll need to find this section:

<Directory "/Library/WebServer/CGI-Executables">
    ... configuration options

You’ll need to change the options to the ones shown below:

<Directory "/Library/WebServer/CGI-Executables">
    AllowOverride None"
    AddHandler cgi-script .cgi .pl .tcl .py"
    Options +ExecCGI"
    Require all granted"+    </Directory> 

You will also need to find this line:

#LoadModule cgi_module libexec/apache2/mod_cgi.so

Remove the leading # sign, so it looks like this:

LoadModule cgi_module libexec/apache2/mod_cgi.so

Once you’ve made these changes, save the file, then start up Apache again (if you didn’t do so before, stop it before you restart it).

Hopefully at this point it will start working.