Unable to share a large database

After several attempts, I have been unable to share a relatively large database. Here are the details of what I have tried and what has happened:

I have three computers involved. Computer #1 is running PanX Server. Computers #2 and 3 are connected over separate VPNs to Computer #1’s network.

Computer #2 is connected to the Server, and tries to share a database (~59,000 records/33.6 MB). The database is set to encrypt the data upon sharing. Entitlements are set to User/Developer/Developer (same as every database I have shared so far.)

With Computer #3, I have Server Administration open for viewing the list of databases on the Server. The shared database did not appear after several minutes.

Back to computer #2, it now shows a Connect to Server option in the File Menu Bar, but if I select that, or other steps that appear to contact the server, I get a notification “Could not open [DB name] on [Server name], Database does not exist (missing info.cfg)”

To me it looks like the client file thinks it is connected to the server, but the server does not recognize it as being connected; the sharing/uploading did not work correctly.

So on Computer #2, I detach the database from the Server. Now I think I am back to the starting point. And will try again with a different client (Computer #3). I use Database Options to Share the Database, again with encryption of the Data enabled, and get a notification that it is being uploaded or shared (I don’t remember the exact term in the message). But again after several minutes, the database does not appear in Server Administration, and the same notifications appear the the Database cannot be opened…

Try again without encryption: Detach the database from the server. Message Says uploading. But again the database does not appear in Server Admin and the notifications say it is not available. (same message every time).

Detach the database and try again to share, this time to a different server running on Computer #3, so both client and server are on the same computer. Same problem, so it doesn’t appear that the network was the source of the failure to share.

Finally, detach the database from the last attempt to share, and then copy the database file to the server (Computer #1). Close all copies of Connected client databases, then Restart the server. and try again to share on Computer #1.

Same failure.

I realize that I have not sent you the database so I am not sure what you can do. The only difference I see with other databases that I have successfully shared is that this one is substantially larger. The largest size I successfully shared has 7,550 records/4.2 MB.

The largest database I have tried so far is the US Airports example database, which is about 7 Mb for nearly 20k records. It went smoothly. The way the system is architected there should be no limit to how large a file can be uploaded, but I haven’t tested it with anything larger so far. I’m sure I can come up with a larger database.

One thing I have not tried even once is uploading a database with encryption enabled. I haven’t tried this with even a small database. It sounds like perhaps you have had success with this when using small databases? I’m not suggesting that it shouldn’t work, but since I haven’t tested it, I have no data.

Yes, several databases are encrypted. Tomorrow I will try cutting this database in half and see if I can share that.

I’ll still need to try it myself, but that is good news. Frankly, I was a bit concerned that it might not work “out of the box”. But if it works at all, it should work all the time.

Is it possible that the sharing of a database depends on the Archive Utility.app? I have had difficulty unzipping .pandb files above a certain size, surprisingly small. For example, if I compress a .pandb file that is 33.6 MB, then try to uncompress it, I get a message that says “Unable to expand [zipfilename] into [dbname]. Error 79 - inappropriate file type or format.” I have been using Stuffit Expanded instead. However, I know Archive Utility will handle much larger files of other file types.

Panorama does compress the uploaded file into .zip format to upload it to the server. It doesn’t use the Archive Utility to do that, but it’s possible that the same underlying compression code is used by both Panorama and the Archive Utility.

The largest database I have handy is the FAA Aircraft Registration database, which is 81 Mb (I think it is available from the Database Exchange if you want to download it). I just tried compressing and uncompressing it with Archive Utility, and it worked perfectly. When I get a chance, I will try uploading it to a server.

I wonder if there is any chance that installing Stuffit Expander somehow patches your operating system? I’m kind of shocked that Stuffit Expander is still available. At this point I would definitely trust Apple’s code over whomever is publishing Stuffit these days. (And actually I think Apple is just using the same code that Linux uses.) There is certainly no reason that compressing/expanding a .pandb should be any different than any other type of file, it’s just random bytes as far as the compression algorithm goes. However, if a file can’t be zipped/unzipped on your computer, that would definitely break Panorama server. That isn’t a possibility that I have ever heard of or ever considered. Though I would have hoped that if there was an error Panorama would tell you about it instead of just silently failing.

In fact, I suggest that you do try downloading the FAA Aircraft Registration database. The download is a zip file, so it would be interesting to see if you can expand it on your system.

Are you running the server using Terminal.app? If you are, there may be an error message in the console output.

The FAA file unzipped without a problem. I have previously unzipped other large files. So far, it’s just Panorama files that are having a problem.
The zip problems may be peculiar to my computer for some unknown reason.
At any rate, I exported the data from the large file, that I have not able to share, and then imported it into a new database, without any forms or procedures. The new database uploaded/shared without a problem. I am going to transfer the forms and procedures next and see how that works.

With my newly created database, and data, forms and procedures transferred from the old one, everything works! That was really weird. I have shared the new one and downloaded it on another, computer, created new generations and everything is working, including zipping and unzipping. I now see that this problem had it roots months ago, when I couldn’t unzip the file with Archive Utility. That annoying problem swallowed a lot of time, but all’s well that ends well? I can’t agree with that platitude, but ending well is better than ending badly.

Amen!

Fingers crossed that this weird problem never rears its head again.