Trouble opening files in new version

Since I’ve updated to the latest version I’m having trouble opening files. Not one single file that I have will open. I first tried to open something from Open Recent; no luck. Then I tried to open the same file from Favorites. No luck. Then I tried from Find and Open: I got an alert saying “Database .pandb does not exist.” I do have one DB open but nothing else will open. I tried to open it by double clicking from the Finder. Still no luck. I’m going to try quitting PanX and see what happens before I send this.

Ok. I restarted PanX. Same deal at first, nothing happened, except on Find and Open I got “OPENDIALOG statement failed, form Find & Open Database does not exist.”

Then I tried opening several other DB’s and they all opened. Then I tried the one that initially was giving trouble, and this time it opened.


Oh boy, I hate reports like this – nothing to go on.

Hmm, I wonder if the files were actually opening, but with no windows. Hopefully this doesn’t ever happen again, but if it does, try looking at the Memory Usage window to see if the file opened but invisibly. If that does happen, you can get the windows open again with the View Organizer.


Yeah, I know, I hated writing it. I think you might be right about the invisible part. The first time I tried to open it, it did open a form that was just called “window”. It’s generated by a procedure. It was after I closed that that I started having problems. I’ll take a look at why that window is labeled window instead of the actual name of the form.

Sorry for bad quality of original report.


Oh, I didn’t mean to say your report was bad quality. I just meant that this sort of problem is frustrating.


For what it’s worth, I’ve tried to duplicate the problem and have been unable to. I did believe that the Open Recent would fail, (as my experience with Open Recent in Pano 6 has been less than optimal) but I was unable to see any failures. In fact, it worked admirably well.

Well, I thought it was. :smirk:

There is definitely a very intermittent problem with opening databases (or maybe saving window positions). I think I’ve seen it once this year, and I obviously use Panorama X a lot. The symptom is that the database opens, but without opening any windows. When it happened to me it was the database that contains all the Panorama Help information – which obviously has a lot of work put into it. Fortunately, all I had to do was use the View Organizer to open a window. From then on it worked fine. There have been a couple of reports of the same problem, but no one is able to duplicate the problem once it is fixed with the View Organizer. So that’s why I hate this!! Obviously I have gone over this section of the source code with a fine tooth comb more than once, but so far I haven’t found the culprit.

Admin Note: Bill Conable replied on this thread at about 12:15 PM California time, saying:

  • Well, I thought it was. :smirk:

But I think this reply actually came straight to me, and isn’t posted publicly on this thread. I can see it here, but can anyone else? Bill, is that what you intended? Doing some experimenting, it looks like it might be very easy to privately reply to a specific poster rather than replying on the thread. Still a lot to learn about Discourse.


His reply was posted publicly. I saw it first in my email.


Interesting. Now as I edit this, it shows that I am replying to “dave”, not the topic. But I think it will show up publicly on the topic thread.


I notice there are two types of reply buttons. The one under each post is a reply to post while the blue button lower down is a reply to topic.

Yes that is what I was talking about. But both types of posts seem to show up more or less the same.

This happened again this morning: I tried to open a favorite DB and nothing seemed to happen; but when I looked in the View Organizer, there it all was and I could open what I wanted right away.

So the file actually did open, but with no visible windows, correct? At least that tells me what section of the code to look in. Weird that it only happens occasionally.

Right. Good hunting.

Status report: I quit PX as a preliminary to installing the latest version; the troublesome file was open and showing a window or two. When I restarted and tried to open the troublesome file, once again nothing showed up. I was easily able to get a window open using the View Organizer. Before I tried that one I opened another file (which had also been open when I quit to install) and it opened fine. I’m going to try things out on a different computer just to see what happens and will report the results.