Trouble moving columns (fields), but thanks to Gary for his fabulous Design Sheet

Dragging a column in a large PanX file does not work as expected and even bombs PanX sometimes. After struggling on this problem for about an hour I discovered the fabulous Design Sheet extension made by Gary. Thank you Gary!

If you can provide any additional details about the problems you encountered, that could be helpful. This feature was exhaustively tested on quite large databases, moving columns far to the left and right (so that the data sheet had to scroll to accomplish the move), and with one or more hidden fields.

This “Design Sheet” of Gary’s is not in the Panorama Database Exchange – did he send it to you privately? Under the hood, it would have to use the same code that Panorama uses when dragging columns, so I’m surprised it would behave any differently. There is one Panorama statement that moves the position of a field, the movefieldbefore statement.

This is used internally by Panorama when dragging columns, and I’m sure must be used by Gary’s tool as well.

I have not entered this file in the Database Exchange since it was always intended as an interim solution until or if Panorama X supplied an updated native version of the design sheet. The file is still available from my site which is where James probably downloaded it some months back when I mentioned it on this forum. And, yes of course, I used the movefieldbefore statement in a looparray for reordering fields whenever called for in the regeneration.[quote=“panaca, post:1, topic:1612”]
I discovered the fabulous Design Sheet extension made by Gary. Thank you Gary!

Thanks for kudos James, I’m glad you found it useful since I put a whole lot of effort in that project (way more than I bargained for when I started it).

I am a total newbie to PanoramX, so I may be missing something, but dragging field columns is totally erratic for me. I am sometimes able to drag a column one or two fields to the left, usually things just spring back to their original positions. No luck at all moving things to the right, the first column in my database is absolutely stuck there. Thanks for the info on the move column command. I wasn’t ready to jump into coding just yet, but looks like I’m going to get my feet wet.

Wow, thanks so much for posting the DesignSheet application. Saved me… I’d been mousing around for a half an hour simply trying to re-arrange a simple DB. Much appreciated; Odd to me that others are not experiencing this, makes me wonder if I am doing something wrong. Dragging cols ought to be pretty straightforward.

Sam, I think I may have been able to duplicate your problem with dragging field columns. If I hide one or more fields, then there is a problem when trying to drag over the “hidden” field. I think you may find that if you make all fields visible, you’ll be able to drag without any problem. Then you can hide one or more fields again.

I’ve added this to the bug list so hopefully it can be fixed in the future.

Also, Gary’s simulated “Design Sheet” is now available in the Panorama Database Exchange. Thanks Gary!

Hi Jim, I did some testing and I can confirm that I did have a hidden column just to right of my first column, effectively trapping it. Your solution solved that. However, I also had erratic behavior in columns to the right of my single hidden column. I was able to move a column one or two positions at a time, but not more. And even at that, the move only worked 50% of the time… most of the time the column just sprung back to its original position on mouse-up. Unfortunately (or fortunately) since a restart of PanX, column dragging now works normally (except for the hidden col prob.) and I am no longer able to reproduce the problem.

Yes - I suddenly was having the same issue. The answer? SHOW ALL FIELDS (as Jim pointed out). If a field is hidden, column dragging produces erratic, unpredictable results.

I have just started with Panorama X and am figuring out things. I have a very simple data sheet and am not able to move the fields by dragging the fields. No field has been hidden. I can only able to reorder them from the ‘Field’ menu.
Do you have any suggestion to resolve this? I can share the files if you need.

Have you tried “Reorder Fields…” from the Field menu? This opens a dialog that allows you to drag field names to a new order.

Yes, that’s why I mentioned that I can only able to reorder them from the ‘Field’ menu. Just that drag and drop is not working.

This was recently mentioned on another recent thread. There does seem to be a problem on some versions of macOS. I think I have it fixed for the upcoming b26 release.

Thanks. It works on my old Mac running Catalina. It only is not working on my new Mac running Monterey. A fix would be welcome.