This is impossible, isn’t it?

I’ve been with Panorama since it was OverVUE, and I love it so much that I’ve used it to build the complete infrastructure for our small nonprofit — financials, contact list, everything.


The upgrade to PanX has been really, really hard for me. I’m OK with losing many statements & functions and learning lots of new ones, and I understood that it would take a lot of time to reprogram 30+ years of code.

What has stumped me, though, are the situations where things happen that I can’t understand or fix and that frankly seem impossible. Most of these are so far buried in the code that they would be hard to explain clearly enough to bring to this forum. However, I ran across this one yesterday, and it’s a good example. I’ve included a screen shot. This should be impossible, right? I’d love any insights.

I don’t see where you have declared Todays Reading to be a local variable. You may have declared Todays Reading as a local variable in another procedure but local variables from one procedure are not carried over to another procedure automatically. Try adding Todays Reading to the list of variables in the Local line.

It isn’t a variable. It’s a field in the active database.

If you are referring to the strange black rounded rectangular window containing the Error Wizard, I have run across this as well in the past but only once or twice recently and I even sent Jim this example depicting this action over a year ago. The animation below shows how it was possible to actually drag the title bar and create clones of the enclosed form. The worst part was that nothing would respond to clicking and I had to force quit Panorama to dismiss it.


I believe he is referring to the error itself. He is being told that his «Todays Reading» field does not exist, but the widow command made the Daily Electric KWH Usage window the active window, and there is clearly a field with that name in that window.

I agree that is most likely the case but I wanted to note the strange window as well since I had run into this in the past and have not seen it discussed on this forum.

You’re right Dave. I really missed that one! An extra space in «Todays Reading» in the procedure code will generate this error.

The error wizard is showing his code in a monospace font, and the space doesn’t appear to be any wider than any other space.

My guess is that the extra space is in the field name, rather than in the procedure code. For example an extra leading or trailing space could cause this. However there is no way to tell for sure from the screen shot.

In Panorama X another option would be to change the name of the field to something simpler, like just Reading. Then the display name could be set to Todays Reading so it will show up that way in the data sheet. This would make it simpler to use the field name in code, with no chevrons required.

Actually, that’s another possibility here – maybe the field name already IS set to something else. That would cause the error message.

Yeah, I wasn’t really clear about my dilemma.

Dave was right; I was referring to the error itself. This is a database I converted from Pan6 that has been running fine for years, and today I even used “Insert field name” right-click just to make sure it’s the same name. I don’t understand how the field can not exist when it’s right there.

This same kind of error has also happened in other instances and I’ve been able to fix some of them by basically having NO secret windows, but it didn’t work with this database.

BTW, I get that “black rectangle of death” a lot, maybe two or three times a day, and I have to force quit Pan to get it back. I thought it happened to everybody.

Is there a list of developers who I could pay to help me get back on my feet? I have decades of experience with Pan6 and I bought and went through the whole video training course and that helped, but I’ve been working on getting my nonprofit back up and running for over 3 months. I can probably do all of the normal changes required for the upgrade, but I’m stuck when I run into these weird things. I think I need some professional help to figure out the bizarre things, from someone who has abundant knowledge of Pan6 as well as the upgrade to PanX. Suggestions/Volunteers?

Robert, I would be interested in helping with your PanX problems. I have been supporting Panorama for many years in ny former law firm, and planning to offer my services to non-profits once the server has been released. If you want to know more, I can give you my phone and email. Tom Cooper

No, it doesn’t. I have never seen that on my MacBook Pro (mid 2012), and I thought it was an artifact of the screenshot.

Robert, do you have any custom settings in System Preferences > Accessibility? E.g. less transparency?

I think the error is coming a bit further down the code than the Error Wizard is showing. Looking at the Daily Electric KWH Usage form in the background you can see that a new record has been added and that the Demand Usage field has been filled in. This means the actual error seems to be around the line:

«Todays Reading» = val(TempText)

After that line nothing is added to the form so the problem must be in that area. The next line assigns a value to a field («Numeric Now») which I do not see on the form so it is either absent or hidden. Is this the real problem?

Only Robert can say whether or not those GetText lines were activated, but you’ll also note that after adding the record, TempText is routinely filled with an existing value in the record. My money is that the fields shown with content are ditto’d for new records.

My suspicions were aroused because the executed addrecord statement comes after the supposed error - which should not happen.:thinking:

I’ve seen the Error Wizard come up like this. It’s definitely annoying because at that point there is no way out other than force quit and relaunch Panorama. I haven’t been able to track down why this occurs, but I don’t think it is random. I think it may be related to an error occurring in low level code, like in a custom function, or in automatic code like .Initialize, .NewRecord, or timer code. However, I’ve not seen this happen very often, so I haven’t been able to track it down so far.

1 Like

It’s somehow comforting that I’m not the only one who has received the “black rectangle of death.” Additionally, there are numerous instances of strange behavior here, and I have often thought they could somehow be related to .Initialize or something else that affects Pan on my system globally. For example, secret windows are so problematic on my system that I’ve just disabled almost all of them.

“Secret windows” work perfectly in Panorama X. And what do you mean by “disabled” them? They are not a thing you can disable. Also, they aren’t really “windows” and never have been, which is sometimes a source of confusion. I’ve written about this extensively on this forum so I’m not going to repeat all of that here.

Yes, no need to repeat, since you’ve done a great job writing about the way “secret” windows simply activate a database. I liked your description in the video training.

What I mean by disabling them is that I make a real window of that database active instead of using a secret window or setactivedatabase. I’m not saying it’s a problem with Pan; I really think it’s something wrong with my programming. And I’m glad to hear that they work perfectly in PanX. I’d like to get back to using them so that things don’t get so cluttered. It’s just that for now, Pan6 code that worked perfectly using secret windows creates all kinds of havoc in my PanX code, so I use visible windows rather than secret windows.

What kind of havoc, you ask? Havoc that’s complicated enough that I need someone to sit down with me and spend some significant time hammering with me on the code. I will, however, keep you updated as I learn more and am able to better articulate the exact nature of the problem(s).

BTW, Jim, I’m again and repeatedly impressed with the active and insightful and kind interest you take in me and the other Pan users. Thanks for your help.

I haven’t been following the forum as faithfully as in the past. But I did notice this HumanPotentialCenter’s entry.

Jim, secret windows might work perfectly for you, and other experts. But there is a fundamental difference between how they work in Pan6 and how they work in PanX.

Nearly ALL my Pan6 macros which used secret windows failed to work properly in PanX, sometimes with disastrous results. I had to, as HumanPotentialcenter did, replace all secret windows with regular windows, and put up with the screen flashing as databases opened for a time and then closed. That also slowed things down considerably. Not a fatal deficiency to be sure, but not ideal either.

Secret windows, which take some getting used to, definitely DO NOT work “perfectly” in PanX.