The new Choice Palette

  1. How do you select one of the choices in the Choice Palette? I tried “enter”, “option enter”, “control enter” … but nothing seems to work.

  2. I have a list of choices longer than can be displayed. Is there a way to scroll through the list?

The Choices popup looks great except any new choice is ignored completely. Like Guido noted, there seems no way to get the chosen item to actually be entered into the cell.

Another thing I noticed is that if you change the text size for the data sheet, the choices popup editing window resizes to the new text size but the text inside the popup does not resize and may no longer fit within the edit box.

It seems like mutiple users are having this problem of being unable to get the Enter, Return or tab keys to work with the Choice palette. I don’t know why, it works perfectly for me.

You should also be able to enter a value by double clicking on it.

Can anybody get this to work? It’s always super hard to debug a problem that I can’t duplicate.

The Choice palette doesn’t work for me either. I’m running Sierra 10.12.1. I can select one of the choices by double clicking it but it doesn’t show up in the cell. I also can’t tab out of the cell.

I think this might also be another problem with Sierra 10.12.1. Here is what happens on my system:

Additionally, the only way to close the edit box is to click outside of it. Double-clicking a choice, Enter, Return and Tab do nothing. Selecting a choice by entering the first letter only produced a beep.

What are the requirements and steps to create a Choices field?

Field Properties
Type: Choices

Data Entry section: In the lower section of the Field Properties box has a ‘Choices’ tab and within that text area of that, I’m imagining a listing of the potential choices.

Are the choices listed in that box? How are the delineated/separated? Comma, colon, semi-colon? I did not find anything in the Help that spoke about Choices that appeared to be relevant.

Anything else to make choices appear on the datasheet?

Robert Ameeti

Delineated by spaces, just like Panorama 6. To include a space, use the underscore character, for example Federal_Express.

I do think this was briefly covered in the “Field Configuration” video.

The help for this topic isn’t written yet, but it is pretty much identical to Panorama 6.

Gary, your movie looks fine – clicking outside cancels, which is what it does on my system and what it was designed to do.

So none of the keys work – but they work in a regular Input Data window? That’s weird, they use the same mechanism.

Looking at the code, Panorama is asking macOS for a keycode value. I wonder if these keycode values could have changed in 10.12? Hope not, that would really suck.

In a field without choices all the keys work normally and Enter and Tab close the edit window. Clicking outside on these non-choice edit boxes enters the edited text and does not cancel it. In a choice edit box the only way to close the box is to click outside of it. No key stroke is allowed while the choice edit box is open. All keystrokes produce a beep except the Escape key which does nothing.

Ok. Sorry about the noise. I was Return delineating and it wasn’t working :wink:

Now my symptoms are identical to others. No selecting ability.

Robert Ameeti
(949) 422-6866

This is not the action I would have expected since clicking outside the edit box does not cancel entry into a non-choice edit box. I personally would prefer to have the choice edit box close the same as the non-choice edit box while the Escape key would cancel any change.


Robert Ameeti

I’m using OS 10.10.5, and seem to be seeing the same problem with entry. So far, I only looked at the datasheet, but I can’t seem to get a value to register. They don’t respond to letters pressed, either upper or lower case. I also get some strange sizes–with three fields that should be identical (they all have 5 choices, space-delimited single letters), I get two different sizes. Two show as a single line, and the third is about 3 lines. I’ve tried resizing without luck.


Ok, so Sierra isn’t the problem. Interesting.

As for the sizing, it is completely manual. But you say that you can’t resize it? Here is how resizing is supposed to work, and does work on my computer. (BTW, this is with the release version, not the debug version that I usually use.)

Do you also get a beep when you press any key?

Hi Jim,

I get the beep when I press any key, including the enter or return keys.


You know, actually, it wasn’t “designed” to do that, I just forgot to handle that situation. You are correct, it should save the changes, and I have made that change.

People wonder why programming takes so long – figuring out how to make this one little change, which you might think would take 5 minutes, took several hours. It was really difficult to figure out how Apple’s code could notify my code that the window was closing due to a click outside the choice palette. But I finally figured it out.

And next time, it will take 5 minutes. :slight_smile:

Robert Ameeti

Thanks for the quick reply. When I go to the corner of the box, it does resize. I would expect the side and bottom resize tools to work as well, and they don’t do so consistently (but they do show up, giving the impression that they should work).
…somewhat later…Ok—I just noticed the very subtle white dots I have to hit with the mouse. I didn’t notice those earlier because my system gives the resize tools (horizontal or vertical arrow) when the mouse is just a couple of pixels away. When I click on the dots, it works fine. Sorry I missed that, but if there’s a way to use the tools, that might be less confusing to others.
I do also get the beeps with any key, and the value doesn’t change, even if I change it in the box. That may be because I am also dismissing the box by clicking outside.
Good luck…

Ditto here on Gary’s example. 10.12.1