The document “SN X.pandb” could not be saved. The file doesn’t exist

The document “SN X.pandb” could not be saved. The file doesn’t exist._

After editing and then waiting a few seconds I get the above message.
How do I fix this?

Thanks, Tom

You’ve provided very little information here, so I have no idea. Is this a new or old database? Did this just start happening out of the blue? Does this only happen for this one database, or all of your databases? Where is the folder this database is supposed to be saved in? Do you have other databases in that folder that are working ok? Do you have any virus checkers or other programs that might be automatically deleting or moving files in the background?

That error message doesn’t exist anywhere in the Panorama X source code. So it must be an Apple error message, making it more difficult for me to track down.

This is a database that was imported from Pan6.
It has happened sporadically in the last week or so since I just started using PanX
I have only used this one database
The database is located in Applications/Panorama/Serial Numbers ƒ
No virus programs

The database is inside the Applications folder? That’s probably the problem. You should never put any kind of document inside the Applications folder. I’m not just talking about Panorama databases, but any kind of document.

On OS X (now called macOS), usually the best practice is to put documents inside your user folder, typically inside the Documents folder inside your user folder. I’ll bet if you move the file there you’ll have no further problems.

I’m imagining that the database needn’t be in any specific location but typically a document that you create would be kept in some folder within the Documents folder rather than the Applications folder.

Robert Ameeti
(949) 422-6866

Yes, anywhere inside the user folder should be fine, and most folks put files inside the Documents folder just for neatness.

But if you put a file outside your user folder, you’re asking for trouble from Apple’s permissions’s system. The exception would be an external drive, where anywhere is fine.

Did you create the “Serial Numbers” folder? I don’t have one inside either my Pan6 folder or the Contents of the PanX app.

Thanks all,

I never had save problems with Pan 6, so I assume the new save problem is something in Pan X.

I just find Pan X too frustrating. Lack of coloring records in the Data Sheet, which is very important for my work, cannot change font size and now not saving files is too much for me. I need to go back to Pan 6 for now.


The ‘Save problem’ is not a Panorama issue.

For as long as their has been Mac OS X, the user should ALWAYS be saving only into their home folder, and most often into their Documents folder. It has never (in the last 15 years) been proper to save documents into the Applications folder. If you have not yet learned this, now is the time. If you continue to save personally created documents into the Applications folder, you will have problems. Guaranteed. This is not a Panorama issue.

Robert Ameeti
(949) 422-6866

Still problems saving my file even after putting into my User folder. I created a new PanX file and then imported my data from the file I was having problems with. So far there are no problem saving this new file

An update on this topic:

I occasionally get the “Can’t do something, file doesn’t exist” type of message and I’ve discovered one cause of this.

In the Procedure panel of a form I had this code:

saveacopyas replace(dbpath(),"Active files","Backup files") + info("databasename") + " backup"closefile

Note that there is no space before the closefile statement (due to clumsy cut & paste). Panorama X doesn’t pick this as an error but it clearly doesn’t like running the procedure.

Panorama X doesn’t seem to be rigorous in checking code in the panel.

In the Procedure panel it runs the same compiler as in a procedure window. When you click Apply the bottom of the panel shows if an error is detected.

The Formula panel does not give any similar feedback.

Same issue here. File is in the Documents folder of my user. When I edit a field or delete/add a record I get this message:

The document “zSerials & Logins (Panorama 6).pandb” could not be saved. The file doesn’t exist.

I’ve tried saving the file as another name in another location, etc. No luck. Same problem.

This is not happening in any other application.

MacOs Catalina 10.15.3, 2019 MacPro, 64GB ram.

The answer for that error has been found to navigate up to the top level of your drive, then manually drill down, directory by directory, to where you want to save. Then effect the save.

Thank you. That seems to have fixed it. I read through the responses here, but must have missed this solution.

I have a database in which I record my daily blood pressure readings. It started life as a Panorama 6.0 database which included a couple of complex graphs and was cluttered up with several used and unused procedures. After I migrated it to Panorama X, I didn’t bother to remove any of these features, I just wrote a new procedure which printed out the results for my GP in a very basic form.

The point of the story is that I then encountered the dreaded “doesn’t exist” message almost every time I tried to save it. My solution to this for a while was to always have a backup of the last saved copy and use that as a new strating point.

Ultimately, I removed all of the old procedures, keeping only the new one. Lo and behold, I haven’t seen the error message since.

It would be interesting to know how many other users have run into the problem with a Panorama 6.0 to Panorama X migrated database and how many (if any) have it in a brand new Panorama X database.

I’m confident that is a coincidence. This is a problem with Apple’s code, if you Google you’ll find that it can occur with many different applications. The internal contents of the file have nothing to do with it.

You’re certainly far more knowledgeable than I am about these things Jim but I’d be interested to know how often the problem has emerged with totally new Panorama X databases as against Panorama 6.0 conversions. There may be a factor there that exacerbates or triggers the Apple issue. Maybe I’m just looking for that 15 minutes of fame which has so far eluded me :slight_smile:

You are imagining that there is some process in which a Panorama 6 database is transmogrified into a Panorama X database. That isn’t really the case. What Panorama does is create a new, empty Panorama X database. It then reads each component of information from the old database and stores it in the new database. But there is never any connection between them, and none of the old structure is retained.

Imagine that a book is translated from English to French. The French book is really an entirely new book – new paper, new ink, new binding. If you read the books you’ll hopefully find that they have almost the same information, but physically speaking, it’s a new book, with no connection to the old book. This is a similar situation.

Cut it out with the fake news! We get far too much of that from our president!

Also, please be careful – what a scary time! Maybe you are far enough from a city you are not so worried, but I just read that there is a hotspot in the Colorado Rockies, 100 miles from the nearest city. (It is a ski resort, so they do get international travelers, which I assume is a minimal risk in your area.) Anyway, I want you around for a while longer, so please be careful. We are completely locked down here, my wife and I have not left the house in 12 days, we are getting groceries delivered and we clean everything before we bring it in the door (the delivery person drops them on the porch and leaves). And the grocery delivery is spotty, you have to wait days and many items are not available.