Text Editor Procedure Triggering Issues

Triggering a procedure when I exit a text editor object is not working the way I thought it was supposed to. I have a text editor object with these relevant settings:
The object has a database field as its Data
Termination Keys: Return and Tab
Procedure Trigger: End Editing and Tab (Also tried this with only End Editing checked.)

I thought that when I have finished editing and press tab, and the focus ring moves to the next text editor field, that the procedure in text editor procedure would be triggered. But it is not. I also tried adding a finishEditing: label in the procedure; still no response.

Any help or ideas would be appreciated.

This might be caused by a known problem when you also have a .ModifyRecord procedure involved. The subject was discussed a year ago on this forum:

There was subsequently a Bitbucket ticket item entered for it that still remains active:

If there is no .ModifyRecord procedure involved it is a different problem from this.

Looks like Tom has discovered the same problem twice, sorry about that.

I finally realized that I can put the code that I wanted to run in the text editor object in the .modifyrecord procedure instead. A reasonable workaround. I put a comment in the procedure for the text editor object for the benefit of my future self when I wonder what is happening. This way, next year I won’t post the same problem again. Besides, it will be solved by then.

Now I discovered the problem.