Text Editor field selector hides under tools

How do I get to the top of this panel? Specifying the field while it is hiding is awkward. Am I doing something wrong?

I can not duplicate what you are showing but I notice you are also missing the title of the Text Editor Options pane.


Does this persist after closing and reopening the form, closing and reopening the file, closing and reopening of Panorama and is this repeatable in a new form? Possible corruption of the file or your Panorama X install. Just guessing as usual.

I have seen this behavior, but it has been infrequent. I cannot reliably reproduce it but it disappears with a restart of Panorama. I have not reported the behavior given my inability to reproduce it.

Quitting Pano X and reopening it resulted in less of the panel displaying. Same result after restarting Panorama.

The form is from a Pano 6 file that I’ve just imported.
I’m reluctant to start the form over as it has at a minimum 33 popdowns, 82 lookups, 74 radio buttons-check boxes, 64 buttons, 44 text boxes, 14 flash art, etc and has worked wonderfully for 9 years in Pano 6.
Any other ideas?

It gets into that state every now and then, I have not been able to track the problem down. I think the trigger is moving the split between top and bottom panes so that the top pane becomes very small, or hiding it completely. The only solution I know of is to close and then re-open the window, restarting Panorama isn’t necessary (but doing so does close and re-open the window, so not surprising that clears it up).

Hold the phone, Robert’s new post came in as I was typing. I’ve never seen this persist when the window was closed/re-opened. That panel is NOT part of the database, so it makes no sense to me that the problem would stick with a particular database and/or form. If it is, I would very much like to see the file if that is at all possible. If that’s not possible, I would at least like to see a movie that shows the entire height of the window.

I just think that there are a lot of problems with the graphic editor and forms translated from Panorama 6. I get lots of them that come and go, apparently randomly. I try to rebuild the forms, but I cannot always do that. I mentioned one recently that crashed as I was rebuilding it, which I isolated down to selecting too many objects at once. Just selecting, nothing else. Once I realized that, I was able to select and delete them in about four separate selections.

Then I tried reconstructing them, and that has been difficult. I choose Construct>Fields and Variables, choose the fields I want, and Panorama either hangs or crashes, even in a new form.

If I were to take a wild guess, I think it might be a memory problem, and that could be an OS problem combined with a Panorama problem.

This has been nailed down to Text Editor objects, occurring only in the Modify Custom Attributes (7th tool) and instigated by the Properties button above. The short term fix is to Close the form, and then re-open it. That seems to temporarily fix it.
Doing this programmatically though can be a challenge as described in another thread . ;-/