Superalert and Dialog Program Error

I am not able to consistently replicate this problem, but it happens regularly.

I have the following Superalert in a procedure:
SuperAlert lvArRentrak,{title=“Rentrak Report”,buttons=“SEND:60;QUE:60;CANCEL:60”}

(lvArRentrak is the message and it is a defined local variable)

The first time I run it I get a blank alert with correct title but with buttons buttons: Copy Stop Ok.
Pressing any of the buttons will result in “Dialog Program Error - Dialog will be aborted” and the procedure stopping.

But if I run the procedure again, I get the correct Alert and buttons and it works as expected (although the font is not the system font, is that the new normal?). It will then run successfully anytime I run it – until the next time it doesn’t.

The TextDisplayObject used with the superalert statement is set to Monaco as the default. To force it to use the system font you would have to use the font=#SystemFont option. Using a very simple procedure I have not been able to reproduce the anomalies you noted.

Visual aids, if they help.
This was from last night:

I don’t know if this could be causing your problem, but the syntax you are using, with a comma between the options, is not correct. It should be one or more spaces, like this.

SuperAlert  lvArRentrak,{title=“Rentrak Report” buttons=“SEND:60;QUE:60;CANCEL:60”}

However, like Gary, I was unable to duplicate the problem you are reporting. The alert worked correctly for me, whether I had a comma or a space in between the options. If I purposely didn’t define the lvArRentrak variable, then I got a standard error dialog, but not the blank dialog that you are showing.

I’ll correct the syntax and see what happens.

Made the change. The blank Alert comes up and won’t close no matter what buttons I hit. Managed to get to the form and close the file and that made it go away. Second try, it worked fine.

FWIW:I’ve been using this procedure in Pan 6 for several years and never had this problem.

I have found that making a movie of the process that can easily and repeatedly cause an error can be very helpful to others.

I’m lost – what does that mean? What form? What file? How did you “manage to get to it”?

The form that has the button that originally called the procedure. With the Alert window open I couldn’t click on anything else (I tried) and the Alert buttons didn’t work. After turning the Alert full screen (because the button on the drag bar worked for some reason), I couldn’t shrink it back. Was able to get to the finder and then to get back to the original form, which was the only other window open, so closing that took care of the alert.

Martin McCaffery

In that situation (stuck dialog or alert) you should always be able to press the ESC key to close the dialog or alert. That should always work, but if you ever find that even that doesn’t work, you can press fn-ESC.

Am I understanding that now the custom dialog is working ok?

did not have a problem last night, but tonight same symptoms: Blank Alert window, dialog program error, works fine the second time.