Strange Search Behavior in PanX on Sierra (10.12.5)

Let me start with a disclaimer. If everyone was seeing the same thing I am, I expect the forum would be lit up with it. That means that there is probably something peculiar about my system or installation, but I have yet to figure out what.
First, the behavior. I am seeing several things, but I’d like to start simply. I can search and select subsets of records using a procedure all day without trouble. When I try to use the find/select dialog, it always fails. Sometimes it will show the correct selection preview, sometimes not. It doesn’t matter whether it is set to search in all fields or just the current one. Clicking any of the buttons to execute the dialog gives error messages. Most often, clicking find or select results in “Resume statement failed (no Pause).”, while clicking “cancel” results in “Dialog program error–dialog will be aborted.” In no case is the find/select dialog dismissed, or the search executed (the error dialogs do go away). After I fiddle with this for a while, it will either crash hard (no warning, just gone), or I will do a force quit.
I have tried changing the preference settings (and the preference dialog does not seem to be working properly for channels), with no luck. I’ve tried reloading the software. I’ve tried checking the database for corruption by sorting each field (seems to work fine). I’ve tried several different database files, including one that had no Pan 6 imported content, and was very simple.
I do have a relatively new Macbook Pro (Retina, 15-inch, Mid 2015) since about the end of March. The program is installed in the applications folder for the entire machine, not just in the one for my account. I did the most recent security upgrade for Sierra (12.4 to 12.5) a day or so ago. I think I was seeing this before the upgrade, but my memory is a bit hazy, as I am back from a week away.
I am also seeing strange behavior from <== and/or runfieldsideeffects, but that’s another post, unless you think that will be helpful in fixing the search dialog.
I’d love to get this fixed, so I can go back to converting my Pan 6 stuff to Pan X.
Thanks to all for your attention to this and other problems.

As you suspected, this problem seems to be unique to you. Have you tried erasing the Panorama application and downloading a fresh copy? The URL for downloading is not currently public, but you can find it in the original email that was sent to you when you got your invite to the Panorama X Early Access program.

Yes, this is a fresh copy. I downloaded version 0.9 and replaced the previous version (which should have been identical). No difference in behavior.

What about other dialogs, like Sort, Split Field, Merge Adjacent Fields, Morph Field, etc.? Do they work?

BTW, you are right about the problem with the Channels preferences – that is a known issue. That definitely has nothing to do with your Find/Select problem.

Thank you for taking the time to get back to me.
I’ve tried these 4 choices, and will try to move through some others. I get mixed results, hopefully in an interesting and helpful fashion.
Sort and Morph Fields (I only tried the single field version) have the same behavior I described for search/select. The dialog doesn’t dismiss, and button presses give weird error messages. In addition, the morph field dialog is really truncated from what I’m used to: it only allows the starting state, but not any of the modifications. I’ve included a screen grab to show you. The data preview is accurate (this is a very simple 7 record file for testing).

Split field and merge fields seem to work ok. I tried “undo” on merge fields (after I had created another field to merge with), and it worked fine the couple of tries. For both, revert had strange behavior–after split field, it caused a crash, and after merge, it failed to show the reverted file correctly. Saving, closing and reopening the file showed that it was in fact correct, so there’s some display issue there, not a reversion issue.
Hope that’s helpful. I’ll be happy to try other tests.
Thanks again-

Just tried a few more. “Summarize and Analyze” fails as Search does, but hide/show fields is ok, as is Find and Replace. I think that’s pretty much all of the dialog items from the menus.
Thanks again-

Your screen shot shows something I’ve never seen before: adjustment handles on the object you’ve filled with they start-with field name. It’s as if this dialog is coming up in graphics mode. Is that a clue?

@rblatchly Unfortuntately, I still don’t know what is going on with Panorama X on your computer. I do have one idea – maybe the preferences got corrupted? You can manually clear them out completely. To do so, go to ~/Library/Preferences, find the file com.provue.panoramax.plist and throw it in the trash. Then Panorama X will build a brand new copy of this file the next time you launch it. Maybe that will help.

If you don’t have access to the ~/Library folder enabled, you can access it by using the Go>Go To Folder command in the Finder.

That seemed like a very promising idea. Unfortunately, it didn’t change the behavior. I discarded the file twice, emptying the trash the second time out of superstition, and tried both Search and Morph Fields.
I had to log back in the first time I deleted preferences, but not the second.
By the way, in response to Bill Conable, the handles on the text box appear when the error dialog appears (e.g., “Resume Statement…”) but not when it’s gone.
Thanks for thinking of this. I’ll be happy to send crash reports if it’s useful, but I don’t assume it will be.

I know I’m reviving a bit of an old thread, but I wanted to report that I think it’s fixed. The strange behavior had persisted until today, when I got an error message telling me that I didn’t have access to the font Verdana. Surely, I do, I thought, but Fontbook said otherwise. I turned the font back on, resolved duplicates, and suddenly search, morph and all the rest of the useful command builders are working.
I hope I don’t jinx myself, but it’s been quite reliable all day. And, no, I can’t tell you why Verdana was turned off.
The error message came from a dialog I had written for an import routine, not from any of the built in dialogs. I’ll leave it to you to decide whether or not to add this to the routine troubleshooting suggestions, or to add something in the code to prevent trouble in the first place. Given the peculiarities of my situation (it was happening to me, and to no-one else), I had suspected font troubles, but had not gotten down to Verdana yet.
Thanks to all for the help earlier.

I’m glad this is resolved for you, you should find Panorama X much more useful now! I would never in a million years have thought that this might have anything to do with fonts.

However, I am also surprised that these dialogs use Verdana, but I checked, and they do. So I think you are on to something. I’m not sure why these dialogs use Verdana instead of the system font, though they are quite old and I think were written before Panorama X had an official method for accessing the system font.

Thank you for this report. I had a theory as to why a missing font might cause errors, but I just did some tests and it didn’t pan out. So I am puzzled, but I have gone ahead and created a bug report.

I’m really glad this was useful. I have been using Pan X quite a bit, but it’s been tricky at times working around the constraints (still possible). I’ve been enjoying the new features, now that I am beginning to get used to them. I did notice yesterday, when everything started working, how often I reflexively hit command-f…
Thanks again-

You are not the only one!
I started using Panorama X a few days ago and had the same problem.
Thank you for the post. The Veranda font was off in my Fontbook and when I turned it back on the problem was solved!

That’s not good – I have this problem marked down as fixed last October. Can I confirm that you are using the latest version of Panorama X? This happened when using the Find/Select dialog?

I am using Panorama 10.0.01 on a MacBook Pro (Retina, 15-inch, Mid 2015). My “Check for updates” says I am using the latest version. I upgraded from Yosemite to High Sierra (10.13.6) just before using Panorama X. I used command-F and the Find/Select dialog box would come up. When I entered the search criteria, none of the buttons would work including “Cancel" and I had to force-quit the program. After reading the Forum, I found Veranda was marked “off” in my FontBook. Once I turned it on, the program ran fine.

Thanks for this report, I was able to to duplicate this problem and I have re-opened this bug report and added the new information to it.

FYI if anyone runs into a stuck dialog like this, try pressing Function-ESC. That should close any dialog without having to force-quit. When I duplicated this problem, I was able to close the stuck dialog using this technique. Basically Function-ESC works like force-quit for any open dialogs, but leaves the rest of Panorama running normally.

Today is day one with Panorama X for me. I was getting this “Resume statement failed” on my first database in the find/select and sort dialogs. I don’t know how or why, but Font Book had Verdana font (and a couple others) turned off on my iMac. I enabled them and the errors have gone away.

Only had to read five forum threads to find this one. Day two will be better.

Thanks for report this today, I have moved this up to the top of the bug list. Fortunately it appears that this happens very rarely, but it should get fixed somehow.

Thanks for the reply. FTR, I am using the latest version of Panorama X, of course, since I just installed it today, 10.1.2 (2854). Also, I’m using Mojave, 10.14.5.