Split column freezes the Data Sheet

Using a database of 33,788 records, I split the Employee Name field into First Name and Last Name. Employee Name was split after first space with surrounding blanks stripped. Upon clicking Split, no movement - except the active column moved to the right. Scrolling the Data Sheet makes all the data disappear and freezes the Data Sheet - can not close it. All other PanX menus seem to work. Had to quit PanX to get Data Sheet window to close. Upon reopening this same database, the field is split correctly.

Also, in the Split pane, the preview of the first 250 records does not display without data drop out - scrolling the preview list makes some of the records disappear or records are blank.

I have replicated this behavior in the same database and in a database with 25 records, so number of records does not seem to be an issue.

iMac running MacOS 10.10.5.

I can’t duplicate this Tom - for me, It runs almost instantaneously on 50,000 records. It would help if you posted the relevant code. This is what I used:

field «First Name» 
  Fill ""
  formulafill strip(«Employee Name»[1," "])

field «Last Name» 
  fill ""
  formulafill strip(«Employee Name»[" ",-1])

Curious. Why did you do the Fill before the FormulaFill?

On the second one, if you put a ‘-’ at the front of the space that you are looking for, you’ll take into consideration names like “Mary Lou Parker”

FormulaFill strip(«Employee Name»["- ",-1])

Robert Ameeti

The Fill “” is something I often do before a FormulaFill - it demonstrates that the FF is doing what I want. And the output is of no interest to me - I was just testing data to see if I could reproduce Tom’s problem.

Michael, you are using a procedure; Tom is IMHO using the Split tool from the toolbar in the data sheet. I don’t know any reason for Tom’s display glitch, but we should test it under the same conditions.

Yes, you are correct KJM. I am using the Split tool in the toolbar in the Data Sheet. Sorry for the confusion Michael.

I’m just trying to learn how these new PanX tools work. I saw the Split tool demoed in the videos and thought I would give it a try. Obviously my results are different.

The Employee Name field consists of a mix of first and last names with some records having a middle initial or name. I thought I could split off the first name (which eventually worked after the display glitch) and then separate the middle name from the last for those records with a middle name. However, I could not figure out how to do so (using just the Split tool) without separating last name only records from middle and last name records. So, using the Search -> Find/Select menu, I selected only those records with middle and last names. Then tried the Split tool to separate them. When the Split pane appears, the Select condition goes away and all the records are included. So, either you can not use the Split tool on a subset of the database records or this is a problem.

I didn’t even know there was a Split tool - there is so much to learn in PanX and I’m working in a different area. I did a Split using your field names (I wondered if it could have been another two-word field name problem) and it was fine on 50,000 records.

I assume that “(which eventually worked after the display glitch)” means you’ve got it working too but have encountered a different problem. It might be better to start a new post as the issue is no longer one of Split causing a freeze. It makes it easier for subsequent searches.

You cannot use the Split tool on a subset of the database records. If you think about it, that makes sense – just as you cannot insert or delete on a subset of database records. The Split tool works on fields, so it can only work on an entire field.

By the way, the Split tool is not new to Panorama X – Panorama 6 includes the exact same dialog. In both cases it is implemented internally with a procedure. The procedure is similar to what Michael supplied but Panorama automatically generates the procedure based on the dialog settings.

I have to agree with Robert, there is no reason to do a fill “” before doing a formulafill. All that does is waste some time. I guess if you think that the result of the formulafill isn’t going to change the cell values any it does make it obvious that something actually happened, but if the database is large that seems like a high price to pay.

I also rinse the dishes thoroughly before putting them in the dishwasher - this is no doubt symptomatic of some deep-seated psychosis.

I do that also … seriously.

Thinking my copy of PanX was on the blink, I downloaded a new one this afternoon to replace the one that generated the above mentioned freeze problems. Unfortunately, the new copy of PanX produced the exact same freeze problems as before.

So, I created a super simple database of 10 records to see if I could get things to split correctly without freezing. No such luck. Here is a screen shot of the result of an attempted split after the first space:

Yes, this is a new error. After clicking the OK button, the only way to get the Data Sheet to refresh is to close the database and reopen it. When it reopens, it looks like the following:

No, those are not the field names I typed in the Split pane. No, I did not uncheck the right hand side of the Split pane column. No, I do not have any other procedures in this database - you are looking at all there is.

I’m going to let you guys figure this out. I’m going to go rinse the dishes before I put them in the dishwasher - yes, sad but true.

Mein Gott! I’ve uncovered a cabal of closet dish rinsers! How many more of us are out there? Does this warrant a separate forum topic?


You know we’re in the middle of a serious drought right? Jane has had me using paper plates, cups, forks, knives, spoons, etc. for two years now. I don’t even know if the dishwasher still works!

Wanting to start the year off right, I upgraded the OS on my iMac to 10.12.2. I also downloaded the latest version of Pan X - 0.1.029 (2203).

I am happy to report that the behavior I described above regarding the Split tool has now disappeared.

However, I have a new problem to report regarding the Split tool and will report it under a new topic.