Some New Install Errors

Yesterday I installed Pan X on a Mini running Sonoma. Panorama had never run on this machine previously.

I enabled the Instrumentation Panel in Preferences, then attempted to open the Instrumentation Log which lead to an error:

Screenshot 2024-03-08 at 1.30.53 PM

This was due to my failure to also set the Log Path.

Screenshot 2024-03-08 at 1.36.06 PM

. Nothing happened, but numerous menu items remained dimmed. I was able to Quit but when I re-opened the shared database I was advised that the “Database is damaged (data.plist)”. I also found that my account no longer had me logged in.

After replacing the database with a backup and logging in, accessing the Timer Workshop repeated all of that except for logging me out.

1 Like

I think there is something wrong with the Panorama preferences on this computer. Occasionally this seems to happen even on a brand new computer. There is no way to uncorrupt them, but they can be deleted using these steps.

• If it is open, Quit from Panorama X
• Open a new window in the Finder
• Choose “Go To Folder” from the “Go” menu
• Enter ~/Library/Preferences/ and press the “Go” button
• Find the file “com.provue.PanoramaX.plist” and move it to the trash
• Relauch Panorama X (this will automatically create new, default preferences)
• Log into your Panorama account

Actually, if you don’t set the Log Path Panorama should use a default location for the log path. So must likely the log path preference wasn’t empty, but some corrupted value.

Hopefully clearing out the preferences as described above will get this computer working properly.

After deleting the Preferences as described, I enabled the Instrumentation Panel in Preferences, and I deliberately avoided the Instrumentation panel and Log Path.

When I attempted to open the Instrumentation Log I got an expected message: Log Path is not enabled. I clicked on Enable and got this error:

In Pan X Preferences, a valid path is displayed. All I have to do is check the box for Log Path and the issue is resolved.

So, it’s not an issue for me at this point, but hopefully that will help you correct the issue.

And, of course, why should we end it there?

Your prescribed steps allowed me to open the Timer Workshop.

On the same database I was attempting to edit some code for a server variable and the file became corrupted. Subsequent efforts with backups kept corrupting.

On some occasions it again lost the account info and after deleting the plist, I’d start over.

Then I ran into being told my login was invalid due to a wrong user name or password. Repeated attempts met with the same error - and I know I didn’t get it wrong over and over.

I deleted Panorama as well as the plist and re-installed. Still can’t log in.

I erased the drive and re-installed the system, but allowed it to restore my accounts, etc. from Time Machine. Still can’t log in.


I think you should make a fresh new user account. Sounds like there is something really wrong with the one you are using. Before doing anything else you could easily make a new account to check to see if that resolves the problem. If it does, I would get rid of the old user account. I’m sure that would be a lot of trouble, but sometimes that is the least amount of trouble. (Hopefully it’s clear I’m talking about a new user account on your Mac, not a new Panorama X account.)

This is a definite bug, which I was able to correct with the assistance of this error message panel.

I think, however, that this bug has nothing to do with the other problems you are running into.

I tested with my own account and it worked. In this case I’m trying to log on using the client’s account since it’s an encrypted file set tied to their account.

I’ll see how it goes for them.

Ok, that sounds like you are talking about Panorama X accounts, while I am talking about macOS accounts.

I tested with my own account and it worked.

Ok, wait - are you saying that on this problematic Mac mini, you were able to log in to your Panorama X account and it worked, but on the same computer when you tried to log into the client’s Panorama X account it didn’t work? If that is what you are saying I really can’t imagine any reason for that other than that the email address or password was wrong. Could the client have changed the password?

Indeed, a new password had been temporarily installed as several new users were put online and I was unaware of it.