Server is not available

The lone database I use that’s been set up to be shared, Mail Log, suddenly shows “Server is not available…” in the Server pane under Database Options. The server also does not show up in the Server Administration page.

How can I recreate / restart the server and get the shared database back to syncing with this server?

10.2.0.b30 on MacOS 10.14.6

Never mind. All of a sudden, after force quitting from a couple of other programs, it’s back. Weird.

Your server computer may have run out of memory.

Okay, I’ve run into this problem again. I’ve rebooted after closing all apps down, then tried restarting the server from the Panorama X Preferences, and only gotten the message ‘Panorama X Server is stopped’. Clicking ‘Start Server’ starts Panorama X Server, but the particular server file I’ve set up is not loading.

We did have a major power outage, so could the server have been damaged? If so, how do I recreate a new server?

What does “not loading” mean? It doesn’t connect when you open a client copy of the file? It doesn’t show up in Server Administration? Both? Something else?

Does the file still appear in ~/Library/Application Support/Panorama X/Server/Public Databases?

I’ve not heard of a problem like this before, so I don’t have a ready solution.

Yes, ‘not loading’ means that client copies of the database are not connecting to the server.

The file ‘Mail Log.panserverdb’ still exists in ~/Library/Application Support/Panorama X/Server/Public Databases. I’m still getting the message ’ The server “SERP Pan X Server” is not currently available, try again later.’ when I try to connect to the server.

When I try to connect to the server through Preferences, here’s how the process goes (after clicking ‘Start Panorama X Server’):

After that, the ‘Start Panorama X Server’ button is greyed out.

You didn’t answer this question. Actually, now I would like to know if it shows up both on the server itself and on the client computer.

How is your network configured? Are the server and the client on the same local network, or is the server remote somewhere on the internet? If the latter, have you configured the client to access the remote server?

The last of the screen shots shows that Server is not running. It went though the startup process and should have ended with blue text indicating that the server is running.

( I’ve blocked out some version codes on mine that yours won’t have)

If yours has crashed on startup you’d certainly have a failure for databases to connect.

If you temporarily use the Advanced Options in that panel to have the Server show in the Dock, you can see if it’s running, quit, and/or relaunching.

Try running in Safe Mode to see if anything changes.

And consider reinstalling Panorama. In the process be sure to Quit Server so that after the reinstall, it too gets reinstalled when you start it.

Sorry, Jim, I missed that part of your inquiry. No, it does not appear in Server Administration. Server Administration is now blank.

The server and the client are on the same network. Shared databases on both the server computer and the client computer can’t connect to the server.

This was all working a few days ago, and for several months before. As I said, we did have a major power outage, which caused all computers to go down a few days ago.

‘Show Panorama X Server in Dock’ is selected, and the server icon does load in the dock, but with the Preferences/Server screens shown above in this thread.

I’ll try reinstalling Panorama.

Okay, I reinstalled the latest version of Pan X after quitting the server from the dock.

I then tried to restart the server from the Preferences/Server window once I started Panorama again, and the same sequence of events happened as noted above.

  1. Server icon is in dock, so it looks like the server is running.
  2. Preferences window shows server is stopped (after saying that it was starting) [as shown in above sequence].
  3. No servers show under ‘Available Servers’ in Server Administration.
  4. Server name still shows as ‘SERP Pan X Server’ in Preferences/Server window.

Try unchecking the Automatic Relaunch option.

Automatic Relaunch unchecked. No difference.

I did notice one other thing that is weird. When launching a Pan database, I noticed that it was opening in the Pan Server app rather than Panorama I checked the info dialog in the Finder for the database file, and Pan is listed as the default in ‘Open with’. Choosing Panorama and then clicking the ‘Change All…’ button does not work…it returns to Pan as the default.

Maybe unrelated, but still wrong.

FWIW, I had some very different and puzzling issues with Panorama Server that were resolved by running OS X Cocktail. I don’t know specifically what it was that was causing the issues, but they seem to be completely resolved by whatever Cocktail did. Since it’s sounding more like a non-Panorama issue, maybe running a utility to clean up your system would help.

The one other diagnostic thing you could try is to check the Launch Using option. Perhaps there will be a useful message in the console log.

It does sound like possibly the power outage might have damaged your system somehow. You could try @jamescook’s suggestion, or you may even have to re-install macOS (or perhaps create a new user account).

Hmm, one other possibility is that your Panorama preferences may have gotten corrupted somehow. There is no way to uncorrupt them, but they can be deleted using these steps.

• If it is open, Quit from Panorama X
• Open a new window in the Finder
• Choose “Go To Folder” from the “Go” menu
• Enter ~/Library/Preferences/ and press the “Go” button
• Find the file “com.provue.PanoramaX.plist” and move it to the trash
• Relauch Panorama X (this will automatically create new, default preferences)
• Log into your Panorama account

If you’ve set up any options in the Panorama X preferences window, you will need to set them up again.

However, I don’t think corrupted preferences could cause the problem of Panorama X Server launching instead of Panorama X. That indicates a problem with the launch services database, which is all Apple. I know at one time there was a way to force the operating system to rebuild that database. I’m not sure if that is still possible or how to do it if it is possible.

Tried removing ‘com.provue.PanoramaX.plist’ using steps listing by Jim R and then restarting Pan X. Still the same result.

Tried opening with ‘Launch Using’ selected. Here’s the result:

“/Users/jcrunch/Library/Application Support/PanoramaX/Server/PanoramaX”

iMac:~ jcrunch$ “/Users/jcrunch/Library/Application Support/PanoramaX/Server/PanoramaX”

2023-01-02 14:31:05.880 PanoramaX[35151:1194387] Launched with PXRole: Client

I’ve downloaded and installed Cocktail, and am awaiting the Cocktail serial number via email so I can fix System settings, including Launch Services.

That seems like it’s just stopping part way thru the startup process. The log doesn’t indicate that the app crashed or quit, it’s just not finishing the initialization process. It should look something more like this:

Last login: Wed Dec 28 15:01:48 on console
"/Users/jimrea/Library/Application Support/PanoramaX/Server/PanoramaX"
jimrea@Jims-13-M1-MacBook-Pro ~ % "/Users/jimrea/Library/Application Support/PanoramaX/Server/PanoramaX"
2023-01-02 15:09:45.762564-0800 PanoramaX[10780:7323868] Launched with PXRole: Server
[DEBUG] Did open IPv4 listening socket 12
[DEBUG] Did open IPv6 listening socket 13
[INFO] GCDWebServer started on port 8080 and reachable at
Start Panorama X Server

On your system it is running the correct application. That makes sense, because launch services is not involved – Panorama explicitly launches the server app.

Good luck. If that doesn’t work I think you’ll probably have to re-install macOS. Actually, if it was me I would first try setting up a new account on the computer and see if that works. That’s a lot easier than re-installing the operating system.

Please note that the problems that Jim Cook had don’t really match your symptom of the server not launching at all. I’ve never had a report of the server completely failing to launch before.

Okay, I reinstalled the system on my Mac. No difference.

I then created a new user, and brought over the shared DB and the server DB through the shared public folder, and installed the server DB in Library⁩ ▸ ⁨Application Support⁩ ▸ ⁨PanoramaX⁩ ▸ ⁨Server⁩ ▸ ⁨Public Databases⁩, and both the local copy of the db and the other one on the network were able to connect to it. I am still getting weird notices on the client computer about not being able to connect to the provue server (complete with puzzle piece screen) as well as some other messages, even though the computer is connected to the internet. So I’m betting that there is some damage on that computer, as well.

Finally seem to have everything back to normal, more or less. I was able to keep my original user, because I reinstalled everything on my computer from a backup I did before the power outage. (Command-R from restart.)

Everything seems to be working properly now, with Launch Services opening Pan X files with Pan X rather than Pan X Server, and our Pan X server loading properly and updating entries flawlessly, as before.

I just have to redo some of the entries and files that I did in the past week, and I should be okay.

Thanks to all for your help, even after it became apparent that it wasn’t a Panorama problem at all.

I must say that it’s a bit sphincter puckering to say ‘yes’ to ‘Erase hard drive…’ or whatever the wording is before the reinstall starts…

I have sorted out the client computer to this shared database, as well. All that took, I think, was deleting Pan X’s preferences.

Everyone is able to connect again! Halle-freakin’-lujah!