Server Channel missing

In Panorama Classic Server, I choose Preferences > Channels > Apple Mail. Works OK.
But, when Panorama Server is relaunched, the Apple Mail Channel must be manually reselected. How can I make the Apple Mail channel “stick” so it’s active when Pan Server is restarted? Second option may be the a procedure command to re-activate Apple Mail channel.
Thanks. PeterG

In Panorama>Extensions>Channels>Email there should be a small file named Email_Settings.dat which contains the name of your chosen email module. That file is saved when you choose the module in the channel preferences, replacing the existing file if there is one. There may be a permissions issue that is preventing that file from being saved.

You can activate the Apple Mail setting by running: channelswitch "Email","Apple Mail". This will create the Email_Settings.dat file if it does not exist and set it to Apple Mail. If you can not get this file to save due to the permissions problem Dave mentioned, you could put this in your .Initialize procedure.

I agree with Dave and Gary, there must be a permission problem with your Panorama folder. You may want to delete that folder and re-install Panorama.

Or before you do that, see if you can change the permissions for that folder using Get Info… on it. Reinstalling Panorama may require even more fiddling with permissions.

Thanks to all PanGurus for info. Will keep sleuthing.
Permissions and “Email_Settings.dat” looks OK.
Will investigate & try to isolate more with channelswitch “Email”,“Apple Mail”
Procrastinating with a clean re-install.

Still no progress.
On my server, re-installed Panorama & Panorama Enterprise server, etc.
All Permissions mentioned by others above are Read & Write.
From my local Mac, ran this procedure: cgiHTML=CHANNELACTIVEMODULE(“Email”)
Response was “Apple Mail”, which is what I want.

Via browser/webpage, triggered sending an email. Apple Mail successfully sent email; but
then, Panorama Server crashes. Relaunching server & sending emails results with more crashes.

The only way I can stop crashes is to restart Panorama Server. Manually choose Preferences > Channels > Apple Mail.
Panorama Server then sends mail via Apple Mail, but does NOT crash. It works normally with same Panorama procedures.

I’ve also tried: channelswitch “Email”,“Apple Mail” No help
Maybe, I should live with it and wait for PanX Server, which may be only a few days away🤪