SaveAs frustrations

Is there somewhere an embedded Save document preference that I can click off? I can’t make changes to a file, hold down the Option key, select SaveAs, name the new file differently and keep the original file unchanged. Revert to Last Saved Version doesn’t do it either and changing the setting in the General Preference of System Preferences to “Ask to keep changes …” only works if you do not wish to Save any changes. The only way I can do so is to work on a duplicate of the file.

I’m not sure if this will do what you are asking.

  1. Open your database
  2. Select Duplicate from the File menu
  3. Make desired changes to the new copy
  4. Save under new name/path
  5. Close the just saved file
  6. Your original unchanged file is now active

Thank you Gary, that worked well.

The SaveAs command is universally used by practically all applications in a uniform and consistent way, including in Panorama 6, why change it now? There are other menu options in Panorama 6 that takes coding knowledge to reproduce in Panorama X. Other than the composing relational Lookup, I was disappointed not to see them included in the last update. Hopefully soon.

This is a change that Apple made some time ago. It is not exclusive to Panorama.

I don’t understand. I opened a file, made a change, did a save as, clicked on the window of the original file, which had remained open, and it was unchanged. I then closed both files, and found, as I expected, that the original file was unchanged and the saved-as one was changed. Am I missing something? Gary and Bruce are much more Panorama-savvy than I am but…

If macOS executes an auto-save after the changes are made but before Save As is performed, it seems that would cause the situation Orlando experienced. Conversely, if Save As is done before an auto-save, then Bill’s observation would occur. Best approach seems to create the copy then make chances as per Gary’s scheme.

Resurrecting this thread. I find it interesting that if I go to the Help file, I can see the SaveAs command in the Help file and then also over under File in my active file, as it seems to replace Duplicate there. However, I tried to take a screenshot to show this and when I did that SaveAs switched to Duplicate before I could do the screenshot. I could also do a SaveAs if I went from the Help file where SaveAs is shown and slide over to the SaveAs dialog in my active file. Yet, there is no SaveAs if I just go to the active file File menu and click on it to bring up the sub-menu, as only the Duplicate dialog shows. Using the SaveAs prompt does exactly that, saving the active file with a new name that I provide. I thought I would pass this along, not knowing if it is a bug or not. I read in the help files the SaveAs is no longer supported in PanX, but as I said, it does show up and does what it did in Pan 6.

Rather than re-writing a reply to this myself, I found this on the web. Since Panorama handles the File menu exactly according to Apple’s standards, the techniques described on this web page apply perfectly to Panorama.

I don’t see how that could be unless you are pressing the Option key. Or maybe you have some non-standard utility that hacks your File menu. But by default, Panorama is going to show the Duplicate menu unless you have the Option key pressed – that is the official Apple standard.

Putting the Save As back makes me happy…:grinning:
Put I can’t reproduce what you say I shouldn’t have been able to do, since both the Save As and Duplicate are now part of the file. But, be as it may, thanks for pointing out the TidBITS article, which did the trick.

Thanks so much.