Running Panorama 6 Classic on Parallels Desktop

Trying to run Panorama 6 “Classic” on Parallels Desktop. I’ve installed with drag and drop from my HD to the virtual machine and it appears in the virtual machine though will not launch. Has anyone had any success running Classic on Parallels Desktop? I am wondering if doing a fresh install would be better. I don’t have the original installer files though. Is there anyway to download the original installer? Thank you.

If Jim doesn’t have them available anymore, I have the installer for Pan 6. I’ll bet a lot of us do.

Panorama 6 has been discontinued, but the download is still available on this page.

Yes, and it has been working very well.

Jim - Thanks for the feedback on Parallels Desktop. I have not gotten it to work though I have not tried to reinstall from the installer. That is my next step. Any suggestions for getting it to work. With my drag and drop installation Panorama tried to launch though it does not open. Best, Jonathan

Jim Rea - Thanks for the link to the Panorama Classic installer. I will try installing onto the virtual machine running 10.14.6 and will report back if that is successful. Jonathan

Jim - After turning off Gatekeeper I was able to install Panorama 6 on a Parallels Desktop running 10.14.6, unfortuanately I can’t activate Panorama 6, Panorama has a demo code and I am trying to activate with my serial number. So can’t open my existing databases as I get the System -7 error even though I disabled SIP on the VM booting into Recovery Mode on the VM and using Terminal csrutil disable. Thanks for your help.

There may be some other way to handle the System -7 error when trying to activate Panorama 6, but this is how I manage to activate the software everytime without a hitch.

I don’t remember how this method was discovered or who discovered it. I would like to give credit where credit is due, but it was many years ago when this method was brought to my attention.

Once Panorama 6 is successfully installed, the Root account needs to be activated on the system. Here are some screenshots and instructions created from my virtual machine running Panorama 6.

  1. Open System Preferences

  2. Click on Users & Groups

  1. Click the lock in the bottom left corner and unlock with user password

  1. Once unlocked, click on “Login Options” and then click “Join…” next to “Network Account Server:”

  1. A new sub window will appear. Click on “Open Directory Utility…”

  1. A new window will appear. Go through the unlock proceedure. Once the password is typed in you will click on “Modify Configuration”

  1. Now that everything is unlocked you need to enable the “root user”. At the top of your screen click on the Edit menu and click on “Enable Root User”

  1. Now you will create a password for the root account. I always use “root” as the password to keep things simple. Click “OK” once you have entered in a password of your choosing

  1. Now it is time to log out of the current user account

  1. You are brought to the login screen and you will see a new account appear called “Other…”

  1. Click on the “Other…” account. Type “root” as the username and the password is the root user password that you created in step 8. Once you have entered this information, proceed to login

  1. You will eventually make it to the desktop of the root user account. Once you do, open a new finder window. Navigate to the “Applications” folder and find and open the “Panorama” folder

  1. Now start panorama and go through the registration process on the root user account. Enter in your serial number and you should now be able to activate Panorama without any issue.

  2. Once activation is successful, you can log off of the root user account and back into your user account. You can also follow steps 1 throuh 7 and disable the root user account, which is what I recommend.

I hope this helps and is clear enough to get Panoram 6 activated on your computer.

In the past I have had some success of activating Panorama 6 by adding my user account with read/write disk permissions. For some reason this no longer works with me as I always get the error “The operation can’t be completed because you don’t have the necessary permission.” when trying to add my account to the Sharing & Permissions secion of the drive.

Good luck!

Thanks very much for this suggestion. While I was able to follow this and get past the System -7 error when trying to activate Panorama 6, I can’t open my existing database files. The files aren’t recognized as Panorama files, and even if I set Panorama as the application with Get Info they still don’t open. Panorama opens the dialog to create a file. Any further suggestions would be appreciated. I am going to post the same question to Jim Cook above since he developed these database files.


Though I’ve been able to get Panorama installed in Parallels I can’t open my existing InView database files. The files aren’t recognized as Panorama files, and even if I set Panorama as the application with Get Info they still don’t open. Panorama opens the dialog to create a new database. If try and open them with File Open the files are just grayed out. Any suggestions would be appreciated. Thanks!

The inability to open files with with files that I had drag copied to the virtual machine desktop. As it turns out I can open the files across the virtual network!

The files I was trying to open had been drag copied to the virtual machine, though I just discovered I can open the files across the network from the virtual machine which is great. Any other suggestions on how best to set this up would be appreciated. Thanks!

In Parallels, launch Panorama 6 and from the Wizards>Utilities menu choose Platform Converter. Drag ONLY the Panorama databases onto the panel labeled for Fix Type/Creator Codes. That will restore the attributes that Catalina removed.

Do not include text or resource files.

Leave Convert & Open unchecked for easier handling of multiple files.

Hello Jim -

Many thanks for that direction on how to fix Type/Creator Codes. Though this situation might be different as the real machine still is running Mojave, as is the virtual machine. Now from the Parallels VM, most of the time I can open InView files across the network, though if I drag copy the files to the virtual machine’s desktop and Fix Type/Creator Codes they will open once but not subsequently. I get an error that the HS Resources files is missing though it is there in the folder and I did fix its Type/Creator Codes. See the screen shots below. I am setting this up so that I can upgrade the actual machine to Catalina, though this has given me pause. Once I upgrade the actual machine to Catalina would you expect that I would be able to continue to open the InView files across the network? Is there a recommended way to open the files from the Parallels VM?

(Incidentally, just to be sure there was no issue with my first VM, I created a new one from scratch and installed Panorama on that VM, first turning off Gatekeeper and I fixed the “System -7” error using the brilliant directions HLJman, Jason James Wadsworth provided above. And the copy of Parallels is licensed, not running in trial mode.)

I know you have a Contacts file that works with Panorama X I need to give that a try too. Any news on possible development of a Worksheet, Receivables and Equipment file?

Thanks again for your help!



The HS Resources is one of the files that is not a Panorama database. It should not have been converted so you should retrieve a copy.

It all runs fine on Parallels with Catalina.

Along with the Contacts, I’ve posted an image catalogue. I do have a rough equipment database running and in time might offer it too. Beyond that I have no plans. I’m building what I need and sharing it if it reaches a point that it’s got an adequate interface.