Propagate not working?

I have one database where Propagate refuses to work, either by direct command from the menu or in a procedure. I have tried changing the field type from text to numeric. Neither will work. If i create a new empty database and try it there, it works fine. The problem database was created by importing a csv text file but I can’t imagine why that should make a difference. Any ideas?

Some additional data, if I add summary records, and then try it again, it will fill the summary record but nothing in between.
So say 5 lines. First line, Field Reference has a value of 101
lines 2-5 Reference is blank
Add a summary record and do a Propagate on Reference. Summary record now shows 101 but the lines in between are blank.

I suspect that the cells you think are empty are not really empty. They probably contain spaces or perhaps even invisible characters.

I thought about that and tried cutting whatever contents were in the cell and trying again but no luck. However since writing the above, I discovered that PropagateUp works as expected!

Could there be a hidden summary record? One of the recent changes was that propagate doesn’t propagate a value beyond the next summary record.

I can duplicate your symptoms with a hidden summary, but without any summaries it works properly for me.

Try removing all summaries, and see what happens.