Problems installing Panorama 6 on macOS 10.12.5?

Over the past week or so, we’ve received three reports of users unable to install Panorama 6 on a macOS 10.12.5 system even after disabling Gatekeeper as described here:

It’s possible that these users didn’t disable Gatekeeper properly, but I’m beginning to suspect that Apple has made a change and that disabling Gatekeeper no longer turns off Gatekeeper Path Randomization, in which case Panorama 6 can’t be installed. If anyone on this list has tried to install Panorama 6 on macOS 10.12.5 (it definitely works on 10.12.4 and earlier), I’d be interested in your results, whether positive or negative.

Good news – I just heard from a user that was able to successfully disable Gatekeeper and install Panorama 6 on his macOS 10.12.5 computer. So I guess it was a false alarm.

I read and followed the instructions at the link provided in your post above but I still get an error when trying to install Panorama 6 on MacOS 10.12.2. Then I read another post that this must be installed using Panorama X first? I’m a little confused. I’m a total newbie, so I apologize for asking any stupid questions :slight_smile:

At one point for a few weeks we did think that the only way to install Panorama 6 was thru a special installer we built into Panorama X, but that turned out not to be the case.

Most likely the reason you are running into this problem is because you are using macOS 10.12.2. That version of macOS had a bug which prevented Panorama 6 from working properly at all. You will need to upgrade macOS to a 10.12.3 or later.

1 Like

I’m not having luck getting Pan 6 up and running on a new iMac running 10.12.6.
I migrated Panorma along with scores of other apps and files from previous computer but I get a error dialog saying "lib failed… Extensions:Libraries:_PanoramaLib"
Trying to reinstall from ProVue’s website generates the same error just trying to install.

That sounds like Gatekeeper. To disable it you need to follow the instructions at the link Jim gave above.

To bypass this problem and install Panorama 6 on a new macOS Sierra computer, you must disable the Gatekeeper feature. To do this, start by opening (in the /Applications/Utilities folder). Then type in the following command:

sudo spctl --master-disable

You’ll be asked for your computer’s administrator password. Once you’ve entered it, Gatekeeper will be disabled and you can run the Panorama 6 installer.

After Panorama 6 is installed, you can turn Gatekeeper back on if you want. To do that, again use but with this command:

sudo spctl --master-enable

Thanks, but that doesn’t seem to be the problem.
After disabling GateKeeper, I get the same error dialog just trying to run the installer.

J.T. Devine

You need to run the installer from the disk image. If you drag it to your hard drive, and then try to run it from there, you will get that error even without Gatekeeper.

Thank you again-

I have run from the installer. Evidently just running the first time before disabling GateKeeper somehow prevented subsequent tries.
What worked was trashing everything, disabling GateKeeper re-downloading from ProVue’s site then installing.
J.T. Devine

I needed to move Panorama 6 from one old computer to a new computer running macOS Mohave 10.14

First disable Gatekeeper…
Open Terminal. Type: sudo spctl --master disable
Press Enter. Enter Password. Press Enter. Restart.
Disable System Integrity Protection (SIP) with a wired keyboard…

  • Click the  symbol in the Menu bar.
  • Click Restart…
  • Hold down Command-R to reboot into Recovery Mode.
  • Click Utilities .
  • Select Terminal .
  • Type csrutil disable .
  • Press Return or Enter on your keyboard.
  • Click the  symbol in the Menu bar.
  • Click Restart…
    Do a Get Info on the primary hard drive. Unlock the permissions. Change the Privileges of ‘everyone’ to Read & Write. Apply to enclosed items…
    Install Panorama. Complete the SN registration.
    Give Panorama ‘Full Disk Access’ in the Privacy tab of the Security & Privacy System Preferences panel.

The link above needs to be updated so that a 404 error does not occur.

Done. I updated in my post, and Jim’s as well.