Possible openmapwindow Viewing Issue

Hello Pan X enthusiasts!

My openmapwindow function yields the following.

Then a second later, the map display goes black.

If I copy the URL of the map window, and pastes into Safari, the map shows up just fine.

Why might the black screen be appearing, and how might I fix it?

Thank you!

I don’t know. It works just fine on my system, macOS 11.6.

OK. FYI, this issue showed up while using macOS 12.3.1.

This is what I get in 12.4…

Does not go black at any point.

Thank you. Since this is working for you, I upgraded to 12.4. Unfortunately, after the upgrade, the problem persists.

Also, I tried changing the settings in Google Maps, resizing the window, and signing into Gmail. None had any positive effect.

Try putting this url directly in your browser to see if it works there:


This is the url produced by the example address you used. If it doesn’t work in your browser then there is a problem outside of Panorama.

Thanks. The link works in my browser (Safari).

The only other thing to test that I can think of is to create a new form with a large Web Browser Object on it. Set the Options panel Mode option to Formula and enter the previous url in quotes into the Formula pane and hit Apply. It should show the map even in graphics mode as shown here:

This pretty much is what is happening using the openmapwindow statement.

Thank you. The following is my result.

I am seeing the same black window section (in b25 on macOS 12.4). The black part of the screen is fully functional, but darkened. I am getting a warning that Google Maps has no access to (the Mac’s) location services, and I find no way to grant Panorama X or its Web Browser object access to the Location Services. I have granted the access in Safari as well as in Chrome, but keep getting the warning in Panorama X.

B26 on OS 12.4 I was able to get the map and leave it open for over 24 hours without any issues. I haven’t made any recent adjustments in Location Services.

Ok, I have been able to duplicate the problem but only on my M1 iMac 12.4 using Panorama X b24 or b25. Using the limited release b26 works perfectly and the Location Services settings make no difference. On my old MacBook Pro under Catalina I can not duplicate the black partial browser window (but I have not tried it under b26 on this machine).

1 Like

Thank you. I played around with the location settings, but was unable to effect any change. I am using a M1 Mac mini.

Sounds like this operator is working in B26. I look forward to testing B26, when it becomes widely available.

I’m experiencing the same issue on my Mac. The issue seems to be a “permissions” problem, but not sure if the problem is with Panorama or with Google, and am at a loss to know where to track down the offending “permissions” setting. BTW, am using an intel based MacBook Pro using OS 12.4 if that helps.

Just installed the latest PanoramaX update, and now the Map function seems to be working properly. The one comment I received when I used the mapurl function in a form was, “Now you are just showing off!” Thanks for working so hard on squashing those pesky bugs.

1 Like

Works for me too! Haha, that’s a great comment.

Thank you Jim!