Popup Menu Button Inconsistency

I have a set of popup menu buttons that all behave differently in spite of being configured identically.

Each is set to use a variable as the data with a formula. The formula is built via listchoices( so my expectation was that each button would be blank when a selection is made since it’s constructed on the fly per: “if the new value is not one of the available choices in menu.” That would be fine, but oddly I get three behaviors. One results in the blank I expected, one stays on a choice no matter what else is chosen, the third switches to the choice which is really nice and would be quite satisfactory.

Movie at: https://youtu.be/cMk_HNCStIU

I tried, and failed, to duplicate this behavior. It worked fine for me.

Looking at your movie, it sure looks like some code is executing after the mouse is released and is switching the value. But from what you’ve shown, I don’t know what it is.

You mentioned you “detached” it from the procedure. I though maybe there was a bug where after removing all code maybe it invisibly remained, but I tried that and it worked fine. So I am stumped.

I’d probably need to run this code under the debugger to see what is going on.

I’d have sent in an example file but now I can’t make it fail. Previously the error survived restarts, but somewhere along the line it corrected itself. Maybe with the latest update??

Maybe. When I was unable to confirm your results, I was using the latest update already.