Parameter referencing a field problem in Version 0.1.026 (2068)

Version 0.1.026 (2068) has caused some of my procedures, which worked fine in Version 0.1.025 (2012), to fail. The problem has to do with parameters that contain a field name. For example, in the following line, parameter(1), 'SpentBy" is the name of a field in my database.

call pickName,SpentBy,“George”

The pickName procedure it calls has this line

select parameter(1) = parameter(2)

Which in this case I want it to select all the records in the field SpentBy that are equal to the name “George”. In the previous version of Panorama X it would select all the records where George was responsible for the spending. In Version 0.1.026 (2068) the selection fails.

Is this a bug in the latest version of Panorama X? If not, how do I use a field name in a parameter?

It was a bug in the previous version. A parameter is supposed to pass a value. The value could be a dictionary or array, but it is still one value. To do what you want to do, you should be able to use

call pickName, "SpentBy", "George"

and then the pickName procedure would be

select datavalue(parameter(1)) = parameter(2)

You could also do it using Execute

Thank you, Dave! Your code worked.

Thanks Dave, you beat me to it! :slight_smile: