PanX10.2 bombs at attempt to add a field

I have been fighting problems all day with Panorama quitting unexpectedly. I have narrowed it down to one file that might be corrupted. For a while I could not open the file. I was finally able to open the file with a procedure from another file using:

OpenSecret “FileName”
SetActiveDatabase “FileName”

Once I got it opened I saved the file and created a new generation on the server. Most recently I needed to add a field to the file, so I detached and removed the file from the server. I can open the file as a single user, but I cannot add a field. Panorama bombs at every attempt to add or insert a new field. Any ideas? Much thanks.

I will reply to my own post. After much first aid (copying the file, deleting all data, removing anything strange from the .Initialize procedure), I have been able to get the file to work. I can insert and add fields without a crash. My fingers are still crossed, but it seems to be working. I may have sounded a false alarm.

For future reference, you don’t need to write a procedure to do this. The Special Operations Menu in the Find & Open dialog already has this feature built in – just use Open Data Sheet Only.

I thought there had been some talk of this. Not sure what the resolution was, but today with the latest Pan beta I tried to insert a field. App froze, so I had to force quit. I do have 5 hidden fields, which has been a problem in the past, but I am unwilling to reset stuff to do a standard function. So I tried to add a field. Froze again. Force quit. So then I duplicated a field near where I wanted the new one. I’ve learned not to try to reorder fields some years ago. THAT worked. It actually put the dupe where the original was and the copy nearby, but I adapted to that and modified the fields to get where I wanted. What am I doing wrong?

How many records and fields are in your database?

How long did you wait before you did a force quit?

If there are a lot of records and/or fields, inserting a record could take a while. Possibly you didn’t wait long enough.

On the other hand, when you duplicate a field Panorama actually runs a procedure that inserts a field as part of the code. So if duplicate works, insert field has to also work. Here is the code from the DUPLICATE statement, you can see that insertfield is the 5th line.

local fname,ftype,fproperties
getfieldproperties "","",fproperties
fieldname dfname
insertfield fname
setfieldproperties fproperties
formulafill datavalue(dfname+"")
if info("selected") < info("records")
    showcolumns fname

Thanks, Jim. I’ll wait longer next time. Not sure how long I waited. There are about 55 fields and 800+ records.

55 fields and 800 records isn’t that many. It shouldn’t take more than a 2-3 seconds, if that. I have no idea why you are experiencing freezes, there are no other reports of that.