PanX loses its credentials when I quit

With Sonoma 14.4 and PanX ver. b37 (4442), whenever I quit PanoramaX (or it crashes), my credentials are lost and I have to re-enter the Site License information. I have turned off the Database Integrity option; I thought that would avoid a problem with this configuration. Alas, no.
At least I can now remember my password and don’t need to look it up.

Have we determined how widespread this is?

I’m not feeling the need to follow others down a hole.

Have other on this list successfully updated to Sonoma 14.4?

I would not speak of big issues of Pan X under Sonoma 14.4, but I have occasionally seen:

  1. Panorama seemingly stuck and not opening auxiliary databases → Force Quit
  2. Panorama showing a distorted Login window → Force Quit
  3. Panorama opening with empty credentials, demanding a login

I have been encountering several annoying problems with Panorama X 10.2.0 b37 (4442) and Sonoma 14.4. I am always getting an error notice coming up when using the Panorama Help pages telling me UpdateActiveHelpPage does not exist. I am also getting my procedure errors being shown as coming from several lines of code previous to where the actual error exists. One time I had all the procedure text simply disappear and not being able to retrieve it with an undo or Command-z. I kind of feel I’m walking on egg shells while working in this environment.

I think Apple has introduced a bunch of new bugs in 14.4 and hope they come out with a fix shortly or an easy way to go back to the previous version. :face_vomiting:

1 Like

Much appreciation to all for sharing.

FYI I would be beyond shocked if the Database Integrity option had any effect on the Site License information - two sections of code that have absolutely nothing to do with each other.

There do seem to be widespread reports of problems across a variety of programs.

I don’t know about easy but it is possible to go back to a previous version of macOS (unlike iOS).

12 days ago Jim Cook started a thread about losing his credentials after installing Sonoma 14.4. By the time the thread ended, you suggested turning off Database Integrity. In the meantime other Sonoma related issues had been raised. But I thought the original issue might be avoided by turning off Database Integrity. Anyway, now I am protected from problems that I haven’t even encountered. Fortunately, this is the only time I can recall where installing an OS update has caused problems with Panorama.

Some of the threads here have more oxbows than the Mississippi River! :rofl:

Turning off Database Integrity resolved several issues on Sonoma 14.4. It did nothing about the registration. On my three active Macs, I now anticipate re-entering my registration at least a few times per day.

This has been less of an issue in recent versions of the OS, but have you tried Disk First Aid?

I just installed Sonoma 14.4.1 - on just one cpu - and it appears that the credentials issue is fixed. I’ve done my best to aggravate the situation and my registration is retained on each launch.

A bit more info… Running Sonoma 14.4.1 with Database Integrity re-enabled, files that I saved with Sonoma 14.4 won’t open due to a claim they’re corrupted. Turning Database Integrity off I was able to open and save the files on 14.4.1. Then with Database Integrity re-enabled the files are opening and running properly.

It seems that with this Sonoma update, Apple has resolved the issues.


One more update… After running Panorama on all three computers all day, two had no further issues with my registration or false claims that files were corrupted.

One the third machine, I’m running a large file set of shared files. It was fine unless I ran a New Generation. As often happens, the uploads fail to complete about half the time. When they do it sometimes crashes the server and it may require a Force Quit on my end. In those instances I was required to enter the registration info and the file was claimed to be corrupted. Turning Database Integrity off on that machine eliminated the corrupted file messages but I still had stalls and lost my registration info when doing updates.

I kind of suspected that might happened, but I had a brain freeze and couldn’t figure out how to put that into words. :man_shrugging:

1 Like

I’m experiencing troubles after updating to 14.4.1

I get this:

And if I turn OFF integrity checks, the database and all auxiliaries open no problem and everything operates as I expect.

Now, I experienced a weird issue when I was applying the MacOS update to 14.4.1 – I usually, and today was no different, let the system updater restart the computer and click the button “Reopen applications…” so that all the million things I usually have open come back and life goes on. HOWEVER, I noticed that “Panorama X interrupted restart” so I went to Panorama and it had a bunch of grayed out menu items – no dialogs or modals that I could find. So I went one by one and closed the databases that were open, and Panorama finally quit, then system update restarted.

When I opened Panorama X after restart, it was logged out and acted like I never had logged in before (!) I’ve never had to log back in to Panorama on this computer … but I had to today, and then I go to open my latest magnum opus, and Panorama X is complaining with the error above… :frowning:

Panorama X is version

It’s running on an M3 Max.

Since the restart (after updating from 14.4 → 14.4.1), I’m now encountering this issue described above…

Fortunately, turning off integrity checks in Panorama has worked but this isn’t good!

Welcome to Sonoma 14.4

I originally asked how does one get back to normal because it looked from my experience that 14.4.1 caused this, but …

UPDATE: I tried it – opened Panorama X, it had me logged in so that problem sorted yesterday and has stayed normal (app stays logged in across quits). I opened preferences and turned on database integrity. I was able to open all the same databases and no problem today. The only thing that is different is time. So, it sorted itself ? … that’s even stranger to me(!) but, the good news is that it looks like database integrity is checking out the way Panorama X expects it to now that over a day has passed since the issue appeared.

Update 2: I did have one database persisting to fail integrity checks. I opened it without integrity checks, then, while that database was open, turned integrity checks on, saved the database. Now, it opens fine again with integrity checks turned on. So, it looks like all the others sorted themselves out, but this one database did not and needed that extra step? That’s even stranger to me – what would make one different than the others?

FYI, your data has been perfectly fine all along. When the integrity check feature is enabled, Panorama saves an additional “seal” as part of the file that contains a checksum of the database contents. When re-opening the file, Panorama checks to make sure that the checksum matches the contents of the file. If there was a problem with your disk drive, the contents wouldn’t match.

I don’t really understand what the bug in 14.4 was, but it was apparently causing the seal itself to be corrupted. In other words, the data was fine, but the seal was corrupted, so you get the error message.

Since the seal inside the database is now corrupted, it will still be corrupted after you upgrade to 14.4.1. So you still get the error message. But if you disable integrity checks, open the database, then save the database - now it has no seal. So once you turn integrity checks back on again, it will open because there is no corrupted seal. The next time you save it, a valid seal will be included, so the problem is fixed.

You can also manually remove the seal from a database. In the Finder, right click on the database, then choose Show Package Contents. You’ll see an item called integrity.plist, that is the seal.

If you drag the integrity.plist file into the trash, you’ll then be able to open the “corrupted” database even if the database integrity feature is turned on.

You may wonder why you can open a database with a missing seal. If Panorama X couldn’t do that, it wouldn’t be able to open databases saved from Panorama 10.0, 10.1, or early versions of 10.2. Remember, the integrity seal is a new feature, less than 2 years old. Before that, everyone was essentially running with the database integrity option turned off all the time - because that option didn’t exist yet. The database integrity feature was created so that if there is a problem with your computer’s file storage that causes file corruption, you’ll know about it right away. Before the integrity feature existed, you might not notice a corrupted file right away, and inadvertently cause even further damage. However, modern computers have very reliable file storage. As far as I know, no one has encountered any file storage corruption since this feature was implemented. So maybe this feature wasn’t worth doing. But at some point, this may save some user a lot of trouble. Unfortunately, right now thank’s to Apple’s bug, it’s causing additional trouble, not less.


Update: With 14.4.1 installed and PanX 10.2.0.b34 (4442), I have noticed some additional things that might be of interest to one trying to understand the cause.

After shutting down my computer, if I start PanX by trying to open a database, my usual method of starting, I get this screen, which forces me to quit.

If I start PanX by double clicking on the PanX icon, I get a different screen, which forces me to click LogOff button and then re-enter my credentials. Form here I can log off and then re-enter my credentials normally. A better failure mode than the first one.

It sounds like you are seeing the same logon screen problems reported by KJM 8 days ago. But with screen shots, which is nice.

I wonder if deleting the Panorama preferences might help, using these steps:

• If it is open, Quit from Panorama X
• Open a new window in the Finder
• Choose “Go To Folder” from the “Go” menu
• Enter ~/Library/Preferences/ and press the “Go” button
• Find the file “com.provue.PanoramaX.plist” and move it to the trash
• Relauch Panorama X (this will automatically create new, default preferences)
• Log into your Panorama account

If you’ve set up any options in the Panorama X preferences window, you will need to set them up again.