Panorama X quits, database completely blank, records seem to be lost

The only recent change is an update from Apple Monday. I usually ignore the messages, but did the update. was it iTunes?

Now Panorama won’t open, if it does, it quits almost immediately, and my databases are being wiped out.

Font issue? I checked for Verdana, and it is installed and open on my iMac.

Mac OS High Sierra 10.13.6
Yes, re-started

Do I need to install Mojave? I hate things in black, so I have avoided it. The dust shows. :slight_smile:

Can anyone help? I did try to re-download Panorama X, and am having similar issues. Can’t get the original database to open. Don’t want to try it with any others.

Thank you in advance for your help,

Eileen Parr
PARRKEES Keeshonden

This is particular to your system. Have you tried restarting your computer, and the usual repair procedures: Checking the disk, starting in Safe mode, etc.? Do you have a Time Machine backup?

Yes, I did restart. Did not try safe mode. No Time Machine back-up. :frowning:


Thank you, Bruce. PanoramaX is not opening in a proper manner. Even the second download.

Hey, fonts are always my issue, as I use many. It may be that. I am also always in a time crunch, too. I am so missing Panorama 6 and its stability.


Oh, I forgot to do a check of the disk. That is next. Thanks, again.

Try the hardware check, too. I just had a problem, and it turned out to be a bad SSD.

But by all means, get a backup plan! Time Machine works reasonably well.

Okay, thank you Bruce!

This is what I did today, with a much fresher mind, and after running Disk Utility on my hard drive. Still have to connect the external hard drive and do a Time Machine back-up. Yes, I will do that later today, before I do anything else major.

I started up my husband’s MacBook Air (he passed, so I haven’t accessed it much in the past two years).

I was able to connect it to my iMac via our network and already had Panorama X installed. I pulled the database file from my iMac to the MacBook and voila! it opened when I accessed Data Sheet, so all isn’t lost.

I did try the file first on the iMac today, and what opens is just a blank procedure window. (the procedure is to do a running total). Choosing Data Sheet adds another blank window.

The only thing I did differently two days ago was to install the recent iTunes update. Is there any way to uninstall it?

Thank you for your help. Is there anyone on this forum who provides Panorama X user lessons, that could be with my files and my needs in mind? Though I am a long time user, I am not a programmer. My needs for Panorama are a simple database in which each year I add entries in each file for a specialty (one breed) dog shows. This information is then re-formatted and exported to a QuarkXpress file of the catalog that is printed and used at the dog show. The Panorama file is also used for the data information regarding the dogs . . . name, AKC number, birthdate, breeder, owner, address, etc. and classes entered. Simple, but it has worked for me for almost 40 years. Overvue/Panorama is an integral step in the process. I will have to retire if I can’t make this work in Panorama X.

Thanks again,

Eileen Parr

I doubt that iTunes is the problem, although there might have been some issue with installing it.

Try making another User in Users & Groups, and seeing if Panorama opens there. If it works okay, then you know it is something in your User identity.

If it does open there, go back to your regular identity, and look in your Library. If you are in the Finder, hold the Option key and choose the menu Go, and the Library will show up. Inside will be the Preferences folder, com.provue.PanoramaX.plist. Throw that in the trash and try opening Panorama X again.

If it does not, you may need to reinstall the system software. Or you might install Mojave. Dark mode is an option which you do not need to choose. Personally, I think keeping the system up to date is a good thing to do.

Eileen Parr, here. Update. I did the Time Machine back-up yesterday. I am probably one of the worst. Having been a Mac user since 1984, I have been truly spoiled without the headaches professed by my friends who are Windows users. I do forget that once in a while, disaster can happen. My Macs (and there have been many, probably close to 20) have been single user machines. No kids, no bumbling friends, etc., and I do think that has been part of my success to have no true Mac failure. It is usually something like my issue here.

Today I downloaded Mojave. I guess I was avoiding it because I live in the Mojave Desert, and didn’t think I needed any more sand.

Then I copied the file from my husband’s MacBook Air to the iMac. I trashed Panorama X and re-installed it, after dumping the preferences, several times. The Panorama X original file on my iMac does not work. The one on my husband’s MacBook Air does load. So, you tell me, what happened to the file on the iMac? I live in the Mojave. Guess what? Lots of wind. Perhaps that is the issue. I will proceed cautiously with my other files, and duplicate them before I work on them for the time being.

Thank you again, Bruce. Your suggestions were very helpful, and I actually did do a new system install . . . didn’t I? Now to get rid of the sand on my desktop!!

Eileen Parr