Panorama X 10.2.0 b4 Build 3252 Released

This version must be manually downloaded and installed (as I expect for all beta downloads for the forseeable future). Here is the link.

The changes in this release are:

  • The Panorama client now always disconnects a database from server when it closes. In the previous version, this did not work if the database was secret (no visible windows), or when closing the database via a procedure instead of the close box.

  • The ∂QuitUsage timer is now invisible in the Timer Workshop unless locked timers are enabled.

  • The Left/Center/Right button in the Text panel (form properties) is no longer cut off on macOS 10.14 and later.

Note: I am not going to put changes between incremental releases (like those listed above) into the Release Notes in the documentation, since these won’t be of any concern to users that never see the beta versions. These notes will only be published here on the forum. If there is a change that will be noticeable for non beta users, I will add it both here on the forum and in the documentation Release Notes, however, I am planning on putting all 10.2 changes on a single Release Notes page, no matter what beta release they are added to.

(I’ve corrected that condensed topic summary, obviously the one above is wrong, but for some reason the forum software isn’t grabbing the updated version. Probably a caching issue.)

I tested both: closing with a procedure (not including a dropserver statement), and quitting while there is a secret file open. The first part works correctly, but the secret file is still not disconnecting from the server, and causing connection problems going forward with the server. I tried three times with the same result. One must stop and start the server to clear the problem; at least, that is the only solution I have found.

In addition, quitting Panorama (Menu item Quit or Command-Q) does not disconnect databases from the server.


I definitely tested that multiple times, and it worked every time. Can you think of any additional details about what you are doing that might help me diagnose this?

I forgot to test whether it dropped the connection when quitting. Oh boy, that is going to be a mess to work on :frowning:

I think the secret file issue is that I am quitting while secret files are still open. So it’s just a subset of the quitting issue.

Ok, good. I’m working on that now.