Panorama Server

When sharing to Panorama X Server the database uploads to the server but remains locked. When looking at server admin the database does not show in the Databases tab. Thoughts?

I’ve not heard of this problem before. Is this a particular database or any database you try to upload? Are there databases already on the server that are working?

There are no databases on the server and I have tried an existing database and created a new one both exhibited the same result.

Have you looked in the Public Databases folder on the server to see if the files were actually loaded to it. Do you possibly have multiple copies of Panorama installed on the server?

What about a second server? I’ve found it very easy to upload to the wrong server if I’m not attentive enough.

I tried sharing again the new database, same result. I then went on the server computer, i only have one, and no database is in the Public Databases folder. I also checked if more than one copy is installed and I only have one. So I went into the logs folder and grabbed today “Daily Sharing.log” file and this is what it contained.

11/23/2023 3:26:08 pm Steve’s MacBook Pro:Steve Middleton UPLOAD FILE ERROR: FileAppend error: You don’t have permission to save the file “” in the folder “TempTransfer”.
11/23/2023 3:26:08 pm Session 4 (Steve’s MacBook Pro:Steve Middleton) OPEN SHARED DATABASE ERROR: Database “new_db.panserverdb” does not exist.

So it appears I have a permissions issue which is weird because I have not changed anything on my server computer, at least not that I can remember. I checked all folder permissions and everything looks appropriate.

When I create a new db on the server computer and then share it, it works. When I do it from my laptop over the network, it still behaves as described and generates a permissions error on the server and logs that error in the log file. Not sure what to do.

I don’t understand how it could work differently depending on what computer is used as the client. The server couldn’t care less what client is being used. This makes me wonder if you are really connected to the same server.

In any case, the server is obviously not going to work if necessary folders have permission errors. This must be corrected. Probably the easiest approach would be to quit the server, delete the TempTransfer folder, then relaunch the server. It should recreate the folder. This folder is inside the ~/Library/Application Support folder.

CleanShot 2023-11-27 at 18.39.59@2x

You may need to delete the enclosing folders also. Alternately, you can try to use Get Info or to fix the broken permissions.

Did you migrate this computer from another computer? Sometimes that can cause permissions problem - usually the computer incorrectly thinks the folder or file is owned by a user on the previous computer. The Migration Assistant is supposed to fix up this sort of problem, but sometimes it doesn’t.

Thank you Jim, I tried your suggestions, still the same result. Im going to try a complete clean install of MacOS then reinstall Panorama. There is only one machine that is the server and when I get info on all the folders in the ~/Library/Application Support folder for Panorama everything looks correct. Ill let you know how it works out.

So I think I solved the problem but it seems weird to me. I will attempt to explain. I have a mac mini that I have been using for Panorama X server for several years. I have the admin account and an user account with admin privileges. I originally installed Server in the user account. I cant remember the MacOs system version that I originally used but it was not updated until a week or so ago. When the problem started is when I update the MacOS software to version 14.1.1 (23B81). Even though all folder permission looked correct it did what I described above. The solution was to log into the Admin account and launch Panorama X Server. Now it works. All server files are still stored in the user account though. Maybe that is expected.

I’m glad you got it working. macOS can definitely get tricky when you are using multiple accounts.

How did you decided it “looked correct”? It sounds like the folder belonged to a different folder than the one you were running. Maybe the OS updater changed the folder owner for some reason (which I think would be a bug)? In that case you could use Get Info to change it so that Everyone is allowed to read and write.

If you ever had problems again in the future, I would consider deleting all of the Panorama folders inside the Application Support folder and then letting Panorama re-create them. You would either have to re-upload your server databases, or save the contents of the Public Databases folder and then put them back afterwards.

Well thats a good question, maybe I interpreted it incorrectly. I did get info on the folders. But, only the user account had read and right the rest were read only. I should of changed the permissions to Everyone is allowed to read and write?

Thank you Jim

Well, usually having just the user account have read and right is ok. But the question is, what is the account that owns the folder? If you set the permissions to Everyone is allowed, then it doesn’t matter who the owner is. So in your situation that seems like the simplest solution.