Panorama database web serving is currently disabled for maintenance

“Panorama database web serving is currently disabled for maintenance. Please try again later.”

Huh? Is this a self induced problem or is this a message from the Enterprise server that I just haven’t seen before? My database pages are not displaying but my Panorama Enterprise Web Publishing Status page says that web publishing is currently active and it lists my 7 web databases, etc.

This message appears when you try to access a database that has been taken offline. See page 73 of the Panorama Enterprise Handbook PDF to learn how databases are switched on/offline using the Server Admin Wizard. It can also happen if you start a New Sharing Generation but never finish it, see page 119. Note that the dialog shown on top of page 121 indicates that the first step in a new generation is “Taken offline.” It’s automatically brought back online when you complete the new generation, but if that was never completed, you would see this symptom. In that case I think you can just use the Server Admin wizard to put it back online again.

Nope. The file is online. It works fine for Local Database Sharing, and Internet Database Sharing. The Web Publishing checkbox is there in the Sharing Options.

I tried doing a New Sharing Generation. No Change. I tried restarting Enterprise. No Change.

Another idea?

I’m sorry, I tried to answer from memory. So now I searched for this exact message in the source code, and found out it occurs if web serving is turned off on the server end. This is the option described on page 56 of the Panorama Server Handbook, in the section Enabling Database Web Publishing.

When I look at the Server Activity Monitor on the server, it shows the Web Publishing? column to have a ‘yes’ in that column. And wouldn’t the Server Status web page require web publishing to be working to have itself be displayed? As I think I noted, that Server Status page with the header Panorama Enterprise Web Publishing Status does state ‘Panorama Enterprise Server web publishing is currently active’ and as noted, it has to be active to display this page (in my mind at least.)

I can click on any of the Database(s) in the listed table and each of them will then display the yellow background showing records, fields, and procedures, etc.

I don’t know what to tell you. There is only one occurrence of that text in Panorama’s source code, and it is triggered when there is a no in that column.


Maybe double or triple check the URL you are using, make sure it is directed to the correct server? I’m sure you’ll say it is, but an incorrect URL is the only explanation I can think of at this point. Did this just start happening out of the blue for no apparent reason?

And the answer was…

DNS pointing to the wrong Enterprise server.

Sorry for wasting your time Jim sleuthing this one out but I am sure that it would have taken me a long time to figure it out on my own. Thanks.

Wow, that’s a sneaky one. Glad you figured it out.