Panorama Classic won't install under macOS 10.13.4 Beta (17E139j)

I was going to fire up P6 and steal data from some of my old databases to give my new PX database a workout, but when I tried to re-install P6, I got an error message:

lib failed! 05D5CAD6-CABF-4F0E-8D94-D#2:d:Extensions:Libraries:_PanoramaLib

Multiple times… PX is working just fine, though.

That’s what Gatekeeper Path Randomization looks like. Read the instructions at

for information on how to temporarily disable it.

A computer at my former office failed and the user has a new computer. They were not able to transfer files, so I want to do a new Installation of Panorama 6; OS is 10.13.6. I used Terminal to disable Gatekeeper, but when I try to install Pan 6 I also get a similar message 'lib failed! A2…:d:Extensions:Libraries:_PanoramaLib. I am way over my head here; any ideas about how to get Panorama 6 working?

You have to disable SIP as well as Gatekeeper. Also, make sure the HD is set to Read and Write for Everyone.

If there is another computer at the office that has Panorama 6, you could copy its Panorama folder to a flash drive and then drag it into the Applications folder of the new computer. Then you would register it on the new computer. As long as you aren’t downloading from the internet, there shouldn’t be a problem.

This FAQ page includes the techniques needed to get Panorama 6 running on High Sierra.

The procedure described on the website worked to get Pan 6 installed on a new machine with High Sierra. Thanks Jim for putting all of that together. I used a copy of PanX to install Pan6 in spite of Gatekeeper (rather than the terminal).