Panorama 6 Enterprise Server Save As - Can't Rename On Server


We’re using Enterprise Server 6 and I’m trying to copy an existing database using “Save As”. When I do, changing the name from 2019 to 2020, and then try to use the Database Sharing Options to “Choose the name of the this database on the server,” it says it’s still called 2019. When I set it to 2020 and click update, it instantly reverts to 2019 and pops up the confirmation screen indicating the “new” name will be 2019.

I’m missing something obvious, I’m sure, but if anyone can point me in the right direction, that would be brilliant.


I’m not sure I follow what the steps are that you are taking, but it sounds like your goal is to rename the of a database on the server. That is not possible. Once a database is uploaded to the server, the name is fixed and cannot ever be changed. If you think about it, it has to be this way. If one client renamed the database, none of the other clients would know how to find that database on the server any more, since they would still be trying to use the old name.

The only way you can do this is to switch the database to single user, delete it from the server, and then re-upload it to the server. When you upload you can pick any name you want.

Note that you can rename a database on a client, either using Save As or simply by renaming it on the Finder. The name of the database on the client doesn’t have to match the name on the server. Panorama keeps track of the name on the server independently from the name on the client.

By the way, the upcoming Panorama X Server will handle this situation the exact same way, for the same reasons.

All that makes perfect sense, thanks!

I currently have a database called 2019 on the server. I just want to copy it, call it 2020, delete all the 2019 data and have it reside on the server so I can start entering the 2020 data.

Do I just Save As 2020 on the client and then copy 2020 to the server and put it in the Server Databases folder or upload it to the server and then delete all the old 2019 data that is in the copy of 2019 called 2020?

Not sure what the best way to do it is. I did spend an hour looking through the docs, but ran out of time. Apologies if it’s already detailed there.

Thanks much for your help!

On the Client computer open a copy of the 2019 database. (Working with a copy leaves your original 2019 database as it was and still fully able to connect to the 2019 server database) Open the Database Sharing Options wizard and from the Maintenance menu choose Force to Single User. Choose the copy of the 2019 database and it will be cleared of all connections to the server.

With it now in single user mode you can clear the data, rename it if necessary and make any other changes offline. When done, use the Database Sharing Options wizard to create an entirely new server copy and you now have your 2020 shared database working.

1 Like

The technique described by @JamesCook will work. Another method would be to make a copy in the Finder, rename it, then open the copy. Then open the Database Sharing Options wizard and simply switch it to single user. When doing it this way, you shouldn’t need to use the Force to Single User method. Then clear the data, make any other changes you want, and upload under the new name.

This technique isn’t any better than the one @JamesCook suggested, and achieves the same result. But it avoids the need to use the somewhat obscure Force to Single User command.

1 Like

Thanks, @JamesCook and @admin that helps a lot and solves my problem. I really appreciate your responses and time. :+1:

As I work to convert some more shared databases from Panorama 6, I was interested in this method that I’ve apparently overlooked all along. I can’t find it.

It’s actually called “Force to Single User” under the maintenance menu.

Never mind. I just saw Jim’s message below which said it replaces the “Force to Single User”. The only other two ways I know of are creating a new sharing generation or just unchecking the sharing modes and clicking apply.

I was just referring to unchecking the Local Database Sharing and Internet Database Sharing boxes in the Database Sharing Options wizard, then pressing Apply Changes. I’m not sure, is that the question you are asking?

Apparently it is. I was looking for a Switch to Single User choice somewhere.