Pan X compatible with macOS Monterey 12.6

Ok, I just tried opening a data sheet of a large db and found the last few records would not display either scrolling or using the down arrow. I tried using showpage as well as showother «»,99 and that did nothing. As reported, resizing the window let it work again but if it is closed and reopened it will not scroll all the way down once more. A procedure I ran to add one point makes it work as well:

zoomwindowrectangle rectangletweak(info("windowrectangle"), "+bottom", 1)

I’m using Monterey 12.6. For what it is worth, my db has 4703 records selected and 4700 could be scrolled. That means three records were inaccessible which is about the same size as the toolbar. Maybe a clue?

Turns out that is not consistent and will vary depending upon the height of the window. What I did find however, is if the width of the window is not beyond the last field it scrolls ok when first opened. If the width is beyond the width of the last field it will not scroll all the way when opened. Don’t know if that is true for the others but it is what I’m finding with my test database.

Note: I also notice that in my case if I have the datasheet open to a height of 710 points or higher it will scroll properly. Under that and it starts truncating records at bottom.

None of that applies for me with a database of 12070 records and 32 fields (Panorama X 10.2.0 b29; MacOS 12.6). I have no problems scrolling to the first or last record, using either the vertical scroll bar or home/end keys, at whatever size the datasheet window is opened, whether all records or a subset are selected

I’m using an iMac with an M1 chip. Don’t know if that is important or not.

Thank you everyone for this rather confusing information. Certainly seems like a probable new Apple bug, but I don’t even know how to report it at this point.

I guess it’s good to know this isn’t happening universally, though it probably makes it harder to track down.

Ok, here’s a random thing to try:

size 13

Note that this statement will only work in a data sheet window, so if you try this in .Initialize you’ll need to make sure the data sheet is open and active.

Why try the size statement? I believe it is triggering the same internal code as resizing the window. (Though as I noted earlier, this code is already triggered when the data sheet window opens, so ???).

Sorry, I should have added: MacBook Pro with M1 Max.

Showpage with or without Wait made no difference.

Size 13 seems to overcome it.