Notes forgetting notes

When I put a Note in the field properties, then leave the field and come back, the Notes are gone. It doesn’t make any difference if I Save from the file menu after putting the notes in.

I tried to search BitBucket, but it looks like it took me on a journey to set up my own account.

I just tried to duplicate this problem and I couldn’t. Notes were persistent whether I clicked on another field, or even closed and reopened the database.

I made a ScreenFlow file but don’t see how to include it - I’ll mail it to you in a separate email. It shows putting “test” in notes, then clicking into another field and back to notes - test is gone. Then I put test in again, move to the choices tab and back to notes. test is still there. And when I go to the next field and back, test is still there. I erase test, go the the next field and back. test is still there. I do have that PopClip loaded, it will show up once or twice as I highlight to delete.

Okay, now I know how to save a ScreenFlow to .mp4 format. But it still doesn’t show up in the upload choices. How did Dave attact that animation on resizing the Formula Workshop box?

Ok, this is a fairly serious bug, I’m amazed it has never been noticed before. It doesn’t just apply to notes, but to any field property. Here’s how to reproduce the problem:

  1. In the data sheet, open the properties panel.
  2. Click on a property and edit it (Notes, Formula, Input Range, whatever)
  3. Click on the COLUMN TITLE of a different field (not on a data cell).
  4. Now click back to the original field, the changes made to the property will be lost.

In step 3, if you click on a cell in the data sheet instead of the title, the property change will stick, even if you click in a different column. So for now, if you change any field property, be sure that the first place you click is in the body of the data sheet, not in a column title.

This wasn’t in Bitbucket before, but it is now.

I vaguely remember some changes that I tried to make which failed to take hold until I pressed Enter.

Glad it will be solved. My workflow was to go from field title to field title, setting their properties. No need to click into a cell at that time.

You can still do that right now, just click on a cell rather than on the field title. You don’t have to click into the cell, just click once on it.

I don’t usually announce here when a specific bug has been fixed but I’m going to make an exception for this one. This bug is now fixed, so once the next version is released this won’t be a problem any more.