Not connecting to PanoramaX server

I’ve been using PanoramaX for a couple of years now on my laptop, as well as on a couple of computers in the office. It still seems to be working fine on the office computers (as noted in my recent usage statements) but, having just gotten the following window, I see that my laptop copy isn’t communicating with your servers.
Once that window pops up, none of the buttons (Check Network, Quit, or Later) work. I also can’t drag puzzle pieces. The only thing I can do is Force Quit PanoramaX.
When I open it again and check my Site License, it shows me (locally) as logged in, but anything that I try to do gives the message that there is a server error.
I am connected to the internet. I’ve restarted the computer. With this I can’t do anything now.

This means that something is blocking Panorama from connecting to If you have normal internet access, then there is some sort of firewall blocking Panorama. For example Little Snitch or Hands Off could do that, there are several other firewall programs available. If you don’t have an outbound firewall program installed then there is some sort of malware on your system that is blocking Panorama, or your router or ISP is blocking connections (since other computers are not affected these last two possibilities are quite unlikely, only a program on the actual computer can block internet access to specific programs).

There is nothing on the Panorama end that can be done to restore the connection. There is no magic setting to get around this – if Panorama is blocked from the internet, it’s blocked. Whatever the source of that block is must be removed to allow Panorama to continue working.

This is the second report I’ve received like this in the past month, after no reports of this ever before. So I am wondering if there is some new malware going around that blocks internet connections.

After reading this, I tried bringing up my site license window, and I also got server errors. Using a web browser object, I found that it would display, but it would not display When I tried entering into Safari’s address bar I got this

It wasn’t actually Provue’s certificate that had expired, but rather that of the certifying authority.

Chrome uses a different root certifying authority, and I had no difficulty viewing it there.

If, in Safari, I chose to view it anyway, that choice apparently applied to Panorama as well, because I was then able to successfully bring up the site license dialog.

What version of macOS are you using? In older versions (before 10.14? 10.13?) internet access in all applications would track Safari (shared cookies, etc.) In more recent versions, individual apps each have their own separate internet environment, and that trick won’t work.

I am not seeing the same issues with the Comodo certificate. It is working fine here on Safari, Chrome and an iPad, and showing an expiration date in 2038 (in Safari and Chrome, I couldn’t figure out how to view the certificate on the iPad).

I think certificate problems could possibly cause the problem Robert is reporting. However, if the certificate actually expired at the end of May, I would think that all Panorama users would be experiencing this problem for the last month, and that no one would have been able to purchase Panorama subscriptions for the past month. Perhaps there is an intermittent problem? But for Panorama to report that it cannot connect to the internet, the problem has to persist for 16 hours of Panorama usage, which is usually several days for most users. If there is even one successful connection, the clock resets.

Still, this definitely merits further investigation. Comodo is not a free SSL service, we are paying so there should never be any problem with the service. I will definitely be contacting them Monday morning to see if they can shed any light on this. Also in the future perhaps a preference can be added to enable non-secure connection to Thank you Dave for this idea, the thought of an SSL error never even occurred to me.

When I look at the certificate in Safari (or Chrome), I see something different:

I don’t see anything about the AddTrust External CA Root. Looking at Dave’s screenshot, it appears that AddTrust is what has expired, not Comodo. I’ve never heard of AddTrust, so I did a search. Lo and behold, this immediately turns up a bunch of pages talking about this certificate being used on “older devices” and causing all sorts of problems because it expired on May 31.

Ok, here are some links I found. It looks like macOS 10;11 qualifies as an “older device”. It sounds like the problem may also occur if you have a newer version of macOS but are not using the latest Safari. If possible, update Safari. If not possible, it looks like the only solution is to override the security as Dave suggested, telling Safari to trust the AddTrust certificate even though it is expired.

I’ve been considering dropping support for OS X 10.9, 10.10, and 10.11. Looks like that decision has been made for me.

This Mac is running 10.11.6

I do believe you all are probably on to something. My laptop is one of the Mid 2009 17" Macbook Pros, so I haven’t been able to upgrade to the newer operating systems. The OS I’m currently using is 10.11.6. (Maybe this issue will force me to give up on my wonderful 17" laptop screen and get a newer laptop!)

use dos dudes os patchers,
you can run later os’es on the 2009

I just got this same dialog today, when I went to use Pan X. I used it all day yesterday with no problem, so…? Other apps are accessing the internet just fine. Older Mac, so 10.11.6. I will mess around a bit, see if I can get around it. (I really need to continue my work on Pan X!)

If your operating system is 10.11.6, it means that your Mac just went past 16 hours of use since this problem began. If you use Safari and try to go to you will probably get this dialog

If you click the link I circled, you will be giving it permission to trust Provue’s certificate, and as a side effect, Panorama will trust it as well, and it will be able to connect.

It isn’t actually Provue’s certificate that expired. It’s the certification authority.

1 Like

Thanks, Dave. It also prompted me for my Mac password, as I guess this is a change to my settings (to always trust ProVue from now on?). Glad to have sidestepped this Sunday surprise.
BTW, the dialog threw an error when I clicked to “Check Connection”. One more click, a different error message, and it closed. Came right back, though. :wink:

I also tried Dave’s suggestion, and my Panorama X seems to be working fine now.

Many thanks to this amazing group of people who collectively provide an unparalled level of support!