No windows or dialogs in panx

after restarting my computer this morning, i launched panx by clicking an alias for a db i always have open because it has hundreds of procedures in it that many other dbs need to call. panorama was working earlier today.

although panx has launched (i know this because it’s icon is visible in the opt-cmd-escape window) it doesn’t have any visible windows.

i can cause it to become the active application by double clicking an icon for one of its files. if i then do an open menu cmd, i don’t get a dialog. usually i get no result at all. the most i get is a sort of a ghostly transparent area circumscribing a white area.

i tried restoring panx from a time machine backup. that didn’t help.
i’d like to reinstall it, and i’m sure i have an installer, but its archived and i am pretty helpless to discover what disk it’s on without panorama.

i’m running os 10.15.7 on a 2019 mac pro.

Go to and click on “Pricing” in the top menu bar and you will see a download link for the latest 10.1.2 (2854) version.

thanks gary.

i downloaded a new copy of panx and installed it.

the first time i launched it, it opened an empty untitled database.
it also displayed a normal dialog after an open menu command, but that was it. it wouldn’t open another file. it won’t even open it’s about window.
when i tried an open command again, all i got was a white box.

Sam, I think this has nothing to do with Panorama X, but with your Mac and its OS. Something does not work there as it should. I am thinking of the system databases that are responsible to know which application can open which type of documents.
First Aid: Simply restart your Mac.
If that still does not help, use an utility like OnyX to rebuild the Launch Services Database and the XPC Cache.

i’ve restarted a couple of times. no help. i’ll see if i can find OnyX.
i will say, however, that panx is the only application that has trouble opening a window.

Your Panorama preferences may have gotten corrupted somehow? There is no way to uncorrupt them, but they can be deleted using these steps.

• If it is open, Quit from Panorama X
• Open a new window in the Finder
• Choose “Go To Folder” from the “Go” menu
• Enter ~/Library/Preferences/ and press the “Go” button
• Find the file “com.provue.PanoramaX.plist” and move it to the trash
• Relauch Panorama X (this will automatically create new, default preferences)
• Log into your Panorama account

If you’ve set up any options in the Panorama X preferences window, you will need to set them up again.

You can also simply click on Download Trial at the top of the page. The “trial” software is the same as the “real” software.

here’s what i’ve done:
-installed a new os: 11.1
-ran the appropriate version of OnyX
Launch Services Database and the XPC Cache were checked
-deleted /users/sam/library/preferences/com.provue.panoramax.plist
-reinstalled panx, v. 10.1.2
-launched panx
-logged on to panx > logged on as administrator
-file menu > open > normal dialog appears
-navigate to a db called p.pandb
-nothing opened; menus stopped working

any ideas?

First of all, I’ve never heard of anything remotely like this.

Does the Panorama menu appear in the upper left hand corner? If yes, what happens if you choose About Panorama from that menu? If that works, how about the Memory Usage window, also in that menu?

What does “menus stopped working” mean? Did the menus disappear? Do they appear but nothing happens when you choose one?

Apparently at some point the File menu was working. If it works again (perhaps after relaunching Panorama), what happens if you create a new database with New>New Empty Database?

I’m trying to understand if you have a general problem or if something is wrong with p.pandb.

From a fresh Open of Panorama X, have you tried creating a new db? Then opening another different db other than p.pandb?

admin: Does the Panorama menu appear in the upper left hand corner?
answer: yes

admin: what happens if you choose About Panorama from that menu?
answer: nothing

admin: What does “menus stopped working” mean?
answer: you click the menu and nothing pulls down.

admin: Apparently at some point the File menu was working . . .
answer: the typical pattern is that the file menu works once.
i could do new > empty database and get an empty database. then nothing worked. same story with ‘new database from text file’. pan would open the text file as a database, then nothing would work.

admin: I’m trying to understand if you have a general problem or if something is wrong with p.pandb
answer: that (finally) occurred to me as well. i retrieved a time machine backup of p.pandb from last night, before this nightmare started, and replaced it. i replaced again, deleted the preferences file again, launched panx open p.pandb and SO FAR SO GOOD!

i’d like to thank everyone for their kind attention and input. and, jim, i hope i’ve given you an interesting problem to mull over.